Jump to content

Change Mode

Pages won't load in IE, activeX not supported


Recommended Posts

I've been testing here for 5 years I think. Haven't been here in a while. Now I cannot load any page on your site on IE except the main one. I have no problems loading all pages on the site on Firefox. When I try to load the page for the full tests, it tries forever and doesn't load. I have no problems at other sites on IE although I seldom use IE but I went to other sites after the problem here to make sure IE was working correctly everywhere else. Any page I try to load from the main page will not load on IE.

 

I have IE settings as you recommend. This problem is happening on my virtual pc which runs XP Pro Sp1a. The virtual PC is running under VMWare 2005. I exited my KIS 2006 beta as that is very buggy but that made no difference.

 

On my host box, I can load all your pages on IE but I can't do any tests. When I try the ActiveX test it tells me that ActiveX is not supported! This is on IE6 on XP Pro SP1a. What the heck does that mean? Of course ActiveX is supported on IE! How could the test tell me that??? On my host box I have your site in the trusted zone so I wouldn't have to lower my security in internet zone. I have no software firewall on the host box and no AV as my Bit Defender just expired earlier today and I haven't acquired the new version yet. I do run behind a router but has nothing to do whatever is causing the strange problems on IE on both boxes.

 

Again, on my host box, like on my virtual box, I have no trouble using Firefox at your site.

 

Both boxes are fully updated with MS patches. Maybe the cumlative IE patch (896727) screwed something up? I just installed that earlier tonight on the virtual box and a few days ago on my host box.

Link to post
Share on other sites

Hi Melelina,

 

It appears that you do have an ActiveX problem. As the Pit test uses ActiveX & is primarily set up for IE, Firefox will sometime work with the Neptune Plugin.

 

I too, run XP with SP1a & have found from experience that if you start making changes to IE settings after you update at WU, a lot of problems can occur. Needless to say, there are quite a few proposed fixes for this problem & some only make it worse. ;)

 

I can offer a couple you can try, if you wish.

 

(1) Go to Start/Search & Type iuctl.dll and iuengine.dll, and then click Search. If these files are found in your C:\Windows\System32\Dllcache folder, delete them.

 

If these files are found in any folder other than C:\Windows\System32, delete them.

 

After you have deleted all other copies of these files, delete them from the C:\Windows\System32 folder.

 

Should you be prompted to insert the Windows XP installation CD-ROM, click Cancel.

Note You will download newer versions of the files from the Windows Update Web Site.

 

(2) ActiveX Possible Fix

 

The easiest way to get to your ActiveX settings is to Open Internet Explorer, click on the Tools tab, click on Internet Options, click on the Security tab, and then click on the Custom Level button. You will see several options for different settings; go down the list and make the appropriate changes, for example:

 

Use this as a guide to set your own (If you Enable all the options, you are leaving your system open to unwanted intrusions.):

Download signed ActiveX controls -- Prompt

Download unsigned ActiveX controls -- Disable

Initialize and script ActiveX controls not marked as safe -- Disable

Run ActiveX controls and plug-ins -- Enable

Script ActiveX controls marked safe for scripting -- Enable

 

The more of these you have Disabled, the safer your system is, but there will be sites that you can't access. Prompting is the next best thing, but constantly clicking OK can be tedious and you usually don't know whether it should be allowed or not. The described combination works best for me, but not be best for you -- it is just shown as a reference.

 

Also, disable you host file & try it without it.

 

Let us know how you get along please.

 

Regards,

 

Hawk :beer:

Link to post
Share on other sites

Thank you for the suggestions. I don't use WU. That is the first thing I turn off onan XP machine. That and automatic updates, auto updating. On my host box, I download and install all updates from MS download site. On the virtual PC which I have had about a month, and which needed 34 patches after I installed the OS, I just got those all tonight from WindizUpdate site.

 

I don't understand what the WU Control Engine has to do with ActiveX control here. I do have those files on both computers. Really old ...from WU version 4. I don't want newer versions. I would not go to WU to install them. I would use the XP CD. I will not allow MS to install the nasty validation tool on any of my boxes. My XP Pro is a valid OEM copy but MS has no business asking me for a store receipt years later and in essence accusing me of being a thief and I have to prove I am not. I feel very strongly about this. I applied the hack that I found for Fx so it can get all MS offerings at MS download site without any prompt for validation. Then I found WindizUpdate site which is great and I don't need WU at all now. Great tech support from Windiz also. I've been talking to the developer all day by email.

 

I have those settings already in IE on both computers that you show.

 

I don't have a host file on either box.

 

I've only had the virtual pc set up for about a month so it shouldn't have any problems at your site due to to many changes made in IE, etc. It has never visited WU. It could be the cumulative IE update I installed a few hours ago though that screwed it up. I can more easily see that my host computer which has been running without any reformat for 22 months might have problems due to changes to IE, etc. The last time I tested at your site on the host box was about maybe 4-5 months ago and it was fine then.

 

I decided to try again before I posted this. My host box (the one saying ActiveX was not supported) worked fine once I remembered to bypass the Proxomitron. I hadn't been here for a while and had forgotten about that.

 

I still can't get any pages except the main one to load on the virtual pc. I bypassed Proxo there too and it didn't help. I suspended KIS and even exited and that didn't help. But the more I think about it, I bet this is KIS. I'm going over to the the Kaspersky beta forum and ask if anyone is having a problem here. KIS appears to run even when totally exited. It is extremely buggy...wrecks havoc with Outlook Express and I can't navigate on the KAV forum site or Wilders Security. Other sites have been ok...but now yours won't load...I bet the problem is KIS. I'll let you know what I find out. One reason I installed it on this virtual box is because it is so buggy...I wouldn't put it on my host box! Kaspersky has promised us a new build this week probably Fri (this build is a month old) and that might fix it.

Link to post
Share on other sites

Well Melelina, I think I'll pass this along to Dave (Administrator) who looks after the Pit test. He may be able to offer you more advice. :)

 

My experience with ActiveX has not been enjoyable to say the least. The way I install ActiveX is to go to ALL the Sites that use ActiveX & d/l the utility before I add any patches or hotfixes from WU, when I do a format & clean install. It appears that once the utilities are installed, all works as it should.

 

I also found that by changing IE settings, it would make the problem worse, especially with SP2, which I run from time to time.

 

The "Validation Tool" is a fairly new feature at WU & I think it is just the way M$ elimates illegal copies. I have never had any problem with the tool as I just d/l it & then I am directed back to the WU d/l page. I do NOT use Automatic Updates either. :P

 

Regards,

 

Hawk :beer:

Link to post
Share on other sites

Melelina, it sounds like you have a few possible culprits including KIS. When you say that you can't get ANY page to load except the home page, do you really mean that you can't start the tests process? For example, can you load a set of someone elses results through a TechExpress link, or can you go to a FAQ page? In other words, do any of these load?

 

http://www.pcpitstop.com/faq/default.asp

 

http://www.pcpitstop.com/spycheck/

 

http://www.pcpitstop.com/

 

http://www.pcpitstop.com/testax.asp

 

http://www.pcpitstop.com/about/default.asp

Link to post
Share on other sites

I was able to load the first of those pages and quickly. None of the others would load. They show a loading bar in the status bar and the bar gets larger VERY, VERY slowly and the page never loads. Eventually (after maybe 5 minutes) it says "done" in the status bar but the page is still trying to load and all I see is a blank white page.

 

After trying to load all the others, I went back and tried the first link again that did load and it now will not load. I then tried to click on reply, using IE, to post this message. The message board had loaded on IE a few minutes ago just fine and quickly. When I tried to click on reply though, it would not load and give me a reply box. It did the same thing the links do. Shows a loading bar in IE that gets larger very, very slowly like I am on the slowest dial up in the world instead of a cable connection at 5Ms down and I just see a blank white page and nothing ever loads. I finally have to resort to "stop loading this page" button. So, I am typing this from Firefox.

 

I did notice that even the first link you gave, that did load the first time I tried, and all the links that never load the page all show in the status bar "uinknown zone". Why would that be? My home site of dslreports still loads fast on IE after all the trouble trying to load those links of yours. I notice that dslreports says "internet zone" in the status bar.

 

I bypassed Proxo to try and load your links but that makes no difference. I could understand KIS interfering with the tests themselves (I would suspend or exit before running the tests), but it shouldn't cause a page to not load at all. It is not popping up the web antivirus module to block your links so I don't think it mistakenly thinks there are trojans on your pages or anything. Actually, totally exiting KIS I think is impossible. Some services don't run when it is exited but the real time scanner runs underneath everything. I'd have to uninstall it I think to get it to totally not run. It has produced problems on some web pages..but your site would be the first that it interferes with the loading of pages if it is the culprit.

 

I have noticed before I tried to do the tests here, that IE would become very sluggish on a variety of pages, even dslreports, after I used it a bit. I seldom use IE. Use it mainly for speed tests that require java applets (I dislikeSun Java and still use MSJVM) or Flash. I didn't think too much about it since I seldom use it. But it has some problems with slowing down shortly after opening and using. I recall now that it wouldn't load dslreports pages a couple of days ago after I had no problems loading Speakeasy speed tests and running them. So, it is something that happens after IE has been open for a bit. Your site seems to be the worse though because if I come to pcpitstop.com on a freshly opened IE, that will load quickly. Then anything I click on that page won't load. Then if I try Dslreportsi it will load quickly, but if I surf around dslr for awhile, then it gets very sluggish at loading and then finally won't load at all. I know it is not a problem with my connection because through all this Fx loads every page very fast with KIS running.

 

Maybe I need to post about this also in the Microsoft Help forum at dslreports now that I remember IE getting sluggish at loading pages at other sites than yours after I have used it bit.

Link to post
Share on other sites

I think you need to disable everything except stock Microsoft stuff and try it then. Proxo's whole job in life is to mangle web page source code, if it's running then all bets are off.

Link to post
Share on other sites
Guest tjw003

I'd love to know if this gets resolved. I'm having exactly the same problem, and it started after I did the windows update for that latest cumulative security pack. I'm running XP SP1a as well.

Link to post
Share on other sites

I doubt seriously that it is Proxo. I was only using Scott's ancient default filters. I didn't have Sidki's on. I know Dave that you don't like Proxo. I recall years ago you saying a similar thing to me when I had a problem here and was using Proxo. I've used Proxo over three years and before that Ad/subtract (which is built on licensed Proxo code). I just tested my host box at PCPitstop last night with Proxo running throughout the tests. No problems except your site seems to think Proxo, Process Guard and a few other applications I have that are outstanding applications are suspect applications. That is pretty hilarious to accuse Process Guard, which is the only application known that can protect against root kits and protects completely against trojans, etc. of being suspect. :(

 

I also beg to differ with your assessment that Proxo lives to rip up web pages. The Remove It Permanently Fx extension far better fits your description. I just ripped a whole bunch of irritating stuff off your main site permanently with RIP. It is fantastic! Everyone I know who has gotten it is addicted immediately and there is a central location where you can post your rips for others to use. Now that is something I can see a web site author being irritated by but Proxo? Proxo makes the web a heck of a lot safer and that is very important these days.

 

I think tjw003 could be right. This all started AFTER I installed 34 security fixes on the virtual box. The only one that would not install well was the IE Cumlative one. I'm going to uninstall it or use system restore and go back before any of them were installed. The other possiblility I think is KIS 2006 beta. We are getting a new build later this week so after I uninstall the current one and before I install the new build, I will come to PCPitstop on IE and see what happens.

 

My host box has the IE cumlative update and IE works ok and that is also on XP Pro SP1a. That still doesn't rule out this as the problem on the virtual machine partly because I upgraded the virtual machine to SP2 and had a bunch of problems (why I don't upgrade the host box) and downgraded to SP1 again. Who knows what that did if the downgrade didn't completely downgrade and then I installed a cumulative update for IE? EEK...

Link to post
Share on other sites

Solved!

 

I cannot believe I just spent a couple of hours going back to every snapshot I have taken of this virtual machine so I could see where the IE problem first began. Problem appeared to be in every snapshot which I concluded meant that this install of XP Pro SP1a must have been a bad install. In the process of going back to the snapshots, I found that I never bothered to set IE to use Proxomitron! :D I never use IE except for speed tests on my host box because I use MSJVM not Sun Java. I never installed MSJVM on this virtual pc so the only time I used IE was to go download Firefox the day I set up this virtual pc back on July 29. So, I was trying to navigate your site without Proxo in the picture. I wondered why I saw a bunch of Google ads but I thought that was because I just had the old default filters.

 

Anyhow, the problem was NOT Proxo, which wasn't even being used for IE internet connection, the problem was NOT KIS 2006 beta, the problem was that PCPitstop had not been placed in the trusted zone!!! GEEZ! I had IE security options for the internet zone set just as you show on your website. But that is not sufficient to be able to use your site. I remember now! Years ago, I had to put your site in the trusted zone on my 98SE box. I had to put it in the trusted zone on the host XP box but that was almost two years ago when I bought this Dell Dimension 8300 box. I had forgotten especially since I almost never use IE and haven't in over four years now.

 

Why don't you tell folks that PCPitstop has to be in the Trusted zone? It sure would have saved me all this work trying to figure out a problem that has nothing to do with the health of my IE or my computer. What the heck setting or settings is it that this site needs lowered so much that it has be placed in the Trusted zone to work???

 

I just did the full tests here and I left Proxo with Sidki's latest configs and KIS 2006 running and the tests completed beautifully. I'm glad I persisted in figuring this out because my internet speed is poor and it's because I forgot to download Dr.TCP and turn windows scaling on and set my RWIN above what XP dynamically sets it at. Your tests reminded me that I haven't done that on this virtual pc although I did it long ago on the host box.

 

BTW, I bypassed Proxo after the tests and clicked on a number of your ads.

Link to post
Share on other sites
Guest tjw003

I stumbled across that same issue last night and added pcpitstop to my trusted zone. Great minds think alike. It works now!

Edited by tjw003
Link to post
Share on other sites

Why don't you tell folks that PCPitstop has to be in the Trusted zone?

As long as the Internet zone is set to Medium and nothing else is broken, it doesn't have to be in the Trusted zone. That's a good troubleshooting suggestion though, especially if it's worked for two people already. :mrgreen:
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...