Jump to content
Sign in to follow this  
Melelina

Why such a high RWIN recommendation?

Recommended Posts

I just ran the trial of your Optimize. My internet connection is just fine (although it has for about 5 years now shown low speed at your site) probably because you are in Texas and I am in Hawaii.

 

I have Road Runner at 5ms down. According to my Hawaii RR VisualWare My Speed test, I routinely test at 4.91Ms/420kbps and Quality of Service is at 99%. Speed Tests on the West Coast from Speakeasy and SBC Yahoo are about the same (4.87Ms down).

 

I have never heard of using an RWIN for XP Pro or any OS much above 100000. Usually the highest recommended RWIN is about 64420 unless you are in the middle of the Pacific ocean as I am in Hawaii. I usually have mine set at 75000. I use DrTCP to set it and this is the recommended setting from my home site of DSLReports. Why then would your test recommend a RWIN of 256960?! What is that supposed to accomplish? I set it to that value, rebooted and ran my speed tests. No difference. I'm really curious about how you arrived at this particular setting and why.

Share this post


Link to post
Share on other sites

RWIN is the most important setting realated to internet connection speed. Setting it too low can limit your throughput and setting too high could also reduce your connection speed. In our Max setting we did not want to limit throughput and found many similar application setting broadband connections at 256960 for XP & Pro. We tested this settings on many PC with different internet providers and based on the testing found that this would be the best setting for our Max broadband connection. We understand that each computer is little different and this exact setting may not be the very best for everyone but it should give all users a nice performance gain over the default setting.

Share this post


Link to post
Share on other sites
Guest flatbush71

256960 is way to high. I have been around here from the beginning (About 5 years)and have never posted. Optimizer or what ever needs a little work, it also does not return to previous settings correctly either. It knocked me down from 3700 to 1200 & I had to reset with DRTCP. Thanks to the guys at DSL Reports I got it sorted out. :bang::bang::bang::bang:

Share this post


Link to post
Share on other sites
Guest kenmar

256960 is way to high. I have been around here from the beginning (About 5 years)and have never posted. Optimizer or what ever needs a little work, it also does not return to previous settings correctly either. It knocked me down from 3700 to 1200 & I had to reset with DRTCP. Thanks to the guys at DSL Reports I got it sorted out. :bang:  :bang:  :bang:  :bang:

Ditto..!!!!!!!!!!!!!!!!!!

 

...Paid 30 bucks to have optimize knock down my speed from an aver of 1553/200 to an average of 1440/130 :angry:

 

Went back to Broadband's recommendations and am back to normal.

 

WHERE'S THE REFUND DEPT ???? :mrgreen:

Share this post


Link to post
Share on other sites

To Keith_L,

 

The only thing I agree with is: " RWIN is the most important setting realated to internet connection speed. Setting it too low can limit your throughput and setting too high could also reduce your connection speed."

 

When you use the term "Max Setting", this is a term I associate with "One Size Fits All".

 

To suggest an Rwin of 256960, which you've stated is a Max setting is clearly not suited for everyones individual computers and connections. This too high Rwin will cause lower download rates and can cause page lag. The optimum Rwin is an Rwin that is the lowest value that gives you consistant speeds. One size does not fit all. This Rwin your utility sets does not take into consideration average ping times/latency in the calculation. In fact, there is no calculation, just a Max setting.

One size fits all? No, it certainly does not. If I was a size 9 shoe, why would I want to wear a size "36"?

Share this post


Link to post
Share on other sites

Ditto..!!!!!!!!!!!!!!!!!!

 

...Paid 30 bucks to have optimize knock down my speed from an aver of 1553/200 to an average of 1440/130 :angry:

 

Went back to Broadband's recommendations and am back to normal.

 

WHERE'S THE REFUND DEPT ???? :mrgreen:

:wp:

 

http://pcpitstop.com/store/service.asp

Share this post


Link to post
Share on other sites

My bandwidth goes between 288Kbps - 360 Kbps each time...

 

And my TCP RWin size is set to 255552...

 

Seriously why this much "window"? And if I can still achieve about 85% of the advertised speed then it's a good setting, right?

 

 

Oh, btw, where do I find Dr.TCP?? :crash:

Edited by EclipseWebJS2

Share this post


Link to post
Share on other sites

The following three links are TechExpress links from my last 3 recorded tests...

 

Internet speeds and RWin sizes are given while you compare internet speeds...

 

RWin @ 255552: http://www.pcpitstop.com/techexpress.asp?id=YJAXNWSQB9QSBTZU

 

RWin @ 10164: http://www.pcpitstop.com/techexpress.asp?id=4CTXNWSQB9QSXFZU

 

RWin @ 5808: http://www.pcpitstop.com/techexpress.asp?id=PKP7NWSQB9QSQFZU

Share this post


Link to post
Share on other sites

The following three links are TechExpress links from my last 3 recorded tests...

 

Internet speeds and RWin sizes are given while you compare internet speeds...

 

RWin @ 255552: http://www.pcpitstop.com/techexpress.asp?id=YJAXNWSQB9QSBTZU

 

RWin @ 10164: http://www.pcpitstop.com/techexpress.asp?id=4CTXNWSQB9QSXFZU

 

RWin @ 5808: http://www.pcpitstop.com/techexpress.asp?id=PKP7NWSQB9QSQFZU

What is your advertised speed from your ISP? (example: 6000/768)

Do you have DSL or Cable?

 

I see you did much better with an Rwin of 10164.

Share this post


Link to post
Share on other sites

my internet is 384 down/128 up

Using DrTCP

 

Use these settings

Rwin: 21780

Window scaling: Off

Time stamping: Off

Selective ACKs: On

Path MTU Discovery: On

Max Duplicate ACKs: 2

MTU: Try 1500 or 1492

Share this post


Link to post
Share on other sites

This was my fastest:

click START to re-test
Another client is currently being served, your test will begin within 45 seconds
Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done
running 10s outbound test (client to server) . . . . . 114.90Kb/s
running 10s inbound test (server to client) . . . . . . 316.98kb/s
Your PC is connected to a Cable/DSL modem
Information: The receive buffer should be 126.357421875 Kbytes to maximize throughput

But DSL Reports still says "Choose RWIN between 5840 and 10220"

And another thing, I can only set my Receive Buffer size up to 64K, my DSL modem connects through the ethernet card.

Edited by EclipseWebJS2

Share this post


Link to post
Share on other sites

This was my fastest:

click START to re-test
Another client is currently being served, your test will begin within 45 seconds
Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done
running 10s outbound test (client to server) . . . . . 114.90Kb/s
running 10s inbound test (server to client) . . . . . . 316.98kb/s
Your PC is connected to a Cable/DSL modem
Information: The receive buffer should be 126.357421875 Kbytes to maximize throughput

But DSL Reports still says "Choose RWIN between 5840 and 10220"

And another thing, I can only set my Receive Buffer size up to 64K, my DSL modem connects through the ethernet card.

Don't worry about the receive buffer. Every time you run the web100 test, it will give you a different suggestion on buffer size. Network traffic determines their suggestion of size.

 

The Rwin suggested on DslReports starts at a low range for your connection. You would be ok with 10220. I have been tweaking PCs for years and know per your tests and specs that your Rwin can be pushed to 21780 safely(based on an MTU of 1492).

 

Your connection looks good.

 

Enjoy!

 

Forgot to add: If you want to experiment further with rwins, stay between 10220 & 21900.

 

Try: 13140, 16060, 18980 & 21900

 

These are all multiples of MMS(1460) Example: 1460 x 7 =10220

 

My suggestion for 21780 was based on an MTU of 1492(MMS 1452) not 1500. You see in my list of Rwins that 21900 is there and not 21780. Not knowing which MTU you were using; 21780 was safe.

Edited by johkal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...