Jump to content

faulty AIO water cooler


Recommended Posts

17 days a go i started to notice my CPU temps while gaming were getting hotter by the day going as high as 84c after 2 hours of gaming. prior to that they never went above 63c. i ran a cinebench 23 30min test and it reached 96c. idle temps were now 50c. funny thing is no hot air was coming from radiator which is why im glad i monitor temps while gaming. quick search said the pump was failing or the cold plate was plugged up with something. the AIO was the Lian Li galahad 360 that was only a year old. got the replacement AIO today and now temps are back to normal with 30c on idle.i have used AIO for years now and this is the first one to fail.anyone else ever have one fail? 

0128220208_HDR.jpg

Link to comment
Share on other sites

I have had several fail and went back to good, tower style air coolers. They are within a degree or two of most AiO and less chance of failure.

Link to comment
Share on other sites

2 hours ago, Tx Redneck said:

I have had several fail and went back to good, tower style air coolers. They are within a degree or two of most AiO and less chance of failure.

i agree with you on that.only thing failing on an air cooler is the fan. i expected more from a brand like Lian Li but they were great on the RMA. i just sent them a screenshot of the receipt and 1 email later they were shipping me a new one minus the fans. not sure why but they didnt even ask for me to return the bad AIO. i just hope the new lasts more than a year.

Link to comment
Share on other sites

10 minutes ago, Tx Redneck said:

That is a great RMA experience and I too hope you get better service from it.

 

Tx 🤠

it was the best RMA i have ever had, not like razer or newegg. pic is when the alarm went off

too hot.jpg

Link to comment
Share on other sites

  • 1 month later...

so i got the replacement AIO and from day 1 noticed the RGB lighting on the pump block was very dim...the RGB was hooked up directly to my motherboard...the AIO does its job at cooling my CPU but i didnt like the fact that the RGB lighting was so dim...sent it back for another replacement...they sent me a refurb instead of a new one...i asked them previously if they were sending a new AIO and they said yes but when i got it the serial # on the radiator and box didnt match...good thing the hopefully new AIO will be here today since the lighting on the pump block is just about dead...im going to avoid Lian Li in the future

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...