Jump to content

Wireless Network Connection doesn't have a Valid IP Configuration WIN 7


Recommended Posts

My Win7 Desktop and Win7 Laptop both connect to the Free Wifi in my apartment complex. On 8/26/2020 it was down for about a month. Now recently, my Laptop is able to connect but my desktop will not. Diagnose tells me Wireless Network Connection doesn't have a Valid IP Configuration. I have tried the easier solutions I could find online, that involve opening CMD and ipconfig /release, /dnsflush, /renew, as well as the Ntsch commands, followed by restarting computer. My only AV is Malwarebytes, manual scan only, no Antivirus operating in the background. Nothing on my system has changed since then. Signal Strength is listed as Excellent. My Laptop is sitting right next to the desktop, has always had a slighter lower signal strength, but now it is connecting to the WIFI, while the Desktop suddenly will not. Please help. The Laptop is altogether inferior and something I only use for travel or emergencies.

Link to post
Share on other sites

Sounds like you've tried all I would suggest; just to confirm you've also used netsh winsock reset (and restart) also netsh int ip reset (and restart).Just to rule things out have you uninstalled and reinstalled the network card / checked drivers?

 

also :wpcm:

 

 

Link to post
Share on other sites

I had this happen on my Aunt's laptop, just last week. The only thing that I found to "fix it" was system restore to a past date. No rhyme or reason for it, but that was all I could do to get it to reconnect. I'm still in the dark on that one. 

Link to post
Share on other sites

Nope, I never figured it out, but there was something I'd run that would break it and wouldn't realize or catch it until after the fact. Indiferencia Idk GIF by Product Hunt

Link to post
Share on other sites

That was quick. yes I tried the netsh codes. no driver updates. Thanks for chiming in, Tx Redneck, I was considering using the system restore, looks like a good idea. Its odd the way it happened, since they actually got rid of the Wifi for a while in favor of using the computer labs, but some people complained about how this affected their online business opportunities. It was definitely down for about a month, because I kept checking both computers.

 

Its as though the desktop was still seeing the network the way it was before, not as it is now. Its an HP Pavillian with a separate restore drive, so I will try rolling it back a few months, hopefully that will help. The desktop uses an HDMI big TV for its monitor and has altogether better specs then the cheap laptop.

Link to post
Share on other sites

Is it possible they changed some settings when they fired back up?

 

For example:  If they were running on, say 192.168.1.XX and, for some reason were now on 192.168.0.xx - if your laptop was on automatic, it would adjust to the "new" network, dhcp would give it a new IP, and away you go.  However, if your desktop had an IP preference set, it would refuse to recognize the "new" network and would not be able to communicate with dhcp to get an IP address - which would mean your system wouldn't be able to configure the IP.

 

Perhaps you could open a command prompt.  type ipconfig and hit enter.  Then provide the informtion that is provided.

 

Or...

a relatively easy way to do that is:

 

Open a command prompt

 

Paste the following into the Command Prompt window, exactly as shown, including double quotes:

 

cmd /c "ipconfig /all > postme.txt & ping yahoo.com >> postme.txt & reg query "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" | find /i "proxy" >> postme.txt & notepad postme.txt & del postme.txt"
 

and press ENTER.

A file will open in Notepad. Please copy and paste the contents here. Close the Notepad window and the file will be deleted and the Command Prompt window will also close. Post results in a reply here.

Link to post
Share on other sites

I tried the system restore, but it didn't go back early enough. I even tried deleting the profile, which did not help, that was done recently, and was not undone by the restore, so it doesnt make a profile. I have to manually type the wifi password when connecting, then it immediately connects but has no IP4 or IP6. I run diagnose and it tells me I am not connected to an available network, so I select it again, enter passwrd again, and then it says the doesnt have a valid ip configuration. I can't do a full system recovery, I have games installed that I dont have the setup files for anymore, and my only mouse and keyboard are USB wireless, and if I did the system recovery and it still couldn't access the internet, I would not even have a mouse or keyboard as I would not be able to find the driver software.

 

Here are the results of the Postme.txt

 

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Phaedron-HP
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : Home

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : Home
   Description . . . . . . . . . . . : Broadcom WLAN Adapter
   Physical Address. . . . . . . . . : 44-6D-57-3C-91-E2
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c55a:9110:be26:955b%14(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.149.91(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 256142679
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-32-7F-B7-90-2B-34-28-97-9A
   DNS Servers . . . . . . . . . . . : 192.168.0.1
                                       205.171.3.65
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 90-2B-34-28-97-9A
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.Home:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : Home
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Ping request could not find host yahoo.com. Please check the name and try again.
    AutoConfigProxy    REG_SZ    wininet.dll
    MigrateProxy    REG_DWORD    0x1
    ProxyEnable    REG_DWORD    0x0
    ProxyHttp1.1    REG_DWORD    0x1

Link to post
Share on other sites

Are you able to set up a mobile phone hotspot and see if the desktop connects to it? That may pin point the issue to either the desktop or the router (IE a MAC address filter?)

 

Link to post
Share on other sites

No router, this is the Wifi are our apt complex, even they do not so much as touch it without a tech expert. Seriously, they wont even turn it off and on.

No other network I can connect to that is not password protected. My only phone is a cheap free phone that only does calls and texts.

Link to post
Share on other sites

I would try getting rid of that prefferred IP address:

"Autoconfiguration IPv4 Address. . : 169.254.149.91(Preferred)"

 

If the gateway is 192.168.0.1, then dhcp should assign you somewhere in that network.  I'm not an expert in this, but I don't know why you would ever show a preffered IP starting with 169.

 

From the an article here: https://www.uswitch.com/broadband/guides/what-is-an-ip-address/

 

Quote

 

Bad IPs

If your IP ever starts with 169, you won't be able to access the internet. A 169 address is your router or modem alerting you to a problem by giving you a bad IP address.

If you're at work, get your IT people on it. If you're at home, the best thing to do is turn off and unplug your router for 30 seconds, then plug it back in and turn it on again. If you're connecting wirelessly, try a cable, and if that still doesn't work, phone your provider — there is a problem between your computer and your router.

 

 

Link to post
Share on other sites

I dont know who you're quoting, but again, I have no access to router / modem. Crazy thing happened tonight. I was using a proxy to access gamefaqs message board, which for some odd reason I get insecure connection message normally. The proxy stopped working, and I went to find others, none of those worked.

 

I could connect find to here, youtube, anywhere else with it set to "Auto Detect Proxy," but I even tried setting it to No Proxy, and soon as I tried to load a youtube video, it died, for like an hour. Then I tried using the original proxy that stopped working to begin with. Now it works, here, youtube, and gamefaqs, doesn't load google search, and even using it no Proxy I can't connect to anything.

Link to post
Share on other sites

So now, I suddenly have to use the free proxy to connect at all, I guess because of the Barracuda security system banning the IP address. Maybe that happened on my desktop. But I dont get the same message on the laptop. It says No IPv6, or sometimes No Network access, but I can still get access with the proxy, at least for now. Funny thing is, I wasn't doing anything that involved a proxy on the desktop on any of the nights before the Wifi went down.

 

Is there a way to use the settings of the laptop on the desktop, to set a specific address to fix the preferred 169?

Link to post
Share on other sites

Looks what this is what I got https://community.barracudanetworks.com/forum/index.php?/topic/28651-access-denied-barracuda-user/

 

"

Good day, Barracuda Community. 
 
I am currently working as an IT Support, and I was able to meet this kind of error below twice already with our users. 
 
Access Denied
 
This link you are accessing has been blocked by the Barracuda Web Security Gateway because it contains belonging to the category of: Search Engine & Portals
 
If you believe this is an error or need to access this link please contact your administrator
 
 
As reported by our users, the error suddenly comes up while they are doing something in the Internet. The only solution we could think of with my partner is that we wait for the 24-hours until the next login of the user as it is how is set by the main administrator of the Web Filter (and unfortunately, we don't have an access on that yet).
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...