Jump to content

Change Mode

Getting Support is Frustrating


Richardb02
 Share

Recommended Posts

I have what should be a simple problem to fix if support was available.

I schedule scans and maintenance and they do not occur.

I try to contact support and wind up in endless loops.

I register for the forum. It asks if I want support. It then directs me back into the endless loop.

I received help very easily 3-4 years ago about a technical issue.

Now,, it is impossible to navigate your system.

Please reply.

Link to comment
Share on other sites

Hola @Richardb02 and :wpcm:

 

Please accept my apologies for the frustration, it does appear that our support page isn't functioning properly. I've notified our devs so they can correct it.

 

In the meantime, please keep your eyes open for an email from one of our Support Team. If you don't see one soon, please be sure to check your spam box/folder as well.

 

Hang tight!

Tx 🤠

Link to comment
Share on other sites

21 hours ago, bkwalk2 said:

I too am having difficulty in obtaining technical support; maybe I should go back McAfee

Hola @bkwalk2 and :wpcm:

Thanks for your support of our software! I see you opened a ticket at our Help Desk on 26 April 2020 11:18 AM and received a reply from Josh C on 26 April 2020 11:49 AM, unfortunately, we've not heard back from you,

 

Please follow up on the directions sent as it's the best means to see what's taking place. On the chance that you did not receive our email to your inbox, please check your spam folder/box, if you've nothing from us, please reply here to that affect so we can send you a reply from an alternate email address. From time to time, various email providers block our outbound replies, but we're working to get that resolved altogether.

 

Should none of this be to your satisfaction, we do offer a 30 Day, no questions asked, money back guarantee.

 

Hang tight!

Tx 🤠

Link to comment
Share on other sites

  • 2 months later...

Hello @URTHllc

Sorry for your frustration.  I do see our support website is loading without errors.

A support ticket has been opened from help desk so we can look into your issue further.  If you do not see it in your inbox, please check your spam/junk folders.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...