Jump to content
Sign in to follow this  
why me

pcmatic.com software

Recommended Posts

Help!!  my new pcmatic.com antivirus program will not allow me to download the software.   I can't find out what firewall may  be preventing it from installing.

Share this post


Link to post
Share on other sites

Hola @why me and :wpcm:

 

I'm unsure of why this might happen. I'll pass this on to our Customer Support team to reach out to you. We'll need to get some info to get this resolved. 

 

Thanks for your support and patience, 

Tx 🤠

Share this post


Link to post
Share on other sites
Posted (edited)

well it got fixed and now it's the new year 2020 and it's stuck in loading.  I can't get it to load not that there is a way to.  I'm sorry I purchased the product.  I don't like this that it just all of a sudden decides not to load as soon as the new year comes.   I paid for this, for the lifetime one time payment,  I haven't even had it a year and already there's another problem.   I got a ticket # from the Company and sent them a snapshot of what is on my screen which is merely that the PC Matic loading screen is as far as it gets I don't even get an error code because it just won't freaking load.

Edited by why me

Share this post


Link to post
Share on other sites

Hi @why me

I see from your support help desk ticket that this issue was resolved.

 

Is that correct or are you still having an issue?

 

Share this post


Link to post
Share on other sites

My internet WILL NOT log onto pcmatic website. Im having a similar problem. All of a sudden, my pcmatic can't log in to scan. My ac5300 router thinks that pcmatic is a malicious site so it won't goto the pcmat page at all. I've turned off the firewall, updated firmware, logged in as administrator, and I still have the problem. Recently, my son's google pixel phone was infected with an xxs script virus. Now my internet is bogged down from constant attacks to my network. I changed passwords to 2G,5G-1, and 5G-2.  Rebooted my router and its still the same. Pcmatic has been useless in detecting the virus.My Asus ac5300 newok security is what caught it.  Any suggestions?

Share this post


Link to post
Share on other sites

Hola @jamesrn909 and :wpcm:

Sorry for the delayed response here, but you should have received an email from our support team. If you don't see it in your inbox, please check your spam/trash folder as well. In the event you did not receive anything from us, please open a trouble ticket at https://www.pcmatic.com/support/

 

Tx 🤠

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/5/2020 at 4:28 PM, stewieT said:

Hi @why me

I see from your support help desk ticket that this issue was resolved.

 

Is that correct or are you still having an issue?

 

Yes it was and I am sorry I took so long to get back here.  It's hard to find this support site.   Now it's doing it again and I checked for the certificate it expired 2/19/20.  I don't know if that has anything to do with this problem.  It just keep saying loading but never loads.  Why does this happen?  It worked fine earlier tonight  I frequently click the icon then in a few seconds it loads (not tonight) and I click scan then continue normally for a while now since January it has been working when it was fixed in January 2020.  It is very frustrating.

 

Edited by why me

Share this post


Link to post
Share on other sites

It's fixed :)   I tried it today and it loads now it's scanning.

 

Thank You :) 

Share this post


Link to post
Share on other sites

Good deal! Thanks for the update. 

 

Tx 🤠

Share this post


Link to post
Share on other sites

Tx Redneck first I really like your quotes.  Very insightful. 

ok now my PC Matic is doing the same thing again it is stuck in "loading" and never loads.   Can someone please unstick if for me?

 

I don't know if it's something to do with so many people being home using the internet/virus scanning more than usual so I'm not sure if I should wait longer

to ask to have it fixed.

 

I appreciate all the help I receive from this forum and do appreciate anything that can be done.

 

Thank You

Share this post


Link to post
Share on other sites

ok that was faster than speeding bullet LOL  it's working again now.  It must be all the people using it more than usual.

 

Thanks,

:)

Share this post


Link to post
Share on other sites

Hola again @why me

 

We identified an issue on our end have rectified it. Please accept my apologies for the disruption and thanks again for your support and patience!

 

Tx 🤠

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...