Jump to content

Recommended Posts

Help!!  my new pcmatic.com antivirus program will not allow me to download the software.   I can't find out what firewall may  be preventing it from installing.

Share this post


Link to post
Share on other sites

Hola @why me and :wpcm:

 

I'm unsure of why this might happen. I'll pass this on to our Customer Support team to reach out to you. We'll need to get some info to get this resolved. 

 

Thanks for your support and patience, 

Tx 🤠

Share this post


Link to post
Share on other sites
Posted (edited)

well it got fixed and now it's the new year 2020 and it's stuck in loading.  I can't get it to load not that there is a way to.  I'm sorry I purchased the product.  I don't like this that it just all of a sudden decides not to load as soon as the new year comes.   I paid for this, for the lifetime one time payment,  I haven't even had it a year and already there's another problem.   I got a ticket # from the Company and sent them a snapshot of what is on my screen which is merely that the PC Matic loading screen is as far as it gets I don't even get an error code because it just won't freaking load.

Edited by why me

Share this post


Link to post
Share on other sites

Hi @why me

I see from your support help desk ticket that this issue was resolved.

 

Is that correct or are you still having an issue?

 

Share this post


Link to post
Share on other sites

My internet WILL NOT log onto pcmatic website. Im having a similar problem. All of a sudden, my pcmatic can't log in to scan. My ac5300 router thinks that pcmatic is a malicious site so it won't goto the pcmat page at all. I've turned off the firewall, updated firmware, logged in as administrator, and I still have the problem. Recently, my son's google pixel phone was infected with an xxs script virus. Now my internet is bogged down from constant attacks to my network. I changed passwords to 2G,5G-1, and 5G-2.  Rebooted my router and its still the same. Pcmatic has been useless in detecting the virus.My Asus ac5300 newok security is what caught it.  Any suggestions?

Share this post


Link to post
Share on other sites

Hola @jamesrn909 and :wpcm:

Sorry for the delayed response here, but you should have received an email from our support team. If you don't see it in your inbox, please check your spam/trash folder as well. In the event you did not receive anything from us, please open a trouble ticket at https://www.pcmatic.com/support/

 

Tx 🤠

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...