Jump to content

Change Mode

Is this USB stick set to read only, or simply failing?

Kerr Avon

Recommended Posts

Yesterday I was transfering some data from a USB stick (64GB Spaceloop, by CnMemory, it says on the outside), and everything worked fine. I reset the laptop
after installing VolMouse (a great program to control the volume via the mouse wheel - http://www.nirsoft.net/utils/volumouse.html), and when the laptop
booted I discovered that the USB stick wouldn't let me delete any files from it. Nor would it allow rename, it just acts like it's purely read only.

I tried it in my desktop PC, which also saw it as totally read only. And on my Android tablet, using a program called Explorer, it does seem to allow
deleting and renaming on the USB stick, but not really, as if I then put the USB stick back into my desktop, or unplug it from the tablet (after performing
seemingly successful renames or deletes) and put it back into the table, then it turns out that nothing has been deleted or renamed. And the data on the USB
stick is not corrupted, it has video files on it that still play, and archive files that are still perfect (according to 7zip's brilliant batch Test


Fair enough, the stick is probably just dying, they're cheap enough to replace so I'm not too bothered. But two things do bother me:


1) Why does the Android program show the rename or delete operations as being successful? If I use it to rename a folder, then the folder shows as being
renamed, and when I select it (still on Explorer, in the tablet, of course) then I can open the folder (via it's new name) and it goes into the folder,
despite the folder's name NOT being the new name (i.e. if I rename 'ebooks' to '2' then Explorer shows it as being named '2', and no folder named 'ebooks' is
listed any more, and I can now go into the folder 'ebooks', even though no such folder really exists, since it's still called 'ebooks'). Not a major problem,
but it's a stupid flaw, either in Android, the tablet, or most like, in Explorer.


2) Much more annoying is that it turns out that Windows has the ability, apparently, to make a USB stick (and USB drive, I assume?) write-only. I didn't know
that, nor did anyone I asked. If Windows has this ability, then (a) why not publicise it, and (b) why not put a ****ing option on the control panel or
somewhere to turn it on and off? I'm using Windows 7 on my laptop and desktop, so maybe a user friendly option does exist in later versions of Windows, but
if so then no one mentions it on the web pages I've searched.


Instead, I only found out about this 'feature' when googling on the off chance that this wasn't simply a case of my USB stick's hardware failing. Turns out,
Windows causing a USB stick to become read-only isn't too uncommon (though to be fair, it's never happened to me before), and there are lots of users with
the problems, though no doubt many of them actually have failing USB sticks instead.


There are three sorts of solutions that I could find:


1) Edit the Windows registry (though I don't see how this could affect something that must be stored on the USB stick, I mean, since when I plug the USB
stick into the laptop/desktop/Android table they all treat it like it's read only, so surely the read only flag is on the USB stick itself?)


2) Use a Windows based command line program called "Diskpart"


3) Download and use various third party programs that claim to make the USB write-able again.


None of the above worked for me, and if the USB stick is indeed physically failing than OK. But I'd like to be able to confirm that it is a genuine hardware
fault, and not that Windows has somehow caused a working USB stick to be flagged as read only. I didn't even know that a USB stick did have a "Treat this
drive as if it's read only" flag, so does anyone know of any program that will scan a USB stick and tell you the status of such a flag, and preferably also
allow you to change the status of the flag? And if this feature does exist, when why doesn't Microsoft have it somewhere in Windows Control Pane?

And if, like me, you didn't know it was possible to set a USB stick to read only, then simply google it, and you'll find lots of people who suddenly found
their USB stick acting like this, many of whom were able to fix it with the methods mentioned above.


Note: Of course I'm not talking about files or folders being set to Read Only, I'm familiar with that, I mean the whole USB stick not allowing delete, or
rename, or new files being copied to it, and when you write click on a file, you don't even get the RENAME or DELETE options in the list of options. It's a
standard 64GB USB stick, normal USB connector, NTFS format, no hardware READ ONLY switch on it's case, a few years old. I've been using various USB

sticks for years, both the laptop and desktop are Windows 7, I've tried other USB sticks in them since and I can rename, delete, and put new files on them

no problem, but this one USB stick is still acting like it's read only.


Edit: The USB stick is a 64GB Spaceloop, by CnMemory, not by ChMemory (I initially put a 'h' instead of an 'n', sorry)

Edited by Kerr Avon
Link to comment
Share on other sites

When in Windows I go to the command line (via Run As Administrator), and type:






then I select the USB stick via SELECT DISK, then when I enter ATTRIBUTES DISK, it says:

Current Read-Only State: Yes
Read-Only: No
Boot Disk: No
Pagefile Disk: No
Hibernation File Disk: No
Crashdump Disk: No
Clustered Disk: No



Then when I type:




it says attributes cleared successfully


but then when I type:




then it gives the same summary as before:


Current Read-Only State: Yes
Read-Only: No
Boot Disk: No
Pagefile Disk: No
Hibernation File Disk: No
Crashdump Disk: No
Clustered Disk: No


So what's the difference between "Current Read-Only State" and "Read-Only" in the above summary? And could the fact that "Current Read-Only State" is set to yes be the reason why the stick isn't writable? How do I change "Current Read-Only State", since I can't find a way to do it in DISKPART?

Link to comment
Share on other sites

Ha d this happen to an Micro SD just a week ago. PC(s) could see and read, phone couldn't. Couldn't format it in any environment, so I broke it into tiny pieces rather than RMA'ing because it had sensitive info on it.

Link to comment
Share on other sites

1 hour ago, Tx Redneck said:

Ha d this happen to an Micro SD just a week ago. PC(s) could see and read, phone couldn't. Couldn't format it in any environment, so I broke it into tiny pieces rather than RMA'ing because it had sensitive info on it.


Yes, it's not like they're expensive, thankfully.


I've been unable to format the USB stick, so I'm going to try to update the firmware if I can find the correct version, as maybe that will make it write-able again.


The stick is one of these (the silver 64GB one, a Spaceloop, by CnMemory)




but the website is terrible, with no downloads, and the question "My USB stick is suddenly write-protected, what can I do?" in the FAQ is answered with "Please contact our technical support in this case", which isn't what I'd call helpful. I've e-mailed them, but Gmail says the email has failed with an "Address not found" error. And according to the site "As you can read in the press, our company is currently in preliminary insolvency proceedings.", so I doubt their technical department will be large, if they even still exist.


So if anyone can tell me which firmware to try, or anything else that might fix the USB then I'll give it a go.

According to Flash Drive Information Extractor the stick's details are:

Volume: P:
Controller: Alcor AU6990AN/AU6987AN/SC708AN
Possible Memory Chip(s): 
Memory Type: MLC
Flash ID: 50504E01 0006
Flash CE: 2
Flash Channels: Single
Chip Code: 0xCA07
Chip F/W: 8799
Group: 90
VID: 058F
PID: 6387
Manufacturer: Generic
Product: Mass Storage
Query Vendor ID: Generic 
Query Product ID: Flash Disk 
Query Product Revision: 8.07
Physical Disk Capacity: 64156073984 Bytes
Windows Disk Capacity: 64152924160 Bytes
Internal Tags: AYWR-YY3J
File System: NTFS
Relative Offset: 1030937860 KB
USB Version: 2.00
Declared Power: 200 mA
ContMeas ID: D979-01-00
Microsoft Windows 7 SP1 x64 Build 7601
Program Version:

According to ChipGenius:

Description: [P:]USB Mass Storage Device(Generic Flash Disk)
Device Type: Mass Storage Device

Protocal Version: USB 2.00
Current Speed: High Speed
Max Current: 200mA

USB Device ID: VID = 058F PID = 6387
Serial Number: 68F171C1

Device Vendor: Generic
Device Name: Mass Storage
Device Revision: 0107

Manufacturer: Generic
Product Model: Flash Disk
Product Revision: 8.07

Controller Vendor: Alcor Micro
Controller Part-Number: SC708AN/AU6987AN [CA07] - F/W 8799
Flash ID code: 50504E01 - 2CE/Single Channel H2DTDG8V01MYR [MLC-8K]

Tools on web: http://dl.mydigit.net/special/up/alcor.html

Possible Flash Part-Number
[2CE]H2DTEG8V01MYR(26nm) x 1 pcs/Channel x 1 Channel
[2CE]H2DTDG8V01MYR(26nm) x 1 pcs/Channel x 1 Channel

Flash ID mapping table
[Channel 0]    [Channel 1]
50504E010006    --------
50504E010006    --------
--------    --------
--------    --------
--------    --------
--------    --------
--------    --------
--------    --------

According to ChipEasy:

Logical drive : P:\ Capacity: 59.7G
Device ID : VID = 058F PID = 6387
Device SN : 68F171C1
Device version : 8.07

Device vendor : Generic
Device model : Flash Disk
Protocol : USB2.0
Max power : 200mA

Partition type : NTFS Device active : OK
Aligned state : 1024 KB, Have been Aligned

Controller : Chipsbank
Controller model: CBMeneric
FW Date : Flas.Di.

Tools : http://www.upan.cc/tools/mass/UMPTool/
OS Version : Windows 7 Professional Service Pack 1
Update Status : The current version is the latest version!

Link to comment
Share on other sites

Thanks everyone for the advice. But it turns out that the USB stick is faulty. I know this because a couple of hours back on a whim I put the USB stick in my desktop, and tried to delete a file, and it worked! So to test it, I tried to copy a folder full of comics, containing nearly 1,700 folders over, and the USB accepted and stored the files until it threw up a "source disc is write-protected" error when partway through the files in the second folder. Now it won't delete anything. And of I course tried the other two USB sticks to make sure it wasn't the PC at fault, and they still work as they should.

So case closed. I'll call it a day, and bin the might-as-well-be-dead stick. Thanks again for all the help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...