Jump to content

LAN connection problem (deja vu)


Recommended Posts

Hi, again. Can someone walk me through connecting w/WLAN in Leap 42? I don't understand why Win10 automatically detects the network and when I enter the passkey it gets all set up. Now I boot up and it's automatically connected.

But in Linux I simply can't get a connection. Tried through Yast, tried through NetworkManager widget, no dice. It must be a simple mistake I'm making in the setup.

All help is always greatly appreciated, Pit has never let me down.

 

KB

Link to post
Share on other sites
  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

you having problems with lan connected by wire, or wlan wifi connection? think you want help with wifi but not 100% sure.

 

i'll need to find a wifi device so i can jog my memory on using wifi, until then open a terminal and as root type

ifconfig -a

and post the results.

 

next type in

ethtool -i wlan0

and post the results for that too

 

first command will show all network devices, 2nd command shows what driver is used for wifi device.

 

:b33r:

Edited by terry1966
Link to post
Share on other sites

Wow, whole lotta typing here, so here we go:

 

OS is openSUSE Leap 42.1, KDE desktop.

 

ifconfig -a

 

eth0

Link encap: Ethernet HWaddr 70:5A:0F:9B:2DC4

BROADCAST MULTICAST MTU=1500 Metric:1

RX packets: 0 errors: 0 dropped: 0 overruns: 0 frame: 0

TX packets: 0 " : 0 " : 0 " : 0 carrier: 0

collisions: 0 txqueuelen: 1000

RX bytes: 0 (0,0 B) TX bytes: 0 (0.0 B)

 

lo

Link encap: Local Loopback

inet addr: 127.0.0.1 Mask:255.0.0.0

inet6 addr: : : 1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets: 12 errors: 0 dropped: 0 overruns: 0 frame: 0

TX packets: 12 " : 0 " : 0 " : 0 carrier: 0

collisions: 0 txqueuelen: 0

RX bytes: 720 (720.0 B) TX bytes: 720 (720.0 B)

 

wlan0

same as eth0 except for HWaddr 74:DF:BF:77:38:5B

 

ethtool -i wlan0

driver: rtl8723be

version: 4.1.12-1-default

firmware-version: N/A

expansion-rom-version:

bus-info: 0000:02:00.0

supports-statistics: yes

" -test : no

" -eeprom-access: no

" -register-dump: no

" -priv-flags: no

Link to post
Share on other sites

just for future reference kurt, you can just copy out of the terminal and then paste it into a reply, (preferable using a code box, <> next to quote icon.)

linux-lm5d:/home/leap42.1 # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1F:D0:DB:F0:E5  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:d0ff:fedb:f0e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:433727 errors:0 dropped:4 overruns:0 frame:0
          TX packets:253943 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:575092048 (548.4 Mb)  TX bytes:21149585 (20.1 Mb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:654 errors:0 dropped:0 overruns:0 frame:0
          TX packets:654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:37076 (36.2 Kb)  TX bytes:37076 (36.2 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:1F:33:FE:16:E8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0   TX bytes:0 (0.0 

things look ok, just the eth0 and wlan0 are shutdown so i think it's just a case of configuring it to start them. (should have "UP BROADCAST MULTICAST MTU=1500 Metric:1" if started i believe, plus an ip address when connected of course.

 

i assume you want to use network manager and not yast, go into yast under network settings, global options make sure networkmanager service is selected where it says network setup method. click ok and exit yast.

 

now in the task bar bottom right you should see the networks icon, click on it and in the popup box does it find and show any wifi networks?

 

if so just click on your wifi network where it says connect, a password box opens. enter your password and that should be it.

 

:b33r:

 

if no networks show up in networkmanager to connect to, then in a terminal as root type in

ip link set wlan0 up

and try again.

linux-lm5d:/home/leap42.1 # ip link set wlan0 down
linux-lm5d:/home/leap42.1 # ifconfig -a           
eth0      Link encap:Ethernet  HWaddr 00:1F:D0:DB:F0:E5  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:d0ff:fedb:f0e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:434618 errors:0 dropped:4 overruns:0 frame:0
          TX packets:254845 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:575428860 (548.7 Mb)  TX bytes:21260923 (20.2 Mb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:654 errors:0 dropped:0 overruns:0 frame:0
          TX packets:654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:37076 (36.2 Kb)  TX bytes:37076 (36.2 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:1F:33:FE:16:E8  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0   TX bytes:0 (0.0 

linux-lm5d:/home/leap42.1 # ip link set wlan0 up
linux-lm5d:/home/leap42.1 # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1F:D0:DB:F0:E5  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:d0ff:fedb:f0e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:435060 errors:0 dropped:4 overruns:0 frame:0
          TX packets:255299 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:575597792 (548.9 Mb)  TX bytes:21423264 (20.4 Mb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:654 errors:0 dropped:0 overruns:0 frame:0
          TX packets:654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:37076 (36.2 Kb)  TX bytes:37076 (36.2 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:1F:33:FE:16:E8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0   TX bytes:0 (0.0 

linux-lm5d:/home/leap42.1 # 

notice when i shut the wlan0 device off using "ip link set wlan0 down" command it says "BROADCAST MULTICAST MTU:1500 Metric:1" and when i start it up again using the "ip link set wlan0 up" command it says "UP BROADCAST MULTICAST MTU:1500 Metric:1"

 

yours needs to say "UP BROADCAST MULTICAST MTU:1500 Metric:1" and then you should find everything will work fine, fingers crossed. :mrgreen:

Edited by terry1966
Link to post
Share on other sites

Yes Terry, I could just copy-and-paste, but I don't know how to do that and then exit Leap and open Win 10 to post it. :)

 

Sometimes the taskbar icon shows my network, other times it won't. When it does, it will show the password entry box but after trying to connect it will fail. I'll try it again and get back to the Pit with the update.

 

Should I be using WPA-EAP or WPA-PSK in Yast setup. Infrastructure or Ad-hoc in NetworkManager? This is probably where I am bollocksing it up.

 

:b33r:

Link to post
Share on other sites

 

i made lots of edits to previous post that you may have missed so please make sure you read everything there.

 

Yes Terry, I could just copy-and-paste, but I don't know how to do that and then exit Leap and open Win 10 to post it.

paste the terminal into a file saved on the windows partition then you can simply copy and paste from there into your reply's.

 

Should I be using WPA-EAP or WPA-PSK in Yast setup. Infrastructure or Ad-hoc in NetworkManager? This is probably where I am bollocksing it up.

depends on what encryption is being used but without checking i'd say it's usually "wpa-psk" in yast, and "wpa-psk2 personal" in manager.

and for mode type in network manager again without testing i'd select infrastructure.

 

but really you shouldn't need to manually add your network, and it should show up by doing a scan.

 

 

Sometimes the taskbar icon shows my network, other times it won't. When it does, it will show the password entry box but after trying to connect it will fail. I'll try it again and get back to the Pit with the update.

ok will need to look into that, as long as wifi networks show up then you know the driver is installed and the device is up and running, and if it doesn't connect we'll need to figure out why. if you've manually added a wifi network connection go into settings and delete them all so we're starting clean.

 

:b33r:

Edited by terry1966
Link to post
Share on other sites

Hey guys, thanks for the help, but I guess I'm a Windows dude now. I step away from the computer for a few to go outside and have a smoke and the display goes haywire and I have to cold boot back up. Maybe my lappy is not good, but Windows does work so I guess I'm stuck with it.

 

How much longer will openSUSE 13.2 have support? Maybe I could try that, but I think I'll just restore my PC to original state and go from there. Or figure out in Win how to format the Linux sub drives back to full M$.

 

My lappy is good, I never got 55+ upload speed on any other box.

Link to post
Share on other sites

You're right, mate, can't throw in the towel yet. I have HP Notebook 17-x061nr.

I can now connect to my network, but I only get one bar and can't connect to any sites. I'll try that ant_sel tweak when I have some time. Thanks, Terry.

 

:b33r:

Link to post
Share on other sites

Don't know how, but I'm typing this to you all on Linux. Strange GRUB menu though. 1st option is Leap 42.1, but farther down is openSUSE 42.1(x86/64) on /dev/sda7. I choose advance options there, and get that with 4.1.whatever-kernel-default. It works, it's good.

Now I have to remember how to kill KDE Wallet, and get my old repos back.

Still feels real good to be running Linux again. Norton's already whacked 5 viruses on my Win 10. Screw Redmond, I'm back in Antarctica with the penguins.

Edited by KurtBleach
Link to post
Share on other sites

:clap:

 

sounds like you may have more than 1 install of leap on that drive, you happy with how things are now or do you want us to look at anything?

 

what did you need to do to get the wifi working?

 

:b33r:

Link to post
Share on other sites

Yes I'd like for you all to check my PC out. Ain't nothing here that Jerry Sandusky would be into or e-mails to ISIS. It is confusing all the options to choose from at boot, and if I don't press F9 quick enough, Windows boots.

 

Only thing that got the wifi working was to choose a different option at boot, but it's not working now anyway - typing this on Win 10. Got through my repo installs and all but it died during Flash install.

 

I'm not giving up yet, but I have done 3 clean installs and nothing changes. I can't hose the Windows, I want to dual boot until I have the Linux up and running right, then I can trash Windows.

Link to post
Share on other sites

ok. lets start from beginning then.

 

you shouldn't need to tap F9 to get an option to boot into leap if you have a dual boot setup, so sounds like you don't have a dualboot setup and just have leap installed on a flash drive (not recommended, way to many problems running from a flash drive in my experience.) which you boot by using the F9 key.

 

just to check though in windows go into disk management and take a screenshot of your hard drives partitions and post it in next reply.

 

once i see that we'll decide on what to do next, depending on what you want.

 

creating a dualboot system will not overwrite your windows os and the first thing you'd do is shrink the windows 10 partition, leaving a certain amount of space free which is where the suse os will get installed, once installed the first thing you'd see is a menu to boot either leap or windows 10 without the need to tap any F keys.

after install which os you set to boot as default if you don't make a choice is up to you but will be suse until you change it.

 

:b33r:

Edited by terry1966
Link to post
Share on other sites

I went into Disk Manager and formatted then removed the Leap partitions. I don't have Leap on flash drive, I burned the ISO disc and installed from it. I will try a fresh install and let you know what's up with that. I do think the signal is too weak here for running Linux. Almost as fast as Usain Bolt in Win 10. I hate this.

Link to post
Share on other sites

Looks like clean install has done the trick. Terry, thanks again. I just had to go F10 and change up the boot order to GRUB. I'll worry about boosting the signal at some other time, right now it's good enough for me.

 

Peace.

 

:b33r::b33r::b33r:

Link to post
Share on other sites

ok.

 

just for info, with a uefi dual boot, there are 2 ways to make sure it shows the grub menu on boot, first and best way in my opinion is what you've done and set it in the uefi and 2nd way is when in windows use bcdedit command.

with secure boot enabled :- bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

with secure boot disabled :- bcdedit /set {bootmgr} path \EFI\opensuse\grbx64.efi

more info here :- https://tweakhound.com/2015/11/04/dual-boot-opensuse-leap-and-windows-10-uefi/

 

as to the weak wifi signal, try adding a file named "rtl8723be.conf" (without quotes.) with this line in it.

options rtl8723be ips=N fwlps=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1

in the /etc/modprobe.d/ folder.

 

no idea what all the options are for without more research, but worth a try to see if it helps you anyway, and if it doesn't you can always delete the file.

 

:b33r:

Link to post
Share on other sites

Hovering between 50-56% signal with 72.2 MBit/s speed. Have to bring lappy into living room to connect. Could be better, but WTH, I am running Linux, so thank you.

 

 

Edit: Nope, I need more tweak help. In Windows I'm getting 55 MB down and 15 up on Ookla Speedtest. Leap can't reach 5/1.

Edited by KurtBleach
Link to post
Share on other sites

what have you done so far to try and fix weak signal, slow connection?

 

did you try making the driver and did you add the file to modprobe.d?

 

i take it everything else works fine and it's only wifi your having problems with.

 

:b33r:

Link to post
Share on other sites

I did add the file. Tried both ant_sel=2 & =1. Also, when I reboot or shut down there's a whole string of lines going by saying something like pcieport Receiver Error. Goes by too quick for me to follow.

Link to post
Share on other sites

to be honest from my understanding the ant_sel option makes no difference without first installing the newer driver.

instructions are open a terminal and enter each of these commands

git clone https://github.com/lwfinger/rtlwifi_new

you'll now see a new folder in your home directory called rtlwifi_new.

cd rtlwifi_new
git checkout rock.new_btcoex
make
sudo make install
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ips=0 ant_sel=0

see what it works like now.

if it now works fine then i think all you need in the config file is

options rtl8723be ips=0 ant_sel=0

if still have problems then try the ant_sel=1 or 2 and test each time.

:b33r:

 

you will need to follow instructions from the cd rtlwifi_new command every time your kernel is updated and breaks things so your wifi has a weak signal and the driver needs to be installed again to get a strong signal. (until of course the new kernel includes the latest driver. which is kernel 4.7 i believe.)

Edited by terry1966
Link to post
Share on other sites

Thank you for all your help, but Linux is banished from this machine. Too much hassle. I've followed directions from the Pit to the T, just ain't happening. Maybe HP and Linux don't mix. Maybe Leap 42 is buggy. Maybe it's just me. :)

 

I need this laptop to find my way around. Stranger in a strange city right now. The Windows works for now. I hate it (and needing Norton), but it is what it is for now. If I get back on my feet a bit, maybe I buy another lappy & whack Windows from it and just run Linux. But this dual boot is not working for me.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...