Jump to content

GPU not folding


dickster
 Share

Recommended Posts

Shows "failed" on F@H control. Log looks like....

 

 

00:31:55:WU02:FS01:Starting
00:31:55:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 02 -suffix 01 -version 704 -lifeline 1439 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
00:31:55:WU02:FS01:Started FahCore on PID 6790
00:31:55:WU02:FS01:Core PID:6794
00:31:55:WU02:FS01:FahCore 0x18 started
00:31:55:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
00:31:56:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:9412 run:161 clone:1 gen:12 core:0x18 unit:0x00000012ab40413a5535e2a6e2990a63
00:31:56:WU02:FS01:Uploading 1.91KiB to 171.64.65.58
00:31:56:WU02:FS01:Connecting to 171.64.65.58:8080
00:31:56:WU02:FS01:Upload complete
00:31:56:WU02:FS01:Server responded WORK_ACK (400)
00:31:56:WU02:FS01:Cleaning up
00:31:57:WU00:FS00:Starting
00:31:57:WARNING:WU00:FS00:Changed SMP threads from 4 to 3 this can cause some

 

How can I clear the gpu folder and let it download a new WU? Running Mint 17.

 

Link to comment
Share on other sites

dickster, in FahControl determine EXACTLY which Work Queue is the GPU, then shut down the client, then go to C:\Users\username (yours)\AppData\Roaming and locate the correct Work Queue (00, 01, 02, etc.) in the Work folder and delete it. (this is for "normal" installation)

 

 

 

 

:geezer:

Link to comment
Share on other sites

to be honest caintry been way to long since i've folded for me to really be of help, things have changed a lot since then, but as far as i remember my work folder was in a hidden folder in /home/terry/folding/ because that was where i'd setup fah.

 

see if this link helps :- https://foldingforum.org/viewtopic.php?f=67&t=21564

 

or maybe a better link :- https://foldingforum.org/viewtopic.php?f=88&t=25319

 

 

Just FYI, there is no GPUs.txt file on my Linux machine either. /var/lib/fahclient contain only the log.txt and the config, cores, logs, work, and .nv folders. But I only CPU fold on the machine in question.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

have you been able to locate the work folder? according to one of those links (and caintry) it should be in /var/lib/fahclient

 

it may be an hidden folder so you'd need to be able to view those by changing the view hidden file option.

 

then in the work folder just delete the corrisponding file like caintry said. ie. 00, 01, 02 depending on the position of your gpu folding in the client.

 

:b33r:

Link to comment
Share on other sites

In the work folder there is only one folder. That is 00 which is the cpu folding client. There is no folder for the gpu client. In the F@H control panel it shows the gpu as trying to download and then switches to failed.

Link to comment
Share on other sites

is there another work folder for the gpu maybe in the /var/lib/fahclient/nv folder?

 

:b33r:

 

just had a thought maybe there is no gpu folder yet because of course you said it is stuck trying to download a wu so maybe the 01 (or whatever) gpu folder doesn't actually get created until the gpu has some work to do.

 

i assume until this last problem wu, it was folding just fine with the gpu so maybe try stopping folding then completely disconnecting the pc from all power and then booting it again will fix any problems.

this will cold boot the gpu and clear any data/driver that may be stuck in it's memory and be causing a problem (which just a reboot wouldn't do.).

Edited by terry1966
Link to comment
Share on other sites

Terry, remember I had trouble like that once...Last year when I was running Linux on my rigs I was having the same basic trouble, like this:

********** Log Started 2014-07-05T18:30:14Z ***********************
18:32:37:WU01:FS01:Connecting to 171.67.108.201:80
18:32:37:WU01:FS01:Assigned to work server 171.67.108.52
18:32:37:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.67.108.52
18:32:37:WU01:FS01:Connecting to 171.67.108.52:8080
18:32:37:WU01:FS01:Downloading 1.52MiB
18:32:39:WU01:FS01:Download complete
18:32:39:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9201 run:294 clone:0 gen:64 core:0x17 unit:0x000000426652edc45399e1998a4f0131
18:32:39:WU01:FS01:Starting
18:32:39:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 01 -suffix 01 -version 704 -lifeline 4311 -checkpoint 30 -gpu 0 -gpu-vendor nvidia
18:32:39:WU01:FS01:Started FahCore on PID 4364
18:32:39:WU01:FS01:Core PID:4368
18:32:39:WU01:FS01:FahCore 0x17 started
18:32:40:WU01:FS01:0x17:*********************** Log Started 2014-07-05T18:32:39Z ***********************
18:32:40:WU01:FS01:0x17:Project: 9201 (Run 294, Clone 0, Gen 64)
18:32:40:WU01:FS01:0x17:Unit: 0x000000426652edc45399e1998a4f0131
18:32:40:WU01:FS01:0x17:CPU: 0x00000000000000000000000000000000
18:32:40:WU01:FS01:0x17:Machine: 1
18:32:40:WU01:FS01:0x17:Reading tar file state.xml
18:32:40:WU01:FS01:0x17:Reading tar file system.xml
18:32:40:WU01:FS01:0x17:Reading tar file integrator.xml
18:32:40:WU01:FS01:0x17:Reading tar file core.xml
18:32:40:WU01:FS01:0x17:Digital signatures verified
18:32:40:WU01:FS01:0x17:ERROR:exception: Bad platformId size.
18:32:40:WU01:FS01:0x17:Saving result file logfile_01.txt
18:32:40:WU01:FS01:0x17:Saving result file log.txt
18:32:40:WU01:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
18:32:41:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
18:32:41:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9201 run:294 clone:0 gen:64 core:0x17 unit:0x000000426652edc45399e1998a4f0131
18:32:41:WU01:FS01:Uploading 1.84KiB to 171.67.108.52
18:32:41:WU01:FS01:Connecting to 171.67.108.52:8080
18:32:41:WU02:FS01:Connecting to 171.67.108.201:80
18:32:41:WU01:FS01:Upload complete
18:32:41:WU01:FS01:Server responded WORK_ACK (400)
18:32:41:WU01:FS01:Cleaning up
18:32:41:WU02:FS01:Assigned to work server 171.67.108.52
18:32:41:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.67.108.52
18:32:41:WU02:FS01:Connecting to 171.67.108.52:8080
18:32:42:WU02:FS01:Downloading 1.53MiB
18:32:44:WU02:FS01:Download complete
18:32:44:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:9201 run:68 clone:0 gen:58 core:0x17 unit:0x0000003d6652edc45399d8b39ee37571
18:32:44:WU02:FS01:Starting
18:32:44:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 02 -suffix 01 -version 704 -lifeline 4311 -checkpoint 30 -gpu 0 -gpu-vendor nvidia
18:32:44:WU02:FS01:Started FahCore on PID 4371
18:32:44:WU02:FS01:Core PID:4375
18:32:44:WU02:FS01:FahCore 0x17 started
18:32:44:WU02:FS01:0x17:*********************** Log Started 2014-07-05T18:32:44Z ***********************
18:32:44:WU02:FS01:0x17:Project: 9201 (Run 68, Clone 0, Gen 58)
18:32:44:WU02:FS01:0x17:Unit: 0x0000003d6652edc45399d8b39ee37571
18:32:44:WU02:FS01:0x17:CPU: 0x00000000000000000000000000000000
18:32:44:WU02:FS01:0x17:Machine: 1
18:32:44:WU02:FS01:0x17:Reading tar file state.xml
18:32:44:WU02:FS01:0x17:Reading tar file system.xml
18:32:44:WU02:FS01:0x17:Reading tar file integrator.xml
18:32:44:WU02:FS01:0x17:Reading tar file core.xml
18:32:44:WU02:FS01:0x17:Digital signatures verified
18:32:44:WU02:FS01:0x17:ERROR:exception: Bad platformId size.
18:32:44:WU02:FS01:0x17:Saving result file logfile_01.txt
18:32:44:WU02:FS01:0x17:Saving result file log.txt
18:32:44:WU02:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
18:32:44:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
18:32:45:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:9201 run:68 clone:0 gen:58 core:0x17 unit:0x0000003d6652edc45399d8b39ee37571
18:32:45:WU02:FS01:Uploading 1.84KiB to 171.67.108.52
18:32:45:WU02:FS01:Connecting to 171.67.108.52:8080
18:32:45:WU01:FS01:Connecting to 171.67.108.201:80
18:32:45:WU02:FS01:Upload complete
18:32:45:WU02:FS01:Server responded WORK_ACK (400)
18:32:45:WU02:FS01:Cleaning up
18:32:45:WU01:FS01:Assigned to work server 171.67.108.52
18:32:45:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.67.108.52
18:32:45:WU01:FS01:Connecting to 171.67.108.52:8080
18:32:45:WU01:FS01:Downloading 1.52MiB
18:32:47:WU01:FS01:Download complete
18:32:47:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9201 run:334 clone:0 gen:58 core:0x17 unit:0x000000406652edc45399e32c58a9c017
18:32:47:WU01:FS01:Starting
18:32:47:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 01 -suffix 01 -version 704 -lifeline 4311 -checkpoint 30 -gpu 0 -gpu-vendor nvidia
18:32:47:WU01:FS01:Started FahCore on PID 4378
18:32:47:WU01:FS01:Core PID:4382
18:32:47:WU01:FS01:FahCore 0x17 started
18:32:48:WU01:FS01:0x17:*********************** Log Started 2014-07-05T18:32:48Z ***********************
18:32:48:WU01:FS01:0x17:Project: 9201 (Run 334, Clone 0, Gen 58)
18:32:48:WU01:FS01:0x17:Unit: 0x000000406652edc45399e32c58a9c017
18:32:48:WU01:FS01:0x17:CPU: 0x00000000000000000000000000000000
18:32:48:WU01:FS01:0x17:Machine: 1
18:32:48:WU01:FS01:0x17:Reading tar file state.xml
18:32:48:WU01:FS01:0x17:Reading tar file system.xml
18:32:48:WU01:FS01:0x17:Reading tar file integrator.xml
18:32:48:WU01:FS01:0x17:Reading tar file core.xml
18:32:48:WU01:FS01:0x17:Digital signatures verified
18:32:48:WU01:FS01:0x17:ERROR:exception: Bad platformId size.
18:32:48:WU01:FS01:0x17:Saving result file logfile_01.txt
18:32:48:WU01:FS01:0x17:Saving result file log.txt
18:32:48:WU01:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
18:32:48:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
18:32:48:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9201 run:334 clone:0 gen:58 core:0x17 unit:0x000000406652edc45399e32c58a9c017
18:32:48:WU01:FS01:Uploading 1.84KiB to 171.67.108.52
18:32:48:WU01:FS01:Connecting to 171.67.108.52:8080
18:32:49:WU02:FS01:Connecting to 171.67.108.201:80
18:32:49:WU01:FS01:Upload complete
18:32:49:WU01:FS01:Server responded WORK_ACK (400)
18:32:49:WU01:FS01:Cleaning up

dickster make sure you have the Nvidia drivers installed in Mint, in Suse Terry and I had to go in and make certain that the correct ones were installed.

See if that helps bro'.....

 

Fold On!

 

 

 

 

:geezer:

Link to comment
Share on other sites

i don't think you need the cuda drivers any more caintry if my memory isn't playing me up, pretty sure i read that somewhere so the normal nvidia driver in the repo's should work for linux gpu folding.

 

:b33r:

 

I do believe you're correct Terry...I think all I jneeded was the Nvidia stuff...

 

 

 

 

:geezer:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...