Jump to content

Change Mode

Help! One wireless problem and one problem that's more difficu

Recommended Posts

Problem 1) The PC is a Windows 7, 8GB RAM, desktop with Avast Antivirus, and Zone Alarm firewall. A few weeks back, I moved from Talk Talk to Virgin, and got a much faster download speed (50Mb/s). My PC doesn't have a wi-fi built in, so I had to buy a PCI wi-fi adaptor (made by Tenda), installed it, installed the driver from the CD, it detected the Virgin signal, I entered the passkey, and everything was great. I tried a couple of broadband speed websites (such as http://www.speedtest.net/ and http://www.broadbandspeedchecker.co.uk/) and they reported that my speed was 50Mb/s

But a few days back, the internet connection started to run slowly, so I tried the broadband websites, and they said I was only getting ~5Mb/s. I've not changed anything hardware or software-wise on the PC (other than the manditory updates to Windows and virus killer, etc).

I used my tablet (w-fi, of course) and it said that I was still getting 50Mb/s, so the problem was obviously with my desktop.

So I phoned Virgin, who couldn't find a fault over the phone, so they sent a bloke around, who checked the router (it was working, plus his device got the full speed over the wi-fi from it), and he connected a cable from the router to my desktop (which I couldn't do, since the desktop is upstairs, the router downstairs), and even by wire the desktop only got 5Mb/s, even though when stood next to the desktop, both my tablet and his phone/whatever got full speed via wire-less. So presumably the problem is not the wire-less PCI card or it's driver, since even if we use a cable then the desktop still only gets 5Mb/s.

I've uninstalled Avast! Antivirus (although I didn't think it would be that), and it's not helped, and I disabled Zone Alarm, and still no change.

Any ideas would be appreciated.

Problem 2) Anyway, every couple of months I create a 1:1 copy of my C: drive using Acronis Home Image (I used to use Norton Ghost years ago, until I discovered Achronis). So I thought I'd just put on my latest C: drive back up, and if it read the broadband at full speed, then I'd use that installation, and update the programs manually.

So I recovered the last backup, from a month or so back, and everything worked except the net connection. There was no wi-fi icon in the Windows 7 task bar (the ascending slopes made up of vertical columns), just the square with a plug icon that you get pre-wireless era. And when I try to access wi-fi, I get told that there are no wireless connections available. The driver for the PCI wi-fi dongle was installed (I must have made this backup not much after I went over to Virgin) but Windows wasn't showing the wi-fi icon.

I uninstalled and reinstalled the driver, but still no joy. Windows says that the device (the PCI network connector) is working perfectly, and Device Manager marks it as working (no yellow exclamation mark).

I went to my two earlier backups, neither of which have the wi-fi card driver installed, so I installed it, with the same result; no wi-fi icon in the task bar, and Windows says it can't find any wireless connections. So of course I though that the wi-fi card might have broke, or had some sort of setting disabled, but fortunately, before I'd reinstalled the backups of C:, I made a backup today, with the problem I describe in problem 1, so I reinstalled that backup (from today), and now the wi-fi card is working, although for whatever reason the PC is still only getting 5Mb/s.

So I installed the earlier backups, and no matter what I do, I can't get the wireless to work with those. And it *definitely* worked in the first backup before I made that backup (it worked and so I decided to make that backup, I wouldn't have made that backup back then if the wi-fi hadn't been working, I'd have fixed the problem first), so I don't know what the problem is.

Again, any light shone on this problem would be much appreciated.

Details of the adapter are:

802.11n.Wireless LAN


Device Type: Network adapters

Manufacturer: Ralink Technology, Corp.

Location: PCI bus 1, device 8, function 0

Driver Provider: Ralink Technology, Corp.

Driver Date: 19/04/2011

Driver Version:

When I use


in both backups (the modern one I made today, which is of course the one where broadband works but only at 5Mb/s, and also the backup from a month or so ago, where the broadband can't be read for some reason) then I get the same values in all of the tabs, except that the IRQ is listed in the


tab in the working (but slow) backup as 0x00000013 (19) whereas in the broadband-not-working backup, the value is 0x00000011 (17)

Windows won't let me edit the entry (in the tab's box, I don't know where else to edit it).

Can anyone help, please.

Apologies if I haven't explained this too clearly. Basically,

1. For some reason, my desktop has stopped receiving broadband (via wireless) at 50MB/s, it's now around 5MB/s. Other wireless devices still receive it at 50MB/s, so it's not the router, it's the desktop (as confirmed by the engineer who Virgin sent, and who wasn't allowed to make changes to my PC, only to the router). Even wired up to the router, the desktop only reads 5MB/s, which makes me think it's not the wireless itself at fault.

2. I've done a clean boot (from an Avast! CD) and scanned the PC, no viruses or malware. I've reset the router. The desktop still only downloads at 5Mb/s, whilst my tablet downloads at 50Mb/s (this is according to various "how fast is my broadband?" site.

3. I have various backups, from a month back, total images of my C: drive. So I thought I'd reinstall one of those, as that would surely not include whatever corrupted file or wrong setting that is causing the problem now. So I first made a backup of the current state, in case I needed to go back, then put the last backup on my PC. But for some reason, that backup (and the two earlier ones) will not see any wi-fi connections, even though I've reinstalled the wi-fi driver, but there's no wi-fi icon in the task bar.

I'll include all available data that I think might be important, in the next post (it's long!)

Link to post
Share on other sites

[Continued from the above post]

In today's backup (which was made of the original state, with the 5Mb/s download speed) which I've put back on to check that the wi-fi works (it does) the settings for the connection are:

IPv4 Connectivity: Internet

IPv6 Connectivity: No Internet Access

Media State: Enabled

SSID: [it does show this right, but I won't post it here]

Duration: [shows the right duration]

Speed: 26.0 Mbps [Note that this is wrong by about 21 Mb/s]

Signal Quality: [Five green bars in the shape of the wi-fi icon]

When I click Details, I get:

Connection-specific DNS Suffix:

Description: 802.11n Wireless LAN Card

Physical Address: ‎C8-3A-35-CA-3B-97

DHCP Enabled: Yes

IPv4 Address:

IPv4 Subnet Mask:

Lease Obtained: 04 November 2015 20:24:37

Lease Expires: 06 November 2015 11:25:46

IPv4 Default Gateway:

IPv4 DHCP Server:

IPv4 DNS Servers:,

IPv4 WINS Server:

NetBIOS over Tcpip Enabled: Yes

Link-local IPv6 Address: fe80::f099:2ee6:2777:5a72%17

IPv6 Default Gateway:

IPv6 DNS Server:

When I click on Wireless Properties, I get a box with two tabs. The Connection tab


Name: [shows the right name]

SSID: [shows the right name]

Network Type: Access Point

Network Availability: All Users

Connect automatically when this network is in range [Ticked]

Connect to a more preferable network if available [Not ticked]

Connect even if the network is not broadcasting it's name [Not ticked]

and the Security Tab says:

Security type: WPA2-Personal

Encryptions type: AES

Network security key: [shows it OK]

and if I click Advanced Settings, then I get a box with one option:

802.11 settings

Enable Federal Information Processing Standards (FIPS) compliance for this network

If I click on Properties (from the General box) then I get:

Connect Using:

802.11n Wireless LAN Card

This connections uses the following items

Client For Microsoft Networks [Ticked]

QoS Packet Scheduler [Ticked]

File and Printer Sharing for Microsoft Networks [Ticked]

Internet Protocol Version 6 (TCP/IPv6) [Ticked]

Internet Protocol Version 4 (TCP/IPv4) [Ticked]

And the settings for TCP/IPv4 are:

Obtain an IP address automatically [Ticked (well, it's a black spot in the option


Use the following IP Address [Not ticked, and no numbers in the IP Address/Subnet

Mask/Default Gateway options]

Obtain DNS server address automatically [Not ticked]

Use the following DNS server addresses [Ticked]

Preferred DNS server:

Alternate DNS server:

Validate settings upon exit [Not Ticked]

And the settings for TCP/IPv6 are:

Obtain an IPv6 address automatically [Ticked]

Use the following IPv6 address [Not Ticked, and the IPv6 Address, Subnet prefix length, and Default Gateway are all blank]

Obtain DNS server address automatically [Ticked]

Use the following DNS server addresses [Not Ticked, and Preferred DNS serve, and Alternate DNS server are both blank]

Validate Settings upon exit [Not Ticked]

Link to post
Share on other sites

Copy and paste these lines in Note pad:


@Echo on
attrib -h -s -r hosts
echo localhost>HOSTS
attrib +r +h +s hosts
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0


Save as flush.bat to your desktop.
Double click on the flush.bat file to run it. Vista and Windows 7... right click the .bat file and choose to run as Administrator. Your computer will reboot itself.

Link to post
Share on other sites
First of all, sorry for not updating sooner, but I've not done anything on the PC (life at the moment is really hectic and I've not been in the mood for PC problems.). I've not tried to fix the PC (not format and reinstall, not take the PC downstairs and connect it via the router, etc) but the last time I touched the PC I started to download a file (a 41GB complete run of a British drama program) to see how fast the downloads were, and because I wanted the TV program (it would also mean having to find out where all the torrent data was stored, to save and restore after any re-format or Acronis image backup restoration, but that was a problem for tomorrow...). I can't remember what the download speed was, but it must have been slow or I'd have taken note and commented on it.

Anyway, today I got home early, so I thought I'd take my desktop downstairs and connect it to the router to see if the speed would increase. But I'd left my PC on over the past few nights, to download the torrent, and to my amazement, the entire torrent has downloaded! 41GB (and I checked some files at random, they do play, the PC hasn't just created empty or corrupt files). I wouldn't have thought this was possible given how slow the download speed had been.

I used speedtest.net and it showed the speed as:

17.47Mbps (small 'b' in 'Mb')

even though I'd done nothing (literally nothing, not even reset the PC) since the I'd given up (for the time being) trying to fix the problem and instead left the 41GB torrent to load.

So to test things, I queued up a lot of torrents to download (films, regardless of age or type, just ones with a good amount of seeders, to give large files that had lots of seeding) and I downloaded a program to show what speeds the downloads are at (Networx, it's free and seems to do what's required, though for all I know a different program might be much better), and I ran it over four hours or so, and I copied and pasted the results from the real-time graph into this image twenty-five times:






and here's the Speed Meter window:


I don't understand this. First of all, how come the speed varies so hugely? And there's surely no way my maximum download speed has been 247MB/s (as the Speed Meter says), is that speed even possible if you have a fast enough router (mine is the router that Virgin installed, so I assume it has a maximum speed of 50+)? And all the peaks (which seem too high and too brief to be anything but glitches) in the Network graph windows, and the drops to almost 0, are they normal, do they occur in all broadband connects and just represent a very brief period where the PC waits for the signal to catch up? A couple of times, the graphs list the speed as between 20 and 40MB/s (and the very brief spike seems around the 30 area) which is a big jump from the other speeds.

Is there a file I can download from somewhere that has a guaranteed download speed of at least 50Mb/s, so I can test the download speed using Network, please? And any ideas or theories ot explain this, please?

Link to post
Share on other sites
  • 3 weeks later...

I'm sorry that I've not replied here sooner, please don't think I've fixed the problem and neglected to post the solution or thank anyone who helped. I've not done anything re: the problem due to real life problems and hardly being at home over the past couple of weeks. I'll post again when things calm down, and if anyone is kind enough to still care then hopefully you can help me address this problem. I wish PC problems or any possession's problems were the only trouble life ever threw at us.

Link to post
Share on other sites

First up torrents and P2P programmes are not a good way to judge your d/l or u/l speeds as the speed you can download a torrent at is restricted by the number of people in the swarm and the speed they can share chunks to you. You could be on 100/mbs fibre but if I can only get a torrent out to you at 5/kbs that's all you are going to get!!


You need to run something like 'Speedtest' with nothing else running to see what your actual sppeds are. Try running it at different times of the day to see if Virgin are throttling your service. Not sure how to do it; but you need to check the speed your PC is connecting to the router not just the speed your router is connecting to the internet.


My first test would be to connect it wired and see if this makes a difference; try replacing the wireless card (they are only around £10 from maplins for a decent one).


Start eliminating areas that might cause a slowdown.


Thickness of walls; mobile phone signals; microwave oven signals; overlap from a neighbours router on the same channel as yours....all these things will have an impact.



Stop downloading torrents; who knows what nasties you have or are sharing!!

Link to post
Share on other sites

from a quick read personally i don't think there is a speed issue except for the fact it's probably your isp throttling your connection at certain times because of their fair usage policy.


just for info, if your max internet connection speed is 50 Mb/s download then that is 6.25 MB/s because there are 8 "b"its in a "B"yte and is the absolute maximum data transfer speed you'd get.


it doesn't matter if a pc is connected to the router by 100MB/s or 1GB/s lan connection or by wireless with say a 300MB/s connection, the extra speed bandwidth will only come into play when transfering data between 2 pc's on your local network and not when connecting/transfering data to/from the internet.


so the speed meter reading of 275MB/s is most definitely possible but only between 2 local pc's and has nothing to do with your real internet connection speed of 50 Mb/s.


my internet connection download speed is 16Mb/s so when i download a large file say a linux dvd iso of about 4GB i get a speed of around 1.9/2 MB/s and it takes about 40 minutes. :- here's a direct link to opensuse's leap dvd iso which is 4.3GB in size :- http://download.opensuse.org/distribution/leap/42.1/iso/openSUSE-Leap-42.1-DVD-x86_64.iso see what speed you get when you download it.



Edited by terry1966
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...