Jump to content

Installation Troubles


JustinP526
 Share

Recommended Posts

Been trying to get Linux on my machine for a while now (about 2 months) and it's been nothing but a headache.

LiveDVD boots up and gets to desktop, but the instant I click anything the machine reboots. Got it to open terminal on last attempt, but then the machine rebooted as soon as I tried to type. Tried from 4 different DVDs that I had burned out. All of them burned just fine (at lowest speed of 4x) and all checked out perfectly on hash checks. I've got:

OpenSUSE 13.1 KDE 64 bit

Mint 17.1 Cinnamon 64 bit

Mint 17.1 KDE 64 bit

Ubuntu 64 bit (forget which version)

 

I see OpenSUSE is now at 13.2 and Mint is now at 17.2 so the discs I have are not the latest. Shouldn't be a huge problem since it could be updated after install, right?

 

This is the machine I'm using:

http://www.bestbuy.com/site/cybertronpc-assault-a46-desktop-amd-a4-series-4gb-memory-500gb-hard-drive-black/9476171.p?id=1219418158123&skuId=9476171

 

It runs on this motherboard:

http://www.newegg.com/Product/Product.aspx?Item=N82E16813130762

 

In system setup I see it is set as UEFI + Legacy and Fast Boot and Windows 8 thing are disabled. Do I need to set BIOS for Legacy only for everything to work without auto rebooting?

 

Also, if recommended, I could just download the latest versions and try to install from USB flash drive. Never done that method before, but I can look it up to be sure I have the drives formatted correctly and set the right settings.

Link to comment
Share on other sites

 

LiveDVD boots up and gets to desktop, but the instant I click anything the machine reboots. Got it to open terminal on last attempt, but then the machine rebooted as soon as I tried to type.

sounds to me like you have hardware problems, maybe ram or power issues, so until you find and fix those i doubt installing any os is going to be successful long term.

 

personally i'd download the latest 64bit live kde from opensuse create a bootable usb stick with the iso, boot that and see if you still have any problems if you do then i'd say that would confirm to me there are hardware issues with your build.

 

:b33r:

Link to comment
Share on other sites

Well I've got latest version of Ultimate Boot CD, so I can run some utilities from there to test RAM, HDD. No access to PSU tester, so best I could do is put my old analog VOM across the the power leads of each connector and test for voltage. In BIOS it shows voltages at the proper numbers and within the ATX spec for tolerance. Aside from that, no clue how I would be able to test for problems elsewhere.

 

I can still try the bootable usb stick, but doubt it will work. Tried every option in BIOS and nothing seems to make any difference. It can be set to either UEFI or UEFI+Legacy (no option for Legacy Only) and boot order I set optical drive first, there is 2 options for that.. UEFI DVD/CD or DVD/CD [LG CD/DVD-RW] (I assume the second one is the same thing but in legacy mode). Had same results from using either option. It will boot to desktop and then just reboot.

 

This machine is only 6 months old, already been repaired once.... how are these newer machines supposed to be "better"? My old 478 Pentium 4 builds lasted 10 years and never gave this kind of trouble. Those only gave problems when the chipsets finally fried.

Link to comment
Share on other sites

OK so I ran Memtest 86+ v5.01 and Vivard 0.4

None of the other HDD tests on Ultimate Boot CD are listed for Toshiba drives. Seatools reported 'no hard drive detected' and Vivard was the only one that would see a drive and scan it.

 

Memtest showed no errors of any kind, these are the details it showed:

 

CLK: 3706 MHz (X64 Mode) CPU Temperature 28*C - 35*C

L1: 64K 34637 MB/s

L2: 1024K 28954 MB/s

L3: NONE

Memory: 3272M 4417 MB/s

Core: #0 (SMP: Disabled)

Cores: 1 Active / 1 Total (Run:All)

RAM: 760 MHz (DDR3-1520) -BCLK: 95

Timings: CAS 11-11-11-28 @ 128 bit mode

 

Memory SPD info

-Slot 0: 4096 MB DDR3-1600

Crucial CT51264BA160BJ.8F1

 

Vivard HDD scan got as far as 2% in when it reported 8 [uncorrectable] errors. Total error count at the end of the test was 8, so no more were found from there.

 

I was told on the Mint forums that it could be due to MSI/AMD combos I'm guessing something with the Radeon graphics. I'm looking over the bug report now.

http://forums.linuxmint.com/viewtopic.php?f=46&t=196324

Link to comment
Share on other sites

the hard drive makes no difference when running a live cd because it doesn't get used at all, try the opensuse live kde first and see if it also reboots when using it after getting to the desktop, if it does then i'd guess you have a hardware problem, and you can rule out hard drive and ram now as the source of the problem.

 

do you have any problems when booted into the windows os? try running something like speccy, coretemp, amd overdrive or any other monitoring tools you may have/use and check what it says for temps and voltages and see if they may be problematic and the cause of the reboots when running a live cd.

 

:b33r:

 

make sure you have the latest bios installed for your motherboard also do you have any overclock? go into uefi and set optimised defaults and save and exit just to rule out a bad uefi setting.

 

well i read the bug report and it seems it was a kernel issue so if you get the newer media than what your using if that is the problem your having then that should fix it, so like i've said before try the latest live kde first and see what happens.

Edited by terry1966
Link to comment
Share on other sites

The only trouble I'm having in Windows is wireless internet keeps dropping off to 0 bps and won't load websites in any browser. I end up having to wait 5 minutes for it actually show any thoughput on a good connection. I can't get any work done with it acting up like this.

 

NO overclock, I don't even know how to do that. The APU is 3.7GHz stock with a 3.9GHz turbo, but that is automatic.

I have already set defaults in system setup.

 

Speccy shows voltages within ATX spec range. Had Speedfan installed but it kept showing voltage and temperature with negative values. Uninstalled it, but it still shows Speedfan stuff in start menu under apps or whatever this new style junk is on 8.1

Can try others and see what shows, hadn't done so yet due to I don't know any other programs/utilities for that.

Link to comment
Share on other sites

yep, think i may have missed edits.

 

msi site shows latest bios as 32.8 with a date of 2014-12-12

don't remember which is already on this board, but it's not the latest one. no idea how to update it though. there is a live update feature, but not sure that works over wifi. no floppy drive and i don't have any clue what other methods or how to do so.

all of the available bios updates say "updated AMD AGESA code" and a few say "improved memory compatibility"

also some about "improved VGA compatibility" and one with "improved USB compatibility"

 

not sure if the ones on VGA mean when using APU and onboard VGA/HDMI port or when using GPU card in PCIe slot

 

what i was confused by with memtest is that it shows memory @ 128 bit mode. but it's in single channel since only 1 stick installed. thought single channel is 64 bit mode

does that mean if i put 2 sticks for dual channel it would go up to 256 bit mode?

 

i was hoping to go with mint since i have trouble getting wireless adapter to work in Linux. it uses Realtek rtl8192cu chip just like my Asus usb-n13 did. got that one working before in ubuntu and mint only by running a dkms module. i like opensuse, but always have trouble using wireless and it's not easy to fix just changing setting in yast.

Link to comment
Share on other sites

 

what i was confused by with memtest is that it shows memory @ 128 bit mode. but it's in single channel since only 1 stick installed. thought single channel is 64 bit mode

does that mean if i put 2 sticks for dual channel it would go up to 256 bit mode?

 

no, 128bit is dual channel mode, and that's what the bios is set at probably but of course seeing how you only have a single stick of ram then it will only be using 64 bits on a single read/write out of the 128 bits it's capable of using.

 

256bit would be quad channel memory on a 64bit system.

 

 

msi site shows latest bios as 32.8 with a date of 2014-12-12

don't remember which is already on this board, but it's not the latest one. no idea how to update it though. there is a live update feature, but not sure that works over wifi. no floppy drive and i don't have any clue what other methods or how to do so.

all of the available bios updates say "updated AMD AGESA code" and a few say "improved memory compatibility"

also some about "improved VGA compatibility" and one with "improved USB compatibility"

yes if you don't know what your doing then use the msi live update feature/program and it should work just fine to update your bios even on wifi.

 

 

i was hoping to go with mint since i have trouble getting wireless adapter to work in Linux. it uses Realtek rtl8192cu chip just like my Asus usb-n13 did. got that one working before in ubuntu and mint only by running a dkms module. i like opensuse, but always have trouble using wireless and it's not easy to fix just changing setting in yast.

no problem get the latest mint and try that AFTER you've updated your bios.

 

if you still have the reboot problem then also test with the latest opensuse live kde, that way you can rule out a distro specific problem.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Jumping in late here; but I had the same issue trying to install SUSE either in legacy or UEFI mode; turned out to be the video driver.

 

In legacy mode; on the screen where you choose to install SUSE; select F3 (NoKMS) and mine then ran fine.

 

Also AMD board.

Link to comment
Share on other sites

not sure if that's the same problem nigsy, did your system reboot as well? must admit any time i've had a graphics problem i don't remember the machine ever rebooting especially after getting to a desktop.

 

if it is the same problem justin then adding nomodeset to the kernel options of whatever distro your going to try, (in other words at the end of the line that starts linux when you edit the boot menu.) will do the same thing as nigsy did by using the F3 and NoKMS option in suse to fix the problem.

 

:b33r:

Link to comment
Share on other sites

not sure if that's the same problem nigsy, did your system reboot as well? must admit any time i've had a graphics problem i don't remember the machine ever rebooting especially after getting to a desktop.

 

if it is the same problem justin then adding nomodeset to the kernel options of whatever distro your going to try, (in other words at the end of the line that starts linux when you edit the boot menu.) will do the same thing as nigsy did by using the F3 and NoKMS option in suse to fix the problem.

 

:b33r:

 

It was rebooting after I selected the timezone in the setup; not from desktop.

 

Couldn't get the nomodeset to work so stayed on legacy boot.

Link to comment
Share on other sites

OK, so my current bios is V32.7 (2014-10-21) and the latest one is V32.8 (2014-12-12). Update to latest will update AMD AGESA code.

Also noticed in bios on the main page it shows Current DRAM frequency 1600 MHz, thought it should be 800 MHz (had a bit of a discussion on that in folding sub forum). That false advertising sure goes a long way :laughing:

 

Also checked the Hardware Monitor while I had the bios up and it shows the following.

CPU Temp 34*C

Mobo Temp 23*C

CPU core 1.016v - 1.024v

CPU NB 1.096v - 1.104v

DRAM 1.504v - 1.512v

System/3.3V 3.312v - 3.328v

System/5V 4.998v - 5.040v

System/12V 12.056v - 12.144v

 

I've already seen Speccy show the CPU temp get as high as 83*C with folding running on maximum, so had to drop it to medium to keep temp at a max of 72*C (even that's a bit high).

Hoping to get a Hyper 212 Evo really soon as the stock supplied cooler is really no help at all. Maybe a couple more case fans too if possible (still have space for up to 3 more 120mm)

 

This is what I was told to do (from Mint forum)

 

 

Some of the people posting there said they had luck adding "radeon.dpm = 0" to the boot parameters. Try that and see if it fixes problem.
  • Boot with live DVD
  • At menu, hit <TAB> key to edit boot parameters
  • after the "--" (at end of line shown), hit <Spacebar> once, then type "radeon.dpm = 0" (without the quotes)
  • hit <ENTER> key to boot

 

Link to comment
Share on other sites

Think I'm all set to go. Any recommendation on formatting USB drive? Do I need a special application to make bootable USB drive in Windows 8.1?

 

I'm following the directions here

https://en.opensuse.org/SDB:Create_a_Live_USB_stick_using_Windows

 

Tried ImageUSB, seems simple enough.

The OpenSuSE KDE Live iso is just under 1GB so figure I'll use a 2GB flash drive and it should go no prob.

Well the flash drive is a Sandisk Cruzer. Had U3 software on it (royal pain in the rear), but I got that removed (easier than I had figured).

Windows Disk Management still shows 20MB of "unallocated" partition on the drive, nothing remains on it however. Right clicked the drive and chose 'Format'

I left the check box uncheck for quick format so that it would fix any errors if applicable. Formatted it for FAT32, is that right? I have no clue what the difference is or if a different type of format would have been better, worse, made any difference at all.

 

It's really sad that all the years I had to take computer classes in school (from middle school up to community college) they never taught a single bit on actual computer stuff. Middle school had some old Macs that ran 133MHz Intel CPUs and most they taught was how to turn it on and how to play SimCity. High school we had slightly better machines, probably running P3s but the most they taught was how to browse the web. College class (CIS101 Intro to Computer Information Systems) they just had us typing junk from a book and printing it out (class on how to waste paper I guess).

Edited by JustinP526
Link to comment
Share on other sites

so what happened? was you able to boot the live kde to a desktop and did it crash or run fine?

 

if your still unable to create a bootable usb stick try using rufus :- https://rufus.akeo.ie/

 

follow the guide below but of course you'll be using the linux iso and not windows 10.

 

depends on your uefi settings but you either need to use GPT partition scheme for UEFI. or MBR partition scheme for BIOS or UEFI-CSM. where applicable.

 

 

A) Set Rufus using the settings below, click/tap on Start, and go to step 8 below. (see screenshot below)

  • Under Device, select the USB flash drive you want to format and use.
  • Under Format Options, check Create a bootable disk using, select the ISO Image option, click/tap on the browse icon 6706d1412912465-usb-flash-drive-create-i to navigate to and select your 64-bit Windows 10 ISO file, and then make sure that Standard Windows installation is selected (dotted).
  • Under Partition scheme and target system type, select GPT partition scheme for UEFI.
  • Under File system, select FAT32.
  • Under Cluster size, select the (Default) (ex: 4096 bytes) it has listed.
  • Under Format Options, check Quick format.
  • Under Format Options, check Create extended label and icon files.
  • Under New volume label, you can enter any name you like for the USB flash drive, or leave the default name.

 

guide :- http://www.tenforums.com/tutorials/2376-usb-flash-drive-create-install-windows-10-a.html

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Yep got Mint 17.1 to boot live after finding the error. It would boot to the first Mint splash screen with the 10 second count down. Had to do the following to get it to go:

 

 

 

Some of the people posting there said they had luck adding "radeon.dpm=0" to the boot parameters. Try that and see if it fixes problem.
  • Boot with live DVD
  • At menu, hit <TAB> key to edit boot parameters
  • after the "--" (at end of line shown), hit <Spacebar> once, then type "radeon.dpm=0" (without the quotes)
  • hit <ENTER> key to boot

 

I don't have any clue about UEFI settings. I just know that I can bring up Disk Management in Windows and it shows HDD with 2 partitions. It shows Disk 0, Basic, online with 350MB as System Reserved NTFS and 465.42GB as C: NTFS and Layout Simple.

 

I have 2 Sandisk Cruzer flash drives that are 4GB each. One had some U3 software on it, but after removing that (per instruction on Sandisk site) it shows a separate 20MB partition as unallocated and doesn't seem I can use it. The main part that is ~4GB formatted fine as FAT32, I think the other choices were MS-DOS, FAT and NTFS.

The other flash drive won't format, just gives an error saying it's not a Windows recognized format. No idea why, it's only been used in a Windows machine before.

 

I will try with rufus and see if it gives better results. Finishing up now with making sure I've got all data backed up. Not too worried about losing Windows, worst case scenario I got a Windows 8.1 DVD with the machine so would just have to do a fresh install.

Link to comment
Share on other sites

 

Yep got Mint 17.1 to boot live after finding the error. It would boot to the first Mint splash screen with the 10 second count down. Had to do the following to get it to go:

 

Quote

 

 

Some of the people posting there said they had luck adding "radeon.dpm=0" to the boot parameters. Try that and see if it fixes problem.

  • Boot with live DVD
  • At menu, hit <TAB> key to edit boot parameters
  • after the "--" (at end of line shown), hit <Spacebar> once, then type "radeon.dpm=0" (without the quotes)
  • hit <ENTER> key to boot

so if mint works live, and you want mint installed then i don't see a reason to use rufus and create an opensuse usb, just use that exact same method (quoted above.) on the install mint option as you did with the boot live option, if you haven't already installed mint by now.

 

:b33r:

Link to comment
Share on other sites

Just making last minute check to be sure I've got everything backed up and not lose something important!

 

Turns out the most trouble I had before was because there was a typo in the original help. The first time around it showed up saying to add "radeon.dpm = 0" (without quotes).

I had finally noticed while it was trying to boot live and there's the messages saying that it's loading kernel, ALSA, and various drivers it got to a point that mentioned something radeon related. It went by so quick I couldn't catch the whole message, but did notice the status showed <FAIL> in red text. Turns out I wasn't supposed to put spaces on either side of the = in that boot option!

 

I'm actually debating on trying OpenSuSE first since I'm hearing quite a bit about it being a much better distro choice for Compiz.

Link to comment
Share on other sites

Got both of my 4GB flash drives formatted and set as FAT32, not sure how the one showed as 3.78GB unallocated and not recognizable by Windows. All fixed, even got it going right with ImageUSB so now 1 drive has Mint 17.2 Cinnamon and the other drive has OpenSuSE 13.2 KDE.

 

Not sure I really understand this, but in Windows the USB drive shows as 1.86MB free of 3.97MB and yet the live OpenSuSE iso is 930,592KB (just under 1GB). Did it compress everything down to under 4MB?

 

Either way.. rebooted, set UEFI USB key as first boot option, save and exit BIOS. It rebooted and no more than 10 minutes later I had the OpenSuSE desktop up!! After all the trouble I had trying to get that far from DVD and it turns out that using USB key does all that in 10 minutes or less... WOW, I'm using USB key from now on!!!

 

Last check now to be sure I backed up everything I needed to. Next, a full install of OpenSuSE 13.2 KDE!!

From live run everything looked to be working just fine, only issue that may arise would be with wireless adapter. Not sure if bugs have been completely worked out for Realtek RLT8192CU chip. Can't imagine it will be too hard to fix either way, was able to do so in Ubuntu and Mint before.

Link to comment
Share on other sites

OK, went through the install process and now it won't boot from hard disk install. It will only boot up from the live USB key. From there I can bring up gparted and see the hard disk is set up with all the opensuse install that it did.

 

Choosing boot from HDD in the main live menu shows a list of 3 errors, but it goes by so fast I can't see any of it.

 

*edit*

Turns out I had to actually remove the USB flash drive so that it wouldn't try to boot from there first. Set BIOS to boot from HDD and it's now running fine!

Wifi connection is rather slow and drops off randomly, but working on the fix now.

 

What happened to the days of booting an installation disc and it just simply installed and started right up? Things should be getting simpler, not more complicated.

Edited by JustinP526
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...