Jump to content

Change Mode

Default Applications for LXSession not working correctly Lubuntu 14.04


Recommended Posts

Whenever I change a Default Application in LXSession from "Disabled" to a Program, such as LibreOffice Calc for the Spreadsheet, it always reverts back to "Disabled", or to some other Program, such as LibreOffice Math, which isn't even in the List. This also happens with the Image Viewer and the Audio Player. Both either revert back to "Disabled" or to some other Program which isn't even on the List. It doesn't matter if I reboot or log out and log back in or even if I change the Program manually, it still reverts back to "Disabled" or to some other Program not on the List.

In regards to the file: ~/.config/lxsession-default-apps/settings.conf

Any changes I make to this file are not being saved upon reboot or logging out and logging back in. Changes are saved prior to reboot or logout. However, upon logging back in or rebooting, no changes are saved and the entire file reverts back to the exact way it was prior to reboot or log out and so do the respective LXSession default Program issues.

Is there a way to fix this so the correct Program displays and doesn't revert back to "Disabled"?

Thank you for any assistance you may be able to provide.
Link to comment
Share on other sites

Not sure if this will work for you.....but what I do is do a 'save as' with the old config file and rename it for example:




I then recreate the original file by pasting the contents of settingsOLD into a new text editor, make my changes and then save it with the original name.

Remeber to do this as superuser / root to ensure the usergroup permissions stay with root.

Link to comment
Share on other sites

  • 3 weeks later...

Thank you so much for your advice! I actually uninstalled lxsession-default-apps. However, I will keep your suggestion handy! I read on the Ubuntu Forums that this specific Program is broken in Lubuntu 14.04. Uninstalling did not break anything at all. It appears the Program isn't really needed.


Thank you again!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...