Jump to content

Change Mode

does anyone know how to fix a Blu touchbook 7.0 , stuck on boot screen

Recommended Posts

I have a tablet like this one , http://www.youtube.com/watch?v=PF2f1ZYnTzY


when I press the power button , it gets to the boot screen , but gets stuck on the Blu logo and won't go any further.

I've tried all the reset methods I could find suggested on youtube, to no avail.


There was one youtuber which posted a tutorial on how to reset using a tool called android multi-tool, but the computer doesn't recognize the tablet , just says no device found when I try to use it.


I was just wondering if anyone knew if it was possible to boot this tablet from the micro SD card , if I could get the FW for it.


I suspect the OS is currupted , but I don't know how to go about re-installing the original OS.


If you think you've got a solution for this one, please let me know , I'm running out of things to try.



Link to post
Share on other sites

I'd say looking at the reviews for this; it's a piece of Chinese junk!!; but you have it now I guess.


Try powering it off completely; then:


Press together volume up; power....and hold both until you see a red warning triangle with a dead Android; press volume up and menu together and the recovery menu should appear.Use the volume key to navigate and the home or camera button to select. There should be an option for factory reset. Try that.

Link to post
Share on other sites

lol, it doesn't actually belong to me, someone I know asked me to try to fix it for her kid.


thanks for the suggestion, but unfortunately that didn't work. When I do what you suggested , the only thing that happens is the red power light comes on and stays on. If I just hold the power button alone it boots to the Blu logo and then it just hangs there.


BTW, how long would you need to hold the buttons? I just want to make sure I held it long enough. I waited for quite a while, though. Maybe close to a minute before I figured it wasn't going to work.

Link to post
Share on other sites

Maybe you need to hold the power and volume button down before you turn it off.

Hold the power button and the volume up button at the same time until the tablet shuts off. Press the power button and volume button at the same time until it turns back on. At this point you should see a robot laying down with a red triangle, now press either up or down on the volume keys. This should of brought up a menu. Use the volume buttons to scroll through the options choose factory reset by hitting the power on/off button. It will take you to a screen that says Factory Reset? Then it will list NO a bunch of times with one YES in the middle...use the volume up and down keys again to reach the YES listed and hit the power on/off button to choose YES. Wait and it will tell you when its finished resetting itself, after that power it off like normal, and power it back on like normal. It should act like the first time you ever turned it on.


Link to post
Share on other sites

still no luck with this piece of junk. Here's a link to a video I posted so you guys could see exactly what's happening with it. not much different than what I've described, but hopefully someone may spot something that will give me some clue as to why I can't get it to boot to the android logo so I can do the factory re-set.




I was also wondering, do you guys think the home button would even register when I'm pressing it , since it's not an actual button, like the volume button or the power button.


I did see a tutorial on youtube where the guy looked like he was able to re-install the original FW , but the video was in spanish ( at least I think it was spanish, lol)

the uploader's name is Deimer Vasquez, and his video just happens to show after the one I uploaded.


Anyone speak spanish , and could translate what he's saying for me? :)

Link to post
Share on other sites

Well I'm not sitting through that lot!!


What I did glean from it is;


Power the tablet off with volume up and power at the same time.

Let it switch off completly.

Power it on with volume up held and rapidly (muy rapido!) pressing the power button for about 15 secs.

Link to post
Share on other sites

tried all the methods suggested , still no luck. Done wasting time on this piece of junk.

Time to return it the the owner , and tell her it's time for the garbage, lol.


Thanks for trying , guys , can't win 'em all!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...