Jump to content

Recommended Posts

used overdrive for years. when launching overdrive, window opens that says" pc utility will gather data....etc" and screen stops.


will also not open when trying to running "old tests. System is vista home premium 32 bit"



checked FAQS and cookies and security at correct setting.

ActiveX installed and working correctly.

disabled firewall and antispyware settings. and still not working.


rand sfc/scannow as administrator from elevated prompt. OK


appreciate any ideas that will launch this.........have tried suggestion on troubleshooting page. nothing woeked.


reset security settings to default levels. Thanks in advance. will respond ASAP




Link to post
Share on other sites

Please run the Active X control removal tool from the link below:




First save the file above to your desktop, then right-click on the file and select, "Run as administrator". Once the removal tool completes, try OverDrive again and verify that it downloads a new Active X control.


Let us know how that goes.

Link to post
Share on other sites

Thanks to Intel Guy.

ran cmd tool as administrator per request


repair completed per tool.


restarted pc and logged in.


still nothing past page that opens and shows

pc status software malware performance drive health.


no hourglass showing tests running, just arrow. waited 20 minutes, still nothing.



Link to post
Share on other sites
  • 2 weeks later...

Re the suggestion of PC Matic Tech Dept. I reset the browser to default settings.


the program runs fin now.


this thread is closed.


Thanks to all for suggestions.




Glad to hear you got it working...! :clap:






Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...