Jump to content

Recommended Posts

Bought and installed pcmatic just fine on one computer...Downloaded the setup file to a second computer, and installed ok, but when I click on LOGIN , instead of coming up with the id and password field, I see the id/password block in the middle of screen, but it is completely blank inside and just an X in upper right corner to cancel.. in other words ,I cannot login!

Link to post
Share on other sites

I could also be an issue with the browser settings. At some point you may need to try resetting IE back to defaults.


What are you using for pop up blockers and other security software? There is something n the computer that is keeping the modal windows from loading/displaying completely.


If you go to the link below and login to OverDrive in the upper left, then open PC Matic are you now logged in?:



Link to post
Share on other sites
  • 2 months later...

Does PC Matic not work with Firefox? I purchased for 3 computers in May 2014 and here -- a month away from my expiration date I am suddenly having real issues with my desktop. I put firefox on it because exp. was giving me fits. The only way that I got good results was after I ran a PCM scan. But, now I can't even login to PCM getting different forms of this: Registry: read error: -2146959355 server execution failed Getstringvalue hive='HKLM' key='Software\PCPitstop\Nirvana' name='Language'


And this is only one of at least 8 other adverse windows that come up in my attempt to navigate through this to open PC Matic up.

I have even tried to approach opening it up through safe mode (which I had to originally do when I first purchased it), but to no avail. I am sending this on my laptop which also has windows xp on it just like my desktop -- however, it is still doing just great.


Can anyone tell me what is going on with my desktop; or, what I will have to do to restore it to good working order? i am at a loss! Please help...

Link to post
Share on other sites



PC Matic includes its own browser but it does need the Windows Active X function to be working.


The error messages that you are seeing are a result of a permissions issue with the Windows registry, it is not browser-related.


Make sure that you are both installing and running PC Matic from an administrator account. You can right-click on the icon(s) and select 'Run as administrator'.


If that does not resolve the issue, run the Windows registry repair tool from the link below:



When you run the tool you should see a command window open and be able to watch the tool's progress. The tool may appear to 'hang' once or twice, but if you wait the tool should complete.


If the repair tool does not fix the problem, another common problem is WMI corruption. To check for this:

* Right-click the My Computer icon and select Manage.
* Open the "Services and Applications" tree.
* Right-click the "WMI Control" item and select Properties.


In the dialog that appears, you should see this message:

Successfully connected to:


If you see error messages, try the steps recommended on this page to rebuild the WMI Repository:



You can also try the automated WMI repair tool from this link:


If the above repairs do not work, the remaining option may be a repair install of Windows:

XP repair Install:


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...