Jump to content

Change Mode

Think my openSUSE install has died!


nigsy
 Share

Recommended Posts

you actually using btrfs or ext4 bruce?

 

i've stated my reasons for sticking with ext4 when i update my main pc in another topic, which is it's the faster file system.

yet am using btrfs on a 2nd/test pc that doesn't get used much, so i haven't even updated it since install and probably the reason why i haven't run into this problem myself yet because it was installed using all defaults so snapper must be beavering away somewhere in the background filling up the root drive on that too.

 

:b33r:

Link to comment
Share on other sites

glad you got it sorted.

 

thing that really puzzles me now tho is why the root drive/partition was showing as only 63% full when in fact it must have been 100% full with the snapshots taking up all the extra space.

why didn't the snapshots show up as using drive space? guessing it must be because the brtfs being the lower level file system manager doesn't tell the higher level os what space it's using to keep it's snapshots. :shrug:

 

Since the df does not show the correct disk usage on Btrfs file systems, you need to use the command btrfs filesystem df MOUNT_POINT. Displaying the amount of disk space a snapshot allocates is currently not supported by the Btrfs tools.

 

Snapshots always reside on the same partition or subvolume that has been snapshotted. It is not possible to store snapshots on a different partition or subvolume.

As a result, partitions containing snapshots need to be larger than “normal” partitions. The exact amount strongly depends on the number of snapshots you keep and the amount of data modifications. As a rule of thumb you should consider using twice the size than you normally would.

 

http://activedoc.opensuse.org/book/opensuse-reference/chapter-4-snapshotsrollback-with-snapper

Link to comment
Share on other sites

Well I'm sticking with the brtfs file system.....

 

Noted a setting on installation that there is a check box when you select brtfs as the file system you can select it not to take snapshots so maybe that's a work around?.

Link to comment
Share on other sites

Bruce is DA MAN! Hell, so are you guys Terry and Nigel. I learn so much from this place. I usually just use the default configuration when I update openSUSE, but next time I'll opt for ext4. I've got btrfs for / and ext4 for /home now, but I followed your links and disabled snapper so I won't run into the same jam Nigel did.

Great job, lads.

Link to comment
Share on other sites

  • 3 months later...

Bit of an update.

 

After battling with snapper; I was still getting bootup problems. So I disabled it completely after clearing out the old snapshots.

Worked fine for about 4 weeks. Switched my monitor on this morning to be greeted by a screen of text with 'BTRFS: Failed To read Log Tree' in red at the bottom of the log report.

Ran a memory test from the SUSE cd. All good. Tested my SSD for errors, none found. So I have reinstalled my '/ ' partition using ext4 and got rid of BTRFS until it's really ready and stable!!

Link to comment
Share on other sites

Folding is fine. Been down for 24 hours while I sorted the issue.

openSUSE is fine...just an issue on my setup with Snapper; I'm not alone, but formatting to ext4 is the fix for me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...