Jump to content

Change Mode

Low video performance


Recommended Posts

Running Ubuntu 10.04.1 LTS

[email protected]:~$ uname -r
3.13.0-35-generic
 

Currently using NVIDIA legacy binary driver 304.117 nvidia-304-updates

 

Other options include nvidia-304 (version 304.117 proprietary, tested).. nvidia-173 (version 173.14.39).. or xserver-xorg-video-nouveau (open source)

 

I tried the 173 driver and it only allows me to use 640x480 resolution. Both of the 304 drivers allow 1024x768 (which is native resolution for monitor). The nouveau driver only allows 800x600 resolution.

 

In WinXP Pro I had it running in 1280x1024 at 75Hz refresh if I remember right. It won't even let me change the refresh rate on here, 'auto' is the only option. I prefer 1280x1024 if possible as it allows me to see the most on my screen without having to keep scrolling all over the place.

 

Using Chrome 37, can't get flash to work at all in FireFox. I can watch videos (i.e. youtube, vimeo) but have to make certain HD is turned off or the machine stops responding for a few minutes and it just sits 'buffering'. Trying to play flash based browser games (Forge of Empires) is just a nightmare.. can't drag the screen to move around as it just freezes up, clicking to collect productions has a delay until it does so. It wasn't this bad in Windows... and I've even got all hardware accel disabled. Enabling it doesn't seem to make any difference at all.

 

th_Screenshotfrom2014-09-17191722_zps1b3

 

th_Screenshotfrom2014-09-17191751_zps3c3

 

th_Screenshotfrom2014-09-17191604_zps258

 

Should I assume this is the point where I have no choice but to switch up to newer, more modern hardware? Any configuration I can do to make things run faster?

Link to post
Share on other sites

6200 is an ancient card that had poor performance the year it was released. Which is almost a decade ago. It certainly won't be getting any better. Time to get something made in the decade at least. ;)

Link to post
Share on other sites

You can't get Flash to work in Firefox because Adobe stopped updating Flash for Linux at 11.x.whatever. If you can watch a YouTube vid in Firefox, it's not in Flash - it's in HTML5. Flash vids work in Chrome/Chromium because they have their own pepperflash plug-in. If I right click a vid while in Chromium, it will say About Adobe Flash Player 14.whatever. It's stuck in 11 with Firefox.

Link to post
Share on other sites

I don't know.. I can watch videos on youtube just fine in FireFox. Can't access Forge of Empires game though. It lets me log in, but then gives the error message "To view this page ensure that Adobe Flash Player version 11.7 or greater is installed."

I can go to Add Ons Manager and Plug Ins, there is a Shockwave Flash 11.2.202.406 installed. I also see a Windows Media Player 10 plugin (that's odd) and VLC multimedia plugin. Also got a DivX and Quicktime plugin showing.

 

I have installed Ubuntu Restricted Extras, VLC player and pepperflash should have installed along with Chrome, think I even choose to install it manually as well. Maybe I did something wrong?

Link to post
Share on other sites

yes flash works fine in firefox (play loads of games with it) but like kurt said they stopped development of it at version 11.2.202.400 for linux so that is why it won't work for some things that need a newer version of it like forge of empires that says it needs version 11.7 or greater, so with that game i'd suggest using chrome and it's pepper flash to play it, even tho i do believe you can get pepper flash working with firefox somehow.

 

:b33r:

 

if you have a netflix account or whatever that only uses silverlight to play it's content then i suggest you also install pipelight so you can watch such content. here a link explaining :- http://pipelight.net/cms/installation.html

Edited by terry1966
Link to post
Share on other sites

can't really see much with that pic kurt, way to small, is it playing and showing the pic but colours all scrambled?

when you right click in the flash window is there a tick in the display hardware acceleration box? if so untick it, restart video/browser and see if you get better results, also what video card/hardware do you have and what drivers are you using?

 

like bruce i've never had a flash problem with any of my machines amd/intel using lots of different video cards, both ati and nvidia.

 

:b33r:

Edited by terry1966
Link to post
Share on other sites

JrKq6e.png

That's as big as I can get it with Imageshack. All apologies. Notice the vid window. Vid only takes up the left half of the window and the colors are like something from the brown acid. What I get for the device is Mesa DRI Intel 845G x86/MMX/SSE2 and the driver is i915. I guess my machine is too old, if I dare go higher than 34 with Chromium or Chrome even a blank page has bad acid trip colors.

Link to post
Share on other sites

I assume that's with onboard graphics then due to the mention of Intel 845G. That's even older than my machine, which, has Intel 865G for onboard GPU. But I use an EVGA geforce 6200 in AGP slot.

 

yes flash works fine in firefox (play loads of games with it) but like kurt said they stopped development of it at version 11.2.202.400 for linux so that is why it won't work for some things that need a newer version of it like forge of empires that says it needs version 11.7 or greater, so with that game i'd suggest using chrome and it's pepper flash to play it, even tho i do believe you can get pepper flash working with firefox somehow.

 

:b33r:

 

if you have a netflix account or whatever that only uses silverlight to play it's content then i suggest you also install pipelight so you can watch such content. here a link explaining :- http://pipelight.net/cms/installation.html

 

That actually sounds right on Terry, thanks!!

And yes, Forge of Empires does actually play in Chrome.

 

Well I'll just have to see how it goes on the other machine as soon as that's all set up.

Link to post
Share on other sites

JrKq6e.png

That's as big as I can get it with Imageshack. All apologies. Notice the vid window. Vid only takes up the left half of the window and the colors are like something from the brown acid. What I get for the device is Mesa DRI Intel 845G x86/MMX/SSE2 and the driver is i915. I guess my machine is too old, if I dare go higher than 34 with Chromium or Chrome even a blank page has bad acid trip colors.

Video plays just fine for me, but then I am not using a 20 year old chipset and onboard graphics adapter that has very limited support. Flash works just fine. ;) Your hardware is the culprit.

Link to post
Share on other sites

did you check to see if hardware acceleration was ticked and untick it? good chance that will fix your colour problem at least, but if it doesn't then yes the age of hardware is probably the culprit in your case. my oldest machine is a spring chicken compared to yours, being only 10 years old. :mrgreen:

 

:b33r:

Link to post
Share on other sites

OK I even tried changing driver and it still won't display the whole nvidia settings. Is there a specific way to remove everything nvidia and re-install it so that I get the whole thing back to how it was?

Link to post
Share on other sites

Spring chicken, ha ha! None of these lil whippersnappers would recall that term, but alas, I remember it well. Yes, Terry, I did uncheck that box, it didn't help. My PC is a geezer just like I am. It's cool. I can't gripe about the age of the PC, some of you may recall that one of my brothers gave it to me for free. Here's another old folks' term: Beggars can't be choosers. :mrgreen:

Link to post
Share on other sites

OK I even tried changing driver and it still won't display the whole nvidia settings. Is there a specific way to remove everything nvidia and re-install it so that I get the whole thing back to how it was?

have you tried clicking on the "nvidia settings configuration" below the highlighted "applications profile" in your pic to get to the settings?

 

personally my nvidia configuration program looks nothing like yours, i assume that's a gnome or ubuntu thing, so can't offer more suggestions.

 

for removal of everything nvidia

 

Step 1: Remove NVIDIA drivers

After booting, if you are seeing a blank display then try pressing Ctrl+Alt+F1, this should give you a terminal login.

The first step is to remove any or all of the NVIDIA drivers installed on the computer. They should not just be uninstalled, but every shred of their prior existence must be eradicated.

Purge, not just remove, all installed NVIDIA packages:

1
$ sudo apt-get purge nvidia-*

If you had installed a NVIDIA driver from their website, uninstall it using the shell script that it ships with. Already deleted that file? Too bad. Try with a newer version of driver that you can download.

You may still have some NVIDIA modules stuck in the kernel. First list the kernel modules:

1
$ dkms status

The output is of this form:

1
nvidia-current-updates, 304.64, 3.2.0-37-generic, x86_64: installed

Here nvidia-current-updates is the module name, 304.64 is the module version and 3.2.0-37-generic is the kernel version.

Remove all the nvidia modules. For example, to remove the above:

1
$ sudo dkms remove nvidia-current-updates/304.64 -k 3.2.0-37-generic

from here :- http://choorucode.com/2013/02/07/how-to-fix-nvidia-driver-failure-on-ubuntu/

 

:b33r:

Link to post
Share on other sites

In my first post you can see screenshots of how it looked when I first install the nvidia driver.

 

This is what I see in that "nvidia settings configuration" section

th_Screenshotfrom2014-09-20164035_zpsd26

 

Shows that I've got the nvidia driver installed and in use on the "additional drivers" section.

th_Screenshotfrom2014-09-20165459_zps21e

 

About the only thing I've done recently was install lm-sensors, and what a joke that is. Ended up removing that one since it gives no real time temperature readouts, as well didn't even give CPU temp. Just one listed at Temperature (of what I have no clue) and showed it to be 39*C, which, could be just about anything so it's of no help. Doubt that caused the problem, during install/configuration of lm-sensors I seen it scanning for i2c devices (nvidia cards are usually found there) and it reported finding none. It always showed as an i2c device in Speedfan via Windows XP.

Link to post
Share on other sites

yep pic in your first post is what i see in mine, that's why i thought the pics of what you see now must be ubuntu nvidia specific, never seen anything like that far as i can remember even when the nvidia drivers weren't properly installed, maybe wrong tho.

 

so not using the distro myself can't think why it changed for you, personally if your not having any problems and the nvidia driver is installed and working fine then i wouldn't worry about it.

 

does ubuntu use any other program for changing the display settings, maybe that has taken over control of the nvidia config settings and why it no longer displays the choices it used to.

 

:b33r:

 

after another look at mine, it does look like yours doesn't see/recognise any monitors/x servers and why nothing shows up above there. no idea what could cause that tho except nvidia drivers not actually being used for some reason.

Edited by terry1966
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...