Jump to content

a little install help if possible. suse 13.1 kde


Croupier
 Share

Recommended Posts

I have a football draft program to install and am having trouble. could not find anything on the net.

 

program name is "draftdominator" I downloaded it. opened with ark by default, extracted it to downloads.

 

file name is DraftDominator_v4.0g.tar

 

I tried searching yast for draftdominator. any ideas how to install.

 

it has an application/x-executable file in the folder "draftdominator"

I just don't know how to run it.

Link to comment
Share on other sites

.exe file sounds like a windows program to me, and they don't run natively on a linux os.

 

if it does work on a linux os then i'd think you'd need some type of middle man/software emulator to run it like wine or crossover.

 

wine :- https://www.winehq.org/

crossover :- http://www.codeweavers.com/

 

personally i can't find anything on those sites saying draftdominator will definitely run on them tho.

 

or of course you could run a windows os in a virtual machine (vm) on you linux os and see if it runs, personally my vm of choice is virtualbox but there are other vm choices out there like kvm or vmware etc.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

I downloaded the linux version, which the author said it should be a one click install. but no joy with that.

 

Might be a problem with my machine though.

 

I tried installing wine and run the windows version but it's just never that easy for me :)

 

I also couldn't get playonlinux to install properly. So I'm thinking through all my tinkering and screwing things up while learning to use linux i might have maybe done something to my o/s.

 

Pretty important draft tomorrow so I'm just gonna have to borrow a buds windows lappy and go that route.

I'll try to fix this up in a few days.

 

Thanks for the quick replies and as always I appreciate your valuable time and input.

 

Edit: here is the error I get when trying to install it with wine

 

Unable to register the DLL/OCX: regsvr32 failed with exit code 0x1.

Edited by Croupier
Link to comment
Share on other sites

ok i downloaded the file and then extracted it.

in dolphin i navigated to the draftdominator folder, made sure it was executable then pressed F4 to open a terminal and typed in

./DraftDominator

to run it.

 

and got a lib error.

./DraftDominator: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

so it looks like you may need to install libgtk-x11-2.0.so.0

there is no libgtk-x11 in yast so tried to do a package search for that lib on opensuse site, but it looks like the site is having problems with it's search repos at the moment because i got a connection error when i tried.

 

so can't point you to the correct needed lib and never got it running on my system, but i'd guess that is all you need to do to get it to work, find and install libgtk-x11-2.0.so.0

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Well thanks to you guys I have gotten farther that i ever would have. But so far I can not install the package bruce linked.

 

just goes to text when i click the one-click install, was able to download it as an rpm. So i have to try to figure that one out.

 

looks like im on the right track and also have learned a few things along the way. THANKS AGIAN!!

Link to comment
Share on other sites

ok you need to install the 32bit package and then it run's.

 

there are 5 different windows

main

playerpool

teams

team stats

draft status.

 

to start it either just click on the gear or start it from a terminal with ./DraftDominator command.

 

it did throw up some warnings but nothing that seemed to stop it from working correctly.

suse13.1@mainpc:~/Downloads/DraftDominator> ./DraftDominator

(DraftDominator:7647): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(DraftDominator:7647): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(DraftDominator:7647): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

:b33r:

Edited by terry1966
Link to comment
Share on other sites

But so far I can not install the package bruce linked.

 

just goes to text when i click the one-click install, was able to download it as an rpm.

 

I get this issue with one click installs with Chrome. I just paste the URL into Dolphin browser; the 'one click' runs then

Link to comment
Share on other sites

Sorry for delay.

 

NIgsy good call with the chrome error. I wont forget that. I used firefox and one-click install no problem.

 

How do i choose to install the 32 bit version. It appears the one-click installs the 64bit version. When i click the 32 bit version it downloads as rpm file and opens with ark. could not get it to install from there. I'm such a noob! but i like this linux PC alot and i will get better with your help :)

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...