Jump to content

USB3 Card


nigsy
 Share

Recommended Posts

Anyone any experience with a PCI USB3 card?

 

Have a couple of USB3 devices but only USB2 on my PC.

 

Found a couple of PCI-E cards, they say Linux compatable. Just wondered if anyone has any experience of using one?

 

Something like this:

 

http://www.amazon.co.uk/TeckNet%C2%AE-PCI-Express-Controller-Adapter-Connector/dp/B00FXMGC5M/ref=sr_1_7?ie=UTF8&qid=1396884722&sr=8-7&keywords=pci+card+usb3

Link to comment
Share on other sites

nope let us know how you get on, might need one myself in future.

 

from one of the reviews.

 

 

Linux recognised the device right away.

full 5 star review posted 27 jan 2014.

 

Easy enough to physically install (note it needs a power connection, like a disk drive). I used an Anker Uspeed USB Front Panel to bring two ports to the front of my PC (and there are a couple more ports on the back). Linux recognised the device right away. I had to install a driver for Windows 7, but this wasn't difficult.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

The card has arrived already. Swift service!!

 

Installed it; can see it in Yast, has installed the correct Via drivers; but it won't work with any of my USB3 devices!! I plug them in and they are not detected.

 

So what next!!

Link to comment
Share on other sites

curious but if you plug the drive in and go into yast partitioner does the external hard drive show up there?

 

do any usb2 devices work in the usb3 ports, and what are the usb3 drives your using, make/model?

 

what do you get with lsusb command?

 

:b33r:

 

oops see bruce posted about using lsusb.

Edited by terry1966
Link to comment
Share on other sites

Output from LSUSB

nigsy@linux-2gvb:~> lsusb
Bus 002 Device 002: ID 0bda:0161 Realtek Semiconductor Corp. Mass Storage Device
Bus 004 Device 002: ID 08bb:2900 Texas Instruments PCM2900 Audio Codec
Bus 004 Device 003: ID 0c45:0520 Microdia 
Bus 009 Device 002: ID 2109:3431  
Bus 010 Device 003: ID 2109:0812  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 003: ID 2109:2812  
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

It is picking up USB2 devices

 

And here's what it looks like in YAST

 

post-35967-0-51253900-1397112336_thumb.jpg

 

 

Main device I'd like it to see is Verbatim 750g USB3 hard drive (Model #53053) or a sandisk 32gb UltraUSB3 thumbdrive.

 

Going to put it in a windows machine and see if it works.

 

**Update:

 

Put it in a W7 pc, loaded the drivers and it picks up both drives perfectly.....so it seems somewhere there is an incompatability either with SUSE or the drives themselves.

Link to comment
Share on other sites

no ideas really nigel.

 

i'd see if i could see/mount them in partitioner and see if they work then.

 

make sure your distro is completely upto date maybe something regressed with usb3 and will be fixed by updating.

 

could try this and see if it makes any difference.

plug in a usb3 device then run as root "rmmod xhci_hcd" and then "modprobe xhci_hcd" and see if that changes anything.

 

:b33r:

 

maybe try this also.

 

 

remove the file /etc/pm/config.d/xhci, if existing.

http://fedoraproject.org/wiki/Common_F15_bugs#USB_3.0_ports_not_working_anymore_after_upgrade_from_F14

Edited by terry1966
Link to comment
Share on other sites

what kernel you running nigsy?

 

been googling like mad and found this that might relate to your problem, seems usb3 auto mount is broken in some kernels but you can manually mount the drives after a few minutes. :- https://bbs.archlinux.org/viewtopic.php?pid=1308466

 

seems kernel 3-10-6-2 has the problem fixed again.

 

:b33r:

 

try plugging in the drives then booting the pc.

 

Well, it seems to be "magic", and I don't know why,
but this "fixed" the issue:

Plugged the external USB 3 drive into a USB 2 port. It was recognized, and I mounted it.
Powered down everything - external USB 3 drive and PC.
Waited 2 minutes.
Plugged the external USB 3 drive into the USB 3 PCIe card's external connector.
Powered on the external USB 3 drive and waited for it to spin up.
Powered on the PC. The external USB 3.0 drive was recognized.

Why the drive had to be plugged in to a USB 2 port once before it would
work in the USB 3 port makes no sense to me. But now, even when all devices
are powered off, then powered on, the USB 3 drive works in the USB 3 connector
as long as it's plugged in and powered on before the PC is powered on.
It's weird, but at least I get USB 3 performance from the drive.

http://forums.opensuse.org/showthread.php/493785-OSS-13-1-USB3-PCIe-Card-and-Seagate-Ext-HDD-Not-Functioning

 

 

The Online Update today (via YOU) to autofs 5.0.8 has resolved all of the
mount and hot-plug issues with this USB 3 PCIe card. External devices
can now be plugged, unplugged, and powered on/off at will; the devices
are now always recognized - and recognized as USB 3.

 

so make sure you have "autofs 5.0.8" installed or go get and install it here :- http://software.opensuse.org/package/autofs?search_term=autofs+5.0.8+

Edited by terry1966
Link to comment
Share on other sites

My kernel is:

 

nigsy@linux-2gvb:~> uname -s -r -v
Linux 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e)
nigsy@linux-2gvb:~>

 

I have the latest version of AutoFS instaled (5.0.8)

 

 

remove the file /etc/pm/config.d/xhci, if existing.

 

File doesn't exist.

 

Plugging in / powering down and rebooting 2 mins later has no effect!!

 

Off to try the last couple of suggestions.

 

(Dmsg output)

   6.166528] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    6.166536] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 9
[    6.166762] xhci_hcd 0000:01:00.0: irq 45 for MSI/MSI-X
[    6.166813] usb usb9: New USB device found, idVendor=1d6b, idProduct=0002
[    6.166815] usb usb9: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    6.166818] usb usb9: Product: xHCI Host Controller
[    6.166820] usb usb9: Manufacturer: Linux 3.11.10-7-desktop xhci_hcd
[    6.166822] usb usb9: SerialNumber: 0000:01:00.0
[    6.166918] xHCI xhci_add_endpoint called for root hub
[    6.166920] xHCI xhci_check_bandwidth called for root hub
[    6.166947] hub 9-0:1.0: USB hub found
[    6.166952] hub 9-0:1.0: 1 port detected
[    6.167025] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    6.167029] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 10

Link to comment
Share on other sites

OK....

 

The drive is there and visable in terminal; out put from lsmod | grep usb

[    8.136321] usb 10-2.4: new SuperSpeed USB device number 4 using xhci_hcd
[    8.148177] usb 10-2.4: New USB device found, idVendor=18a5, idProduct=0401
[    8.148180] usb 10-2.4: New USB device strings: Mfr=10, Product=11, SerialNumber=3
[    8.148181] usb 10-2.4: Product: Executive Portable HD
[    8.148183] usb 10-2.4: Manufacturer: Verbatim
[    8.148184] usb 10-2.4: SerialNumber: 203817161572
[    8.435255] EXT4-fs (sda5): re-mounted. Opts: acl,user_xattr

So it's visable; looks like it's on sda5; but I can't mount it.

Tried to create a directory on the desktop

 

cd Desktop

mkdir /Verbatim

 

(Creates the folder)

 

Tried to then create the mount but but it just errors cannot find device in etc /fstab?

 

Tried a more general " mount /dev/sda5 / mnt " and it tells me mount point does not exist.

 

Can someone give me the command to mount the drive

Link to comment
Share on other sites

mount /dev/sda5 /home/yourusernamehere/Desktop/Verbatim

 

is the command to use the Verbatim folder you created on the desktop, putting in your user name where it says that of course.

 

or use yast partitioner and edit sda5 and add the mount point to the Verbatim folder you've already created.

the mount point is /home/yourusernamehere/Desktop/Verbatim

 

to be honest tho i doubt sda5 is your usb drive, that's more likely to be your home partition than anything else in my opinion.

 

sda is first hard drive in bios and 5 is the 5 partition on that drive (1st logical one with mbr file system, not sure with gpt file system probably real 5th partition).

 

i'd expect the usb drive to at least be the 2nd hard drive sdb or even 3rd hard drive sdc depending on how many drives you have in your pc and only have the 1 partition on it, so sdb1 or sdc1 would be what you wanted mounted in /home/yourusernamehere/Desktop/Verbatim.

 

:b33r:

 

as root in a terminal use fdisk -l and print the output in next post so we can see exactly what drives/partitions you have before trying to mount anything again.

Edited by terry1966
Link to comment
Share on other sites

Terry;

 

:b33r: !!

 

Device was sdd; used partitioner set the mount point and can now access files!!

 

Going to transfer some files later on USB3 & USB2 to get some speed comparisons.

 

Once again thanks.

Link to comment
Share on other sites

:clap:

 

don't be surprised in the future after an update somewhere the auto mount starts working again for usb3 drives.

seems to be an ongoing thing where they fix the problem then it gets regressed then they fix it again for some reason from what i've been reading.

 

a quick way to check the speed of the usb3 port is, as root, to run

hdparm -t -T /dev/sdd

which will give an output something like this.

/dev/sdd:
 Timing cached reads:   12368 MB in  2.00 seconds = 6187.83 MB/sec
 Timing buffered disk reads: 460 MB in  3.00 seconds = 153.18 MB/sec

and probably a better way is use the dd command to write a fixed amount of data to a testfile on it and show time taken.

dd if=/dev/zero of=/home/nigsy/Desktop/Verbatim/testfile.bin bs=1M count=1024

this will write a 1gb file called testfile.bin into the usb drive mounted on your desktop as Verbatim and will take a while to run then show an out put something like this.

 

1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 32.3429 s, 33.2 MB/s

the above took 33seconds of what looked like doing nothing before it showed the results.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Hit a problem....

 

Seems as a mere user I only have read access to the drive and only root has read/write.

 

Checked in partitioner > fstab and don't see any way to change permissions.

 

I can open the drive as root and change the permissions in properties, it looks like it applies those changes. But when I try to write to the drive the permissions have reset to root only.

 

How do I either mount it as me; or change the permissions?

 

 

Here's the speed reading:

/dev/sdd:
 Timing cached reads:   18668 MB in  2.00 seconds = 9342.43 MB/sec
 Timing buffered disk reads: 306 MB in  3.02 seconds = 101.44 MB/sec

1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.66255 s, 124 MB/s


Link to comment
Share on other sites

not sure exactly what you did but this is how i change permission to take ownership of any drives i've mounted so i have full read/write permissions as my user.

 

open a superuser dolphin window click on root then navigate to the folder where you've mounted the drive.

right click on it, click on properties

in the window click on permissions tab

access permissions i'd leave at defaults which are usually owner can view+ modify content, group can view content and others can view content.

now where it shows ownership, user root, group root change the user to nigsy and the group to users put a tick in apply changes to all subfolders and their contents then click ok.

 

and that should be all you need to do, you now have full ownership of the drive and can do what you like with it as your normal user without ever needing to be root.

 

of course you can do exactly the same from command line using chown command but i can never remember the exact syntax so prefer to navigate to the things i want to change using dolphin.

 

nice speeds no different than being connected to a sata port i'd say, have you compared them to using usb2 port yet, i'd be interested in seeing the difference.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

USB2 speed (Front Ports):

 

1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.86771 s, 121 MB/s

 

USB3 speed:

 

1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.66255 s, 124 MB/s

 

Not sure the USB3 port is working as it should!!

 

Another issue; the drive when mounted as USB2 is now owned by root so I can't write to it.

 

I can't change the permissions; I've done it the way suggested; I can access properties and physically change permissions and advanced permissions; apply the changes to all sub folders. The little window opens to tell me it's applying changes; but as soon as I close the properties box the changes revert back to the original settings. I think it's the actual mount point causing the issue:

 

/Home/Nigsy/Desktop

as opposed to

/home/nigsy/Desktop (note the capitalisation)

 

off to change the mount point!

Link to comment
Share on other sites

/Home/Nigsy/Desktop

 

that mount point would be a completely new folder in your root folder called Home (which would need the permissions changed.) not your actual home folder so yes that definitely is where your problem is.

 

your changing the wrong folders permissions. ;)

 

once you've changed the mount point to the correct thing run those speed tests again, (what you've actually been testing so far is your home partition hard drive sda and not any drives connected by either usb2 or usb3 ports.) there's no way a usb2 port can write anywhere near 120MBs in fact i think it's max is 40MBs and i'd expect result nearer 20MBs

 

:b33r:

 

personally to make things easier i'd just mount it as /external

 

then in the root folder you'd see the external folder and just change it's permissions/owner to nigsy users.

 

as for when it's auto mounted using usb2 (far as i'm aware you should have full read write permissions to it by default.) just open it with dolphin then click to the right of whatever it's called just above the white part of the window this will then show it's true full path.

probably something like

 

/var/run/media/nigsy/drivename

 

this is what you need to copy into the dd command to test the usb2 speeds

so the command would look like this

 

dd if=/dev/zero of=/var/run/media/nigsy/drivename/testfile.bin bs=1M count=1024

 

instead of

 

dd if=/dev/zero of=/external/testfile.bin bs=1M count=1024

 

if you mounted the drive when plugged into usb3 port as /external

Edited by terry1966
Link to comment
Share on other sites

I now have read/write on USB2

Here's the USB 2 speed, front port:

 

nigsy@linux-2gvb:~> dd if=/dev/zero of=/var/run/media/nigsy/FE9C28959C284B0B/testfile.bin bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.59391 s, 125 MB/s

 

And here it is on the USB3 card:

 

linux-2gvb:/home/nigsy # dd if=/dev/zero of=/external/testfile.bin bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.77021 s, 122 MB/s

 

Had to run as SU due to permissions; but this looks slower than USB2!! (If I'm reading it right?)

 

Think I'm going to put the card in a windows machine and check the speeds there just to make sure it's no a dodgy card.

Link to comment
Share on other sites

don't know what's up with that but i'd say the usb3 port is about the speed i'd expect in other words as fast as the drive is capable of, so is correct but the usb2 port isn't, like i said i don't believe usb2 ports can transfer data anywhere near as fast as the 125MBs being reported.

 

i believe max usb 2 speeds are about 400 Mbs and max usb 3 speeds are 5Gbs.

so the 400Mbs is equal to 50MBs and that's the MAX data transfer speed of usb2 period and in real world i believe it's much less more like 30MBs so way less than the reported 125MBs.

 

so something is going on there that i don't understand might be it's writing to cache/swap or something so it's not actually showing us the true write to drive data speeds.

 

what does the hdparm -t -T /dev/sdd command say when it's plugged into the usb2 and then usb3 port?

 

:b33r:

 

just to add

 

Had to run as SU due to permissions;

use the method i described in earlier post and change the /external folder to nigsy users and then you won't need su to write to the drive.

Edited by terry1966
Link to comment
Share on other sites

Still battling with the permissions; I've read online that it maybe down to the file structure (NTFS) and that it always mounts as root and can't be changed?? Is this true?

 

No matter how I open dolphin or open the root folder as 'file manager - Super User' navigate to the required folder (now mounted /home/nigsy/Verbatim) change the owner to nigsy. The applying changes box come up, but no changes are made.

 

Googled and found the chown command:

 

As su cd into /home/nigsy and run ls -l

drwxr-xr-x  1 root  users   126976 Apr 12 13:07 Verbatim

Ownership is with root...so run the chown command:

linux-2gvb:/home/nigsy # chown nigsy Verbatim

Re-run ls -l to check result:

drwxr-xr-x  1 root  users   126976 Apr 12 13:07 Verbatim

Link to comment
Share on other sites

OK....

 

It seems that NTFS is the problem....reformatted to ext4....remounted it in home/nigsy/Verbatim and with Dolphin in superuser able to change the permisions and I now have full read / write access.

 

Thanks all for your help...learning all the time!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...