Jump to content

Blu Ray & openSUSE


nigsy
 Share

Recommended Posts

I am helping a friend ditch XP and move onto openSUSE.

 

He's still not sure about the move so I have installed SUSE 13.1 (64 bit) on a spare drive so he can dual boot and play.

 

I've got all his old peripherals up and running but can't get his Blu Ray player to do anything...it will read the data and dolphin will let me explore the file structure, but if I try to play in VLC or any other media player it just errors - Tried several different movies and all go the same way.

 

Have installed packman repo.....

 

Not sure what to do next??

 

 

Link to comment
Share on other sites

have you installed libdvdcss? don't think it's used for blu ray but will be needed for dvd's.

 

don't have any experience with blu ray but from my understanding vlc does play them but you need to add 2 files.

 

http://vlc-bluray.whoknowsmy.name/

 

these may also help you :-

https://wiki.archlinux.org/index.php/BluRay

 

http://www.makeuseof.com/tag/what-you-need-to-know-about-watching-blu-ray-on-linux/

 

http://forums.opensuse.org/showthread.php/488250-Playing-Blu-Ray-Disks

 

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

been doing a bit more research on this and i think the first thing i'd do is install vlc's repo and then install these 3 things.

libbluray

libaacs

libbdplus

 

links explain them :-

http://www.videolan.org/vlc/download-suse.html

http://www.videolan.org/developers/libbluray.html

http://www.videolan.org/developers/libaacs.html

http://www.videolan.org/developers/libbdplus.html

 

if you run into any playback problems like stuttering, make sure you are using hardware acceleration as explained in earlier arch link.

 

if still no playback then it seems makemkv can be used to convert or stream the blu ray so you can watch it, again no experience with makemkv either but here's more links.

http://software.opensuse.org/package/makemkv

http://www.makemkv.com/forum2/viewtopic.php?f=3&t=6350

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Cheers Terry.

Won't see him till the weekend; but will give it a go. Don't want to leave him high and dry; so need to make sure everything is running a smooth as possible before we go for the full install.

Link to comment
Share on other sites

Nigel, why not setup Team Viewer for remote access and work on it that way. That might remove the time barrier and allow you to get him on his feet sooner.

 

Normally would; but I'm working away this week; not allowed to install or run any 'unauthorised' software on my company laptop (already been warned for running the non-install version) and only have it on my phone; useful for retrieving files off my home pc...but a nightmare trying to do any serious work on the S3s little screen!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...