Jump to content

Mint 15 not installing


dickster
 Share

Recommended Posts

  • Replies 89
  • Created
  • Last Reply

Top Posters In This Topic

yes it will, but you need to do it correctly.

 

first off, to write anything in etc/X11 you need the correct permissions (write) which root has but a user doesn't, so either :-

1:- log in as root,

2:- use sudo as a normal user,

or

3:- as a normal user open whatever file manager mint uses in "superuser" mode or whatever they call it.

 

before trying to create an empty xorg.conf file navigate to the /etc/X11 folder and make sure there isn't one there in the first place, don't need to be root to read most files so just log in as a normal user.

 

:b33r:

 

see if this works for you, log in as a normal user, open command line and type

sudo touch /etc/X11/xorg.conf

then see if the file is now there.

Edited by terry1966
Link to comment
Share on other sites

can't remember how by command line so easiest is to just log out from user account and log in as root then just start it as you normally would.

 

:b33r:

 

don't forget once you've saved the settings, log out of root and back in as your normal user.

we don't want to get you into the habit of running as root normally but sometimes it's just easier to do it that way if you forget or don't know the correct commands to start/do things using sudo.

Edited by terry1966
Link to comment
Share on other sites

I'm the only user on this system, so the only account set up. Guess I just go into the program and run it. But I have a question. In the device driver section it says that these are an alternitive driver. Not proprietary. I was loking for the real nvidia drivers. Is this not going to be them? From what I understand (very little) folding has problems with some of the other drivers.

Link to comment
Share on other sites

there is always a root account, along with any user account/s you setup.

on a suse system with only 1 account i'd just click leave and log out which takes me to a screen to log in again with my user name already selected, all i do is delete it and type in "root" (without quote marks.)along with the sudo (in your case) password to log in as root.

 

yes then you just go into programs and run the nvidia settings program.

 

as far as i know the drivers you have installed are nvidia proprietary drivers, same as if you got them directly from nvidia site, they have just been compiled and packaged by someone else ready to be installed by you from the ppa (repo on my suse setup.), they may not always be the latest and greatest but they are nvidia drivers.

 

not to be confused with the open source nvidia drivers called nouveau or the linux mesa drivers.

 

so should work just fine for folding as far as i'm aware, never run gpu folding tho so can't say for 100% certain.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

there is no need to "log in" as root. if you are trying to create an xorg.conf file, and the nvidia drivers are already installed... then all you need to do is open a terminal and run the following command:

sudo nvidia-xconfig

logout/login or reboot when its done. if you need to configure the file after it boots, run the following in a terminal:

gksudo gedit /etc/X11/xorg.conf

then you can follow terry or bruce's instructions for editing the file. save the file when done and then logout/login or just reboot for changes to take effect.

 

not sure about opensuse, but in ubuntu/mint there should never be any reason to "log in" as root.

 

hope that helps

Edited by iamgeorgeareu
Link to comment
Share on other sites

Followed your instructions, but it says it can't write xorg.conf because a device is missing. Then it says it's writing from an old backup. After reboot I'm back to 640x480 with no other options. The only way to get back to where I was required opening gedit in root and deleting everything in the xorg.conf file. Now back to 1152x864

Link to comment
Share on other sites

You don't have the nvidia driver installed.

 

If you run the command below it will tell us what hardware you have and what driver the system is trying to use. Please post the output from the command below.

lsmod |grep nvidia* && grep Driver /etc/X11/xorg.conf
Link to comment
Share on other sites

It should look something like.

nvidia 10627060 80 Driver "mouse" Driver "kbd" Driver "nvidia"

Just reading a few threads where the nvidia driver was not loading or Mint was having difficulties with.

 

I am no ubuntu expert by any stretch of the imagination, however the below instructions may help you get the latest driver available installed.

sudo apt-add-repository ppa:ubuntu-x-swat/x-updatesThe following will update your software repository list:sudo apt-get updateThe following will add the nvidia driver from the PPA:sudo apt-get install nvidia-currentThe following will update your x-windows configuration:sudo nvidia-xconfigThe following will reboot your system:sudo reboot
Link to comment
Share on other sites

I get as far as nvidia-xconfig and I get this.

 

 

sudo nvidia-xconfig

 

Using X configuration file: "/etc/X11/xorg.conf".

 

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.

At least one Device section is required.

 

Backed up file '/etc/X11/xorg.conf' as

'/etc/X11/xorg.conf.nvidia-xconfig-original'

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'

New X configuration file written to '/etc/X11/xorg.conf'

 

 

I use sudo reboot and it comes back up in 640x480 with no other options. I have to delete all in the xorg.conf file (while in root using gedit) and reboot to get back to the resolution I'm at now.

Link to comment
Share on other sites

sorry don't know why things are not working for you but can you do it again and this time when you get the errors and it creates a new xorg.conf file and your in 640x480 can you post that file here so we can see it before deleting everything to get back to your normal resolution, maybe we can work with the file it does create to fix things for you anyway.

 

:b33r:

 

something silly to try maybe, but can you connect the monitor to a different connection on the graphics card too and see if that makes any difference to things.

 

also not sure if you've said or not but when your in the 640x480 res and start the nvidia app does it show any other resolution settings there you can choose? maybe post another screen shot of what it says.

Edited by terry1966
Link to comment
Share on other sites

Ok, I'll do the nvidia install over and post the xorg.conf file contents before I delete it to get back to this resolution. As for showing other choices when it's at 640x480, no. I have no other options. Tried a different cable and port on the vid card with no luck. They were both DVI, but I do have an HDMI port on the card. Will buy a HDMI cable tomorrow to try that. Picked up an AOC 27" monitor today and it does have an HDMI port where my Acer didn't. Transfering some files to an external drive at the moment, so it'll probably about an hour before I can do the nvidia thing again, but I'll post it when it's done.

Edited by dickster
Link to comment
Share on other sites

My xorg.conf contents.

 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig# nvidia-xconfig: version 304.116 (buildmeister@swio-display-x86-rhel47-01) Mon Oct 28 21:46:08 PDT 2013Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer"EndSectionSection "Files"EndSectionSection "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5"EndSectionSection "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd"EndSectionSection "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS"EndSectionSection "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation"EndSectionSection "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 SubSection "Display" Depth 24 EndSubSectionEndSection

Link to comment
Share on other sites

You are using driver 304.116

 

Proper Support for the 650ti was not added until driver version 319

 

I am kind of really shocked that mint uses such an old driver.

 

That said if the directions to remove that driver, and add the ppa for the latest driver had been followed correctly I believe all of this would be working now.

 

The use of the old driver is the reason for the earlier no device errors, and also likely where there is no pci device in xorg.

 

I am currently using 331.20. It appears that Mint is far, far behind in drivers.

Edited by Bruce
Link to comment
Share on other sites

i'm using 319.32 on this 12.3 machine.

 

still think just editing the HorizSync 28.0 - 33.0 line will fix the res. problem regardless of driver version.

 

must admit tho dickster you really do need to at least install the latest from the ppa if you want the best chance of folding working too.

 

:b33r:

Link to comment
Share on other sites

 

and also likely where there is no pci device in xorg.

 

was curious about this so checked mine and no pci device listed in my xorg.conf file either.

# nvidia-settings: X configuration file generated by nvidia-settings# nvidia-settings:  version 319.32  (buildmeister@swio-display-x64-rhel04-14)  Wed Jun 19 15:50:23 PDT 2013Section "ServerLayout"    Identifier     "Layout0"    Screen      0  "Screen0" 0 0    InputDevice    "Keyboard0" "CoreKeyboard"    InputDevice    "Mouse0" "CorePointer"    Option         "Xinerama" "0"EndSectionSection "Files"EndSectionSection "InputDevice"    # generated from default    Identifier     "Mouse0"    Driver         "mouse"    Option         "Protocol" "auto"    Option         "Device" "/dev/psaux"    Option         "Emulate3Buttons" "no"    Option         "ZAxisMapping" "4 5"EndSectionSection "InputDevice"    # generated from default    Identifier     "Keyboard0"    Driver         "kbd"EndSectionSection "Monitor"    # HorizSync source: builtin, VertRefresh source: builtin    Identifier     "Monitor0"    VendorName     "Unknown"    ModelName      "CRT-1"    HorizSync       28.0 - 80.0    VertRefresh     43.0 - 75.0    Option         "DPMS"EndSectionSection "Device"    Identifier     "Device0"    Driver         "nvidia"    VendorName     "NVIDIA Corporation"    BoardName      "GeForce GTX 275"EndSectionSection "Screen"    Identifier     "Screen0"    Device         "Device0"    Monitor        "Monitor0"    DefaultDepth    24    Option         "Stereo" "0"    Option         "nvidiaXineramaInfoOrder" "CRT-1"    Option         "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1024+0"    SubSection     "Display"        Depth       24    EndSubSectionEndSection

:b33r:

Link to comment
Share on other sites

Thats odd I have always had a PCI line in my xorg files.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig# nvidia-xconfig:  version 331.20  (buildmeister@swio-display-x64-rhel04-18)  Thu Oct 17 10:15:46 PDT 2013Section "ServerLayout"    Identifier     "Layout0"    Screen      0  "Screen0" 0 0    Screen      1  "Screen1" 1680 0    InputDevice    "Keyboard0" "CoreKeyboard"    InputDevice    "Mouse0" "CorePointer"    Option         "Xinerama" "0"EndSectionSection "Files"EndSectionSection "InputDevice"    # generated from default    Identifier     "Mouse0"    Driver         "mouse"    Option         "Protocol" "auto"    Option         "Device" "/dev/psaux"    Option         "Emulate3Buttons" "no"    Option         "ZAxisMapping" "4 5"EndSectionSection "InputDevice"    # generated from default    Identifier     "Keyboard0"    Driver         "kbd"EndSectionSection "Monitor"    # HorizSync source: edid, VertRefresh source: edid    Identifier     "Monitor0"    VendorName     "Gateway"    ModelName      "Gateway HD2201"    HorizSync       24.0 - 83.0    VertRefresh     48.0 - 76.0    Option         "DPMS"EndSectionSection "Monitor"    # HorizSync source: edid, VertRefresh source: edid    Identifier     "Monitor1"    VendorName     "Samsung"    ModelName      "Samsung SyncMaster"    HorizSync       30.0 - 81.0    VertRefresh     56.0 - 75.0    Option         "DPMS"EndSectionSection "Device"    Identifier     "Device0"    Driver         "nvidia"    VendorName     "NVIDIA Corporation"    BoardName      "GeForce GTX 275"    BusID          "PCI:1:0:0"EndSectionSection "Device"    Identifier     "Device1"    Driver         "nvidia"    VendorName     "NVIDIA Corporation"    BoardName      "GeForce GTX 260"    BusID          "PCI:2:0:0"EndSectionSection "Screen"    Identifier     "Screen0"    Device         "Device0"    Monitor        "Monitor0"    DefaultDepth    24    Option         "Stereo" "0"    Option         "nvidiaXineramaInfoOrder" "DFP-1"    Option         "metamodes" "1680x1050 +0+0"    SubSection     "Display"        Depth       24    EndSubSectionEndSectionSection "Screen"    Identifier     "Screen1"    Device         "Device1"    Monitor        "Monitor1"    DefaultDepth    24    Option         "Stereo" "0"    Option         "nvidiaXineramaInfoOrder" "CRT-1"    Option         "metamodes" "1680x1050 +0+0"    SubSection     "Display"        Depth       24    EndSubSectionEndSection
Link to comment
Share on other sites

ok i was running twinview with single x screen, instead of xinerama with seperate x screens.

 

this is what my new xorg.conf file reads when i made the changes, now there is the pci line.

 

forgot to say with my monitor i was only able to set 1024x768 as it's res instead of it's native 1280x1024 because of a wrong HorizSync setting but when i manually set it to 28.0 - 80.0 instead of it's original setting which i think was something like 28x68 originally then i was able to set the res much higher.

# nvidia-settings: X configuration file generated by nvidia-settings# nvidia-settings:  version 319.32  (buildmeister@swio-display-x64-rhel04-14)  Wed Jun 19 15:50:23 PDT 2013Section "ServerLayout"    Identifier     "Layout0"    Screen      0  "Screen0" 0 0    Screen      1  "Screen1" 1280 0    InputDevice    "Keyboard0" "CoreKeyboard"    InputDevice    "Mouse0" "CorePointer"    Option         "Xinerama" "1"EndSectionSection "Files"EndSectionSection "InputDevice"    # generated from default    Identifier     "Mouse0"    Driver         "mouse"    Option         "Protocol" "auto"    Option         "Device" "/dev/psaux"    Option         "Emulate3Buttons" "no"    Option         "ZAxisMapping" "4 5"EndSectionSection "InputDevice"    # generated from default    Identifier     "Keyboard0"    Driver         "kbd"EndSectionSection "Monitor"    # HorizSync source: xconfig, VertRefresh source: xconfig    Identifier     "Monitor0"    VendorName     "Unknown"    ModelName      "CRT-1"    HorizSync       28.0 - 80.0    VertRefresh     43.0 - 72.0    Option         "DPMS"EndSectionSection "Monitor"    # HorizSync source: edid, VertRefresh source: edid    Identifier     "Monitor1"    VendorName     "Unknown"    ModelName      "SAMSUNG"    HorizSync       15.0 - 81.0    VertRefresh     24.0 - 75.0    Option         "DPMS"EndSectionSection "Device"    Identifier     "Device0"    Driver         "nvidia"    VendorName     "NVIDIA Corporation"    BoardName      "GeForce GTX 275"    BusID          "PCI:2:0:0"    Screen          0EndSectionSection "Device"    Identifier     "Device1"    Driver         "nvidia"    VendorName     "NVIDIA Corporation"    BoardName      "GeForce GTX 275"    BusID          "PCI:2:0:0"    Screen          1EndSectionSection "Screen"    Identifier     "Screen0"    Device         "Device0"    Monitor        "Monitor0"    DefaultDepth    24    Option         "Stereo" "0"    Option         "nvidiaXineramaInfoOrder" "CRT-1"    Option         "metamodes" "CRT: 1280x1024 +0+0; CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0; CRT: 1280x960 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_56 +0+0; CRT: 700x525 +0+0; CRT: 640x480 +0+0; CRT: 512x384 +0+0; CRT: 512x384d60 +0+0; CRT: 400x300 +0+0; CRT: 320x240 +0+0; CRT: nvidia-auto-select +0+0 {viewportout=1024x576+0+96}"    SubSection     "Display"        Depth       24    EndSubSectionEndSectionSection "Screen"    Identifier     "Screen1"    Device         "Device1"    Monitor        "Monitor1"    DefaultDepth    24    Option         "Stereo" "0"    Option         "metamodes" "DFP: nvidia-auto-select +0+0"    SubSection     "Display"        Depth       24    EndSubSectionEndSectionSection "Extensions"    Option         "Composite" "Disable"EndSection

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Fantastic! New xorg file while running in 140x900. Don't see 1600x900 but I do have other choices. Will experiment with them to find the best for me.

 

 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig# nvidia-xconfig: version 331.20 (buildmeister@swio-display-x86-rhel47-05) Wed Oct 30 18:20:53 PDT 2013Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer"EndSectionSection "Files"EndSectionSection "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5"EndSectionSection "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd"EndSectionSection "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 30.0 - 80.0 VertRefresh 50.0 - 75.0 Option "DPMS"EndSectionSection "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation"EndSectionSection "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 SubSection "Display" Depth 24 EndSubSectionEndSection

 

 

Thanks to everyone for their help. It is very much appreciated! :tup:

Edited by dickster
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...