Jump to content

Mint 15 not installing


dickster
 Share

Recommended Posts

Tried it but no joy. Got stuck at 640x420 again and had to delete the xorg.conf file to get back to where i was. Ran the xrandr command and here is the results.

 

xrandr Screen 0: minimum 8 x 8, current 1152 x 864, maximum 16384 x 16384 DVI-I-0 connected primary 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.0 + 1360x768 60.0 59.8 1152x864 60.0* 800x600 72.2 60.3 56.2 680x384 60.0 59.8 640x480 59.9 512x384 60.0 400x300 72.2 320x240 60.1 DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) DVI-D-0 disconnected (normal left inverted right x axis y axis) 1600x900_60.00 (0x2ba) 118.2MHz h: width 1600 start 1696 end 1856 total 2112 skew 0 clock 56.0KHz v: height 900 start 903 end 908 total 934 clock 59.9Hz "1440x900_60.00" (0x2cc) 106.5MHz h: width 1440 start 1528 end 1672 total 1904 skew 0 clock 55.9KHz v: height 900 start 903 end 909 total 934 clock 59.9Hz

 

It shows 1600x900 and 1440x900 but I don't have those choices.

 

 

Here is my xorg.conf after I reinstalled it.

 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig # nvidia-xconfig: version 319.32 (buildmeister@swio-display-x64-rhel04-14)

Wed Jun 19 15:50:37 PDT 2013

Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection

Section "Files" EndSection

Section "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection

Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd" EndSection

Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS" EndSection

Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection

Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 SubSection "Display" Depth 24 EndSubSection EndSection

Edited by dickster
Link to comment
Share on other sites

  • Replies 89
  • Created
  • Last Reply

Top Posters In This Topic

Nope, because after rebooting I'm stuck in tty1 with error boxes saying xserver is not configured correctly, and the other says restart mdm when xserver is corrected. Where do I go from here. Don't really want to start over. AGAIN!

Link to comment
Share on other sites

I'm stuck here in tty1. Even tried switching to root and stiil no luck.

 

if you can get to tty1? ...try typing the following to completely remove the nvidia driver you have installed:

sudo apt-get remove --purge nvidia*

press enter after typing it out and when that completes, type this one:

sudo apt-get install nvidia-current

press enter and when it completes, reboot with this command:

sudo reboot

hope it helps.

Link to comment
Share on other sites

I'm back up to the desktop with the same resolution issues I've had. But used different commands. Did the remove, reinstall and configure of xserver. Rebooted and here I am.

 

Lets see. What other trouble can I get myself into? :laughing:

Edited by dickster
Link to comment
Share on other sites

don't understand why you are having to configure xserver....i haven’t had to mess with any of that in years.

 

if i were you, i would try the xedgers-xorg repository. they have updated xorg-server and updated nvidia drivers. its pretty simple to do if you want to give it a go. but first i would undo whatever changes you made to xserver or whatever. then in a terminal run the following to first add the xedgers repository:

sudo add-apt-repository ppa:xorg-edgers/ppa 

then run the following to update the repos including the newly added xedgers ppa:

sudo apt-get update

the next command installs any available updates:

sudo apt-get upgrade

reboot after all that, and see if anything has improved. if no change, then try to install the latest nvidia driver (unless it already updated when you ran the upgrade command). the latest driver should be version 331.20 from the xedgers ppa. if it did not update, the following command should do it:

sudo apt-get install nvidia-331

reboot when it finishes, hope that helps

Link to comment
Share on other sites

this might help you :- https://wiki.ubuntu.com/X/Config/Resolution

 

what i would try first tho is edit this part

Section "Monitor"    Identifier     "Monitor0"    VendorName     "Unknown"    ModelName      "Unknown"    HorizSync       28.0 - 33.0    VertRefresh     43.0 - 72.0    Option         "DPMS"EndSection

to

Section "Monitor"    Identifier     "Monitor0"    VendorName     "Unknown"    ModelName      "Unknown"    HorizSync       30.0 - 80.0    VertRefresh     50.0 - 75.0    Option         "DPMS"    Option "PreferredMode" "1600x900"    Option "TargetRefresh" "60"EndSection

and change the "HorizSync" and "VertRefresh" to the correct values if you know them if not try the ones i've listed.

 

and see if that works for you.

 

:b33r:

Link to comment
Share on other sites

sorry didn't read the whole topic before making my last post.

 

i think you've just done a complete re-install and installed the nvidia drivers but now have no xorg.conf file is that correct?

 

if so what i would do is create an empty xorg.conf file then from this picture. :- http://img.photobucket.com/albums/v335/dickster/Screenshotfrom2013-11-24173851.png

 

what ever resolution it is reading, doesn't matter at this point maybe 1024x768 or 1152x864

 

click on the "save to x configuration file" button and save the settings it's currently using to the xorg.conf file you just created. (will probably need to run the nvidia app as root so it can save the settings.)

 

now post back your xorg.conf file with the settings it saved and we will tell you exactly what to edit in that to get the 1600x900 resolution you want with any luck.

 

:b33r:

Link to comment
Share on other sites

I create 1 and it's in home. I use the command (in root) sudo cp /home/me/xorg.conf.new /etc/x11/xorg.conf (me being the username) and it gives me errors. This command was taken from the mint forums "how to" section. I exit out and check. The xorg.conf is in the home folder, but showing a lock. I can open it, but it will NOT move to the x11 folder.

Link to comment
Share on other sites

what do the errors say? and is the file in your home directory actually called "xorg.conf.new" ? or just "xorg.conf" ?

 

I use the command (in root)

to be honest it sounds to me like you were root when you created the file in your home directory, so your actually using roots home directory and not the users me home directory so that's where the problem was.

 

if you just logged in as a normal user (me) then created the xorg.conf.new file, i think if you then used the

sudo cp /home/me/xorg.conf.new /etc/X11/xorg.conf

command things would work and the file would be copied without problems.

 

personally if your not really sure what the commands your typing are doing, i think it is a lot easier to just use whatever file manager your distro uses to actually navigate to where you want to put files just using the mouse and left click/right click to make choices.

 

for example as a normal user i would open dolphin in super user mode, click on "root" folder, click on "etc" folder, click on "X11" folder to navigate to where i want to put the new file, then right click and choose create new txt file in pop up and name it xorg.conf that's the empty file created.

 

now log off or switch user to root and run the nvidia app, or if you know how, use the terminal and sudo to start it running as root and then save it's configuration to the xorg.conf file you just created.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Can't even create one now. I get this. (And I am in root)

 

Xorg -configure(EE)Fatal server error:(EE) Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again.(EE)(EE)Please consult the The X.Org Foundation support at http://wiki.x.org for help.(EE)

 

And I did stop mdm before I tried.

Link to comment
Share on other sites

sorry dickster i have absolutely no idea what your doing, but it sounds like your trying to start a 2nd xserver when you don't need to.

 

i've never ever had such errors and no idea why you think you needed to stop "mdm" either. :shrug:

 

please list exactly what your doing in a step by step guide so we can see where you may be going wrong.

 

:b33r:

Link to comment
Share on other sites

Following this guide

 

http://forums.linuxmint.com/viewtopic.php?f=59&t=117643

 

I get to the install of the proprietary nvidia drivers (hoping with them I might get better resolution choices, plus better for folding) where it gives the command of ./n.run and it starts the process. But then it brings up a box saying that the Xserver is running and can't install the drivers. I can't seem to stop it, or delete it so that nvidia can install. This whole Mint thing on this pc has been one big cluster #*^@. Installed and running fine on 2 other systems, but this one...... :IG:

Link to comment
Share on other sites

why are you trying to install the nvidia driver again? i thought you already had them installed.

 

http://forums.pcpitstop.com/index.php?/topic/202458-mint-15-not-installing/page-2&do=findComment&comment=1779660

http://forums.pcpitstop.com/index.php?/topic/202458-mint-15-not-installing/page-2&do=findComment&comment=1779661

 

also what laptop is it? from that link.

 

This also will not work on "Hybrid" (laptops that have both an Intel ow power GPU, and an Nvidia discrete/standard GPU) tose require you to use a seperate method,

 

:b33r:

Link to comment
Share on other sites

ok if you've started over and don't have any nvidia driver installed follow http://forums.pcpitstop.com/index.php?/topic/202458-mint-15-not-installing/page-2&do=findComment&comment=1779660 and install them this way, better this way because you won't need to keep re-installing them every time mint has a kernal update.

 

once they are installed, just create an empty xorg.conf file in etc/X11

 

run the nvidia settings app as root :- http://smg.photobucket.com/user/dickster/media/Screenshotfrom2013-11-24173851.png.html

 

click on the "save to x configuration file" button and save the settings it's currently using to the xorg.conf file you just created.

 

now you should have an xorg.conf file populated with the settings currently in use and we can go on from there.

 

:b33r:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...