Jump to content

A little fstab help, please?


KurtBleach
 Share

Recommended Posts

/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part1 swap swap defaults 0 0/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part2 / ext4 acl,user_xattr 1 1/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part3 /home ext4 acl,user_xattr 1 2proc /proc proc defaults 0 0sysfs /sys sysfs noauto 0 0debugfs /sys/kernel/debug debugfs noauto 0 0usbfs /proc/bus/usb usbfs noauto 0 0devpts /dev/pts devpts mode=0620,gid=5 0 0/dev/fd0 /floppy auto noauto 0 0/dev/sr0 /mnt/cdrom auto noauto,x-gvfs-show 0 0

 

Just hoping that someone will show me what is wrong with this. I know floppies are so 80s, but all I want to do is save my Firefox bookmarks to a floppy so if I ever get to get a newer PC I can simply import them. I saved the bookmarks.json file, copied the file to /floppy, but it doesn't copy onto the disk.

And I do think the laser in my cdrom drive died, but if it's just a problem in this file, I appreciate the help from Pit bros.

 

Peace.

Link to comment
Share on other sites

Oh, and yes I do get defensive sometimes with apologizing for being such a Linux moron, but I deserve it, and I give mad thanks to the gurus here who keep me running.

Check this out: I almost killed my PC trying to get my floppy and CD drives back up. I took advice from random Googling, and I whacked my PC. I did some sort of block device command, and it ruined my fstab. I could not log on and my /home directory was unavailable. But thanks to you people up in here, I knew enough to log on as root and copy fstab's backup config and paste it into fstab. It worked, and I still have a PC. Thanks from Kurt. I can't trust fixes I get from random sites, but I know the Pit is real.

Link to comment
Share on other sites

It is frustrating when things do not work right with Linux but when they do it is a lot of fun to play with it. There is a lot more automation now but in the process one forgets about how things work and how to fix them when they don't.

 

Good luck and hang in there. As long as you keep moving forward you will never regret it.

 

I remember learning the hard way that floppies on linux must be mounted and unmounted using the mount and unmount. After copying some files on a floppy I deleted the original on the hard disk. I then did like I always did with DOS and ejected the floppy. I realized then that I had messed up. I put the floppy back in and remounted it but it was too late. The files were either not there or corrupt.

 

Years ago I did a dual boot of Windows XP and Fedora Linux. After I rebooted neither Windows or Linux would boot. It turned out that Fedora had messed up the partition tables. The Fedora support said no fix would be available so I had to wait for the next release. I finally figured out what to do after a week or two of Googling:

To fix things I did the following:

1. Boot using the Fedora Recue CD

2. Ran fdisk

3. Llisted the fstab

4. Wrote down the parttion information including sizes for the partitions

5. Deleted all the partitons

6. Recreated all the partitions

7. Saved the changes and exited fdisk

 

When I exited and rebooted linux was now working.

 

I was told that linux was confused as to whether LBA and CHS modes was used for the disks. Fedora support said it was Windows fault. I heard the mistake caused linux partitions to be created on non-cylinder bounaries. After I deleted and recreated the partitions the error was still there but at least linux would boot.

Edited by MisterEd
Link to comment
Share on other sites

don't have a floppy drive myself but everything looks ok to me, try copying to /dev/fd0 and see it that's any better.

 

been that long since i've used a floppy drive i'm not sure if you still need to mount the floppy drive first like mistered said or if it automatically gets mounted on startup before you can read/write from/to it.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

Thanks, Terry.

Well, I found a half- :filtered: fix for my problem and ended up copying the file to disk, but I'd still like it if someone could show me how to configure the fstab right.

Here's how it looks right now:

/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part1 swap swap defaults 0 0/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part2 / ext4 acl,user_xattr 1 1/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part3 /home ext4 acl,user_xattr 1 2proc /proc proc defaults 0 0sysfs /sys sysfs noauto 0 0debugfs /sys/kernel/debug debugfs noauto 0 0usbfs /proc/bus/usb usbfs noauto 0 0devpts /dev/pts devpts mode=0620,gid=5 0 0/dev/disk/by-path/pci-0000:00:1f.1-scsi-1:0:0:0 /mnt/sr0 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0

Now there is no floppy showing.

I did all the normal command line things to mount the disk, and it wouldn't work. Whether I set the path as /floppy or /mnt/floppy - no dice. So I went to the little lizard on the bottom left (I run open SUSE) and opened the Disks utility. When I would click to mount the disk, it would flash "yes - mounted on [whichever]" and then flash right back to "no". I tweaked it to become Automatic Mount, and now I can mount to /run/media/paulrut1964/disk. I can read or write from there, so I guess I accomplished something, but I know there must be an easier way.

There was nothing I could do in the Disks utility to get the CD/DVD up, maybe my line in fstab is wrong or the drive is dead, who knows? Not me. :mrgreen:

 

Thanks, guys.

KB

 

P.S. @terry - Isn't it great to know that the word I used in my first sentence is filtered in both American and English English? :rofl3: Bloody PC world we live in. :b33r:

Edited by KurtBleach
Link to comment
Share on other sites

fstab depends on your hardware/pc setup so there is no right way to "show me how to configure the fstab right."

it is usually created automatically so shouldn't need editing anyway.

 

my advice, things work now so leave it alone. :mrgreen:

 

only time i can think of that i ever altered the fstab was to add/remove some read/write/trim options for a ssd drive i had installed which weren't added automatically because the os just saw it as another normal hard drive.

 

here's a good link that explains everything you should need to know about fstab. :- https://wiki.archlinux.org/index.php/Fstab

 

:b33r:

 

 

/dev/disk/by-id/ata-ST3250820AS_9QE5P89N-part2 / ext4 acl,user_xattr 1 1/dev/disk/by-id/ata-ST3250820AS_9QE5P89N-part3 /home ext4 acl,user_xattr 1 2/dev/disk/by-id/ata-ST3250820AS_9QE5P89N-part1 swap swap defaults 0 0/dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR0697468-part1 /tvrecs1 ext4 defaults 1 2/dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR0706563-part1 /tvrecs2 ext4 defaults 1 2/dev/disk/by-id/ata-WDC_WD1001FALS-00J7B0_WD-WMATV0287990-part1 /tvrecs3 ext4 defaults 1 2/dev/disk/by-id/ata-ST2000DM001-1CH164_S1E19G75-part1 /videos ext4 defaults 1 2/dev/disk/by-id/ata-ST2000DM001-1CH164_S1E19GB5-part1 /videosbackup ext4 defaults 1 2proc /proc proc defaults 0 0sysfs /sys sysfs noauto 0 0debugfs /sys/kernel/debug debugfs noauto 0 0usbfs /proc/bus/usb usbfs noauto 0 0devpts /dev/pts devpts mode=0620,gid=5 0 0

here's my fstab, notice there is no sr0 (cd/dvd drive) mentioned in it, because it's not needed in there any more and it works just fine same thing applies to a floppy drive i believe, as proven by yours not having a floppy entry in it but still works. :mrgreen:

 

so all you really need in yours is this.

/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part1 swap                 swap       defaults              0 0/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part2 /                    ext4       acl,user_xattr        1 1/dev/disk/by-id/ata-Maxtor_2F040J0_F15C43LE-part3 /home                ext4       acl,user_xattr        1 2proc                 /proc                proc       defaults              0 0sysfs                /sys                 sysfs      noauto                0 0debugfs              /sys/kernel/debug    debugfs    noauto                0 0usbfs                /proc/bus/usb        usbfs      noauto                0 0devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
Edited by terry1966
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...