Jump to content

Change Mode

Mounting A 64gb SDXC card in the Galaxy S3


Recommended Posts

Picked up a 64gb SDXC Kingston card and thought I would share how I got it mounted and working.After a bit of research, many people were saying that the card should work out of the box, or reformat to NTFS first. Or just stick it in the phone, go to storage, and format it from there. Didn't work for me. I'm rooted, so booted into custom recovery tried to 'mount & format' from there; again no go.I run Linux (openSUSE) on my PC, put the card in the reader, wouldn't mount. Turns out the default file system exFat32 is quite picky about what can a can't read it.So this is the fix that worked for me:You need access to a Windows 7 PC (Really couldn't get it to work with Vista)Download SDFormater from here:https://www.sdcard.org/downloads/formatter_4/This will reset the card to the default file structure.Now, we need the card in a file structure the S3 will read, namely FAT32; the problem with this is Windows can only see / format 32gb of FAT32. You will now need MiniTool Partition Wizard from here:MiniTool Partition Wizard Home Edition - CNET Download.comInstall it to windows and run.Your card will now show as F:/ (Or whatever drive it's in)Right click on it in the window and select 'reformat'. Choose FAT32. Click Apply on the menu bar and it will reformat all 64gb.You should now be good to go!!

Link to post
Share on other sites

just curious if you tried using gparted on it before using windows?

 

i recently bought a samsung 64GB class10 micro SDXC card for my pantech discover phone (even though the specs say it can only handle 32GB cards - googling it said otherwise). when i got the card and tried it in the phone, it was not recognized. i loaded it in my ubuntu 13.10 desktop and could not mount it at first, started up gparted and was able to format it to fat32.

 

i then proceeded to load 40+GBs of my music catalog on it, put it back in the phone where it was now recognized and works perfectly! :)

Link to post
Share on other sites

can't remember what suse uses in yast for partitioning but any time you find it doesn't work with a partition/file type for some reason or another you'll usually find that you can get the job done with fdisk instead. ;)

 

all that matters tho is you got it working (even if you had to use cough windows. :mrgreen: ). :banana:

 

:b33r:

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...