Jump to content

Change Mode

Linksys AE1000 in OpenSuse


Recommended Posts

I was last running OpenSuse 11.4 KDE 32bit and having trouble getting my Linksys AE1000 USB wireless N adapter to connect and be of use.


This was the most relevant info I could find, which, is quite helpful.




I've even tried running Mint, Gentoo and Sabayon live to see if any luck there, and got the same results. Guess this wifi adapter is not the best choice when running Linux.


Any recommendation for an 802.11n adapter that runs well in Linux?

Link to comment
Share on other sites

Bruce, I believe I had tried everything that was suggested in the post I showed from OpenSuse forums. What I have not tried was using Windows driver via ndiswrapper, seems it's a bad idea to do so. I was able to see the adapter listed in Yast under Hardware info as well as running the lsusb command.


Terry, I don't see it listed in the HCL and you may be right about the firmware. Can't say I've ever installed/upgraded firmware before.. would that require building an rpm?


I don't remember which kernel I had, already wiped the HDD so it would be ready to reinstall with a different mobo. Of course I will give it another go and see what the outcome is. Maybe I need to use the latest release of OpenSuse with at least kernel 3.4?


This is from the 3rd page, post #22 in the link I provided above


Your wireless is suffering from a transition in the driver. Now that the

development code is nearing what will be in kernel 3.4, things have stabilized.

Link to comment
Share on other sites

here's a link that should help you justin, it's for fedora but should work for suse i believe.



and my mistake rt3572usb isn't a firmware file but a driver, if my memories right, firmware files you just download and extract the file then copy it to where it needs to go (usually the lib/firmware folder) so no you don't build a rpm.


if the rpm doesn't work or you didn't try the rpm mentioned in the last post and your not having any luck following the instructions manually, then this other link may offer the answer.


in this one it says the latest rt3572usb driver doesn't work so to use an older version.



Edited by terry1966
Link to comment
Share on other sites

hmm, can't say I've tried Fedora yet either... I'll need to wipe spare HDD either way, but going to try Debian first.


I always thought firmware files are supposed to be install to the device itself.. guess I need to research that as well, it's something that I surely should know


I did just a bit earlier try running Sabayon live and get the same result as with Suse, in knetwork manager the wireless tab is greyed out. yet the device is listed as an attached device in lsusb

Link to comment
Share on other sites

  • 1 month later...

Think I see where I've been goofing. Got confused most likely due to over thinking the situation and making it much more complicated than it really is.


Unfortunately the Linksys adapter fried during the last round of storms we had about 2 weeks ago. I didn't get system shut down in time and it got hit by a nasty power surge. Fried motherboard and some USB devices died as well.


Ended up ordering one of these as a cheap replacement: http://www.ebay.com/itm/802-11n-g-b-150Mbps-Mini-USB-WiFi-Wireless-Adapter-Network-LAN-Card-w-Antenna-/200755616792?_trksid=p5197.m1992&_trkparms=aid%3D111000%26algo%3DREC.CURRENT%26ao%3D1%26asc%3D14%26meid%3D1318744803239642364%26pid%3D100015%26prg%3D1006%26rk%3D3%26


It's not the best out there, but it does work well in WinXP and the included mini CD has drivers to install in Windows, Linux and Mac environments. The Linux drivers are run.sh file type so should be a straight forward install.


I'll be setting it up to run on my quad core system as soon as I get the mobo repaired.

Link to comment
Share on other sites

Terry, I definitely bookmarked that awesome link you posted to LQ.org. Thanks again, mate! :b33r:


Justin, if you can get that adapter working (good luck!), could you be so kind as to tell us how you achieved success?

There's a thread a ways back about my troubles in trying to get wireless working. I gave up and bought a cat5 cable to connect, but if you succeed, maybe I can follow your example and take another whack at it. Good luck again.

Link to comment
Share on other sites

OK, I'm pretty sure I get it now. Should be smooth sailing ahead :yup:


I was following the opensuse guide for wireless, seen here:



I'm guessing this is meant for enabling built in wireless by connecting wired to another machine or directly to router. I was trying to enable wireless to a desktop machine using the USB type adapter, when NO wired connection was available. The wired connection method being a much simpler and easier route.


In this situation it would be possible by manual install, seen here:



This cheap-o adapter I'm using now came with a mini CD that has .pdf format user guides and a nice variety of drivers so it will run in Windows XP, Vista, 7 as well as Linux and even Mac. This device has an Ralink chip and the disc has Ralink drivers as well as Realtek drivers, which, should also be compatible.

Posted Image


I'll use the Ralink driver since I feel it's a safer choice. These are actually on the CD as .tar.bz2 (tarball).

10.2.2 Tarball

If the website doesn't have an RPM for openSUSE, it will most likely have a so-called tarball. Tarballs (*.tar.gz, *.tar.bz2) are simply compressed archives similar to ZIP and RAR files. To uncompress a tarball:

Open the Dolphin file manager => Navigate to the tarball => Right click => Extract Archive


The tarball might contain binaries that just need to be ran, or it might contain source code which needs to be compiled to run on your system - this can be very complicated, and requires you to first install various developer tools. There's no one standard way to install tarball content, but instructions should always be included in the tarball in files called INSTALL, README or similar - or you should be able to find installation instructions on the website where you downloaded the tarball.


Should work out well, I'll first read the user guide so I don't skip any important steps.


Out of curiosity, would I install the driver first then plug in the adapter to USB port (similar to how is done in Windows)? Or can the adapter be already plugged in prior to installing the driver?

Link to comment
Share on other sites

It isn't windows. You don't do things the way windows does them.


Ralink drivers are built into the kernel for many devices, you likely won't need the CD. However if you do need a driver I would recomend getting the latest one from the ralink site as the CD likely has old drivers on it.


Or you can use the repository as your fist link laid out.


zypper addrepo -f http://download.opensuse.org/repositories/driver:/wireless/openSUSE_12.1 wireless
Edited by Bruce
Link to comment
Share on other sites

Hail Bruce!

Bruce is DA MAN!


I hope "fist link laid" was a typo (I'm straight) :mrgreen: , but Bruce nailed this. (Not that I don't appreciate your efforts, Terry, but Bruce is spot-on here.)


Justin, copy and paste what Bruce put in the box in his post. Then, type the name of your wireless driver (mine is zd1211) into YaST or whichever method you use and d/l the firmware.


I did it, and now my dongle works. Of course I promptly disconnected it and replugged my cat5 cable in (did Pit speed test, way faster with the direct connect), but now I know how to get the wireless working - if I ever get the funds to buy a laptop or notebook and want WiFi connectivity.


Again: add that repo Bruce listed, find your dongle's driver, success should soon be yours.


Bruce rules. :worship:

Link to comment
Share on other sites

The thing about that is it then wants a wired connection in order to make the wireless available.

So why would I need the wireless if I had access to a wired connection?


Without installing drivers or firmware or whatever, the wireless tab stays grayed out so I'm not able to do anything with it.


Well I guess if there's no way for wireless only then forget it.

Link to comment
Share on other sites

You don't have access to a computer anywhere with a usb thumb drive or cd burner to put the files needed on?


How are you posting here? You must have internet access to download the needed files.

Link to comment
Share on other sites

Yes on my PC that I use which is running Windows XP. I'm really only using it for browsing the web and folding@home runs in the background. So why not set it up to run strictly on Linux? Sure I have usb thumb drive and dvd burner.

Link to comment
Share on other sites

2 ways around your problem that i can see.


1:- use the windows pc as an access point, ie. connect the linux pc to it by cable and use the xp machine as a gateway to the internet.

2:- download the railink driver/firmware on the xp machine transfer it across to the linux machine by usb stick, like bruce mentioned.



Link to comment
Share on other sites

  • 5 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...