Jump to content

Change Mode

PC Magnum Will Not Run

Recommended Posts

I've been attempting to run the PC Magnum free scan (try before buying). It appears to scan then shows a screen saying PC Magnum is loading at which point it hangs. The only way to close it down is using Task Manager.


My Operating System is Windows 7 Professional 64 bit. I can also dual boot into Windows XP Professional where the problem is the same. PC Magnum works correctly in the XP Virtual Machine but I'm not going to purchase a product that only runs in the Virtual Machine.


Any Suggestions?

Link to comment
Share on other sites



You will need to set your firewall to allow www.pcpitstop.com. The corresponding IP is The program name is PCMagnum.exe.


If the issue persists try running PC Magnum from Safe Mode with Networking to determine if the problem is with a third-party application interfering.


To access Safe Mode with Networking repeatedly tap the F5 or F8 key while the computer is booting up. Once the menu opens, select Safe Mode with Networking. The screen will look different because the video driver is not loaded. That will return to normal after a reboot. To run PC Magnum, you may need to go to Start>Programs>PC Pitstop>PC Magnum if the desktop icons are not present.


If the computer connects to the Internet using a wireless connection, it may be necessary to connect using an Ethernet cable in order to have Internet access from Safe Mode with Networking.

If it completes from Safe Mode with Networking but will not complete from Windows, it is being blocked from exchanging information with our server by a third-party program, most likely a firewall.


Let us know if the issue persists.

Link to comment
Share on other sites

Hi. Thanks for getting back to me. I have followed your advice and now recognise that I did not correctly report the problems yesterday.


In Windows 7, it is as I said before, PC Magnum loads and scans and then a screen appears which says that "PC Magnum is loading" and the program hangs. It does the same in Windows Safe Mode With Networking and I have checked and my firewall (Kaspersky Internet Security) is giving permission for PC Magnum to access the Internet.


In Windows XP Professional, the program will not install. It says that .Net is not installed. But Windows Update has installed both the Service Pack for .Net 3.5 and .Net 4. Yet again it does the same thing in Safe Mode.


In the version of Windows XP that is part of the Virtual Machine, the program loads,scans and reports what it has found. I also have Kaspersky Internet Security installed on the Virtual Machine and it is the same build on Windows 7, XP Professional and Virtual Machine XP (I have a multi-use licence).


My Internet access is via a router and cable modem and the computer is connected to the router via Ethernet cable.

Link to comment
Share on other sites

Thank you for the additional information.


For the XP computer try installing .NET 2.0 from here: http://www.microsoft.com/downloads/en/details.aspx?familyid=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en


For Windows 7, please try uninstalling/disabling Kaspersky Internet Security and see if that allows PC Magnum to finish its scan. Any time you see a "Loading" screen the program is trying to communicate with the remote server. If it does not get past that screen something locally is interfering with that communication. If necessary, we can have you open a help desk ticket and get a fiddler trace to see what's blocking the communication.

Link to comment
Share on other sites

XP first. Tried installing from your link but got Microsoft message saying download was incompatible with current installation. According to Add/Remove Programs, I currently have installed .Net framework 1.1; 2 (Service Pack 2); 3.0 (Service Pack 2); 3.5 (SP1); 4 (Client Profile) and 4 (Extended). They all show up in the Windows Registry but PC Magnum still says that .Net is not installed.


Windows 7. Tried disabling KIS but it made no difference. When I delved into the Application Control section of KIS it showed PC Magnum as "Trusted" with full Internet permissions.


By the way, I have been running Optimize 3 (and before that 2) for some time and that works perfectly in both Windows 7 and Windows XP. That seems to indicate that my computer has no problem linking with the PC Pitsop servers.

Link to comment
Share on other sites

  • 7 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...