Jump to content

Nvidia Driver security vulnerability


Bruce
 Share

Recommended Posts

A security vulnerability in the NVIDIA UNIX driver has been closed with the latest driver release, 295.40. Details about the vulnerability are available at: http://nvidia.custhelp.com/app/answers/detail/a_id/3109

 

Because the vulnerability makes it possible for attackers with read/write access to the GPU device nodes to access arbitrary system memory, NVIDIA recommends that users of the NVIDIA Linux, Solaris, and FreeBSD drivers with Geforce 8 or newer, G80 Quadro or newer, or any Tesla GPU update their drivers to version 295.40 or later.

 

For users of the NVIDIA Linux driver who need to continue using older drivers, a patch is available which closes the vulnerability. The patch is not necessary on 295.40 or later, which already includes the security fix. The patch, and instructions on how to apply it, are available at ftp://download.nvidia.com/XFree86/pa.../CVE-2012-0946

 

Users of the Linux CUDA debugger should note that an updated CUDA library is needed to maintain driver compatibility with the CUDA debugger after the security vulnerability has been closed. The 295.40 driver includes an updated CUDA library and is compatible with the CUDA debugger. The CUDA debugger will not work on an older driver which has had the security patch applied.

http://www.nvnews.net/vbulletin/showthread.php?t=178006

 

The latest driver can be downloaded from http://www.nvidia.com/Download/indexsg.aspx?lang=en-us

Link to comment
Share on other sites

Bruce, can you help me with installing the .run file I downloaded (nvidia driver)? I tried to find information on the interwebs but found some conflicting methods. Just wondering how you go about it.

Link to comment
Share on other sites

You first need to install

kernel source

kernel syms

gcc

make

automake

 

Then you need to disable the nvidia repository and uninstall the current nvidia drivers.

 

Once all that is done, it is a pretty straight forward process.

 

open a konsole

su

 

init 3

 

cd to the directory where the driver is aka cd /home/adam/Downloads

 

sh NV hit the tab key and it will fill in the rest automagically

 

follow through the prompts make sure to allow the install of 32 bit compatibity, and at the end let it write the xorg file. when finished reboot

Link to comment
Share on other sites

You first need to install

kernel source

kernel syms

gcc

make

automake

 

Then you need to disable the nvidia repository and uninstall the current nvidia drivers.

 

Once all that is done, it is a pretty straight forward process.

 

open a konsole

su

 

init 3

 

cd to the directory where the driver is aka cd /home/adam/Downloads

 

sh NV hit the tab key and it will fill in the rest automagically

 

follow through the prompts make sure to allow the install of 32 bit compatibity, and at the end let it write the xorg file. when finished reboot

 

:tup: NVIDIA 295.40

 

I did have to delete... /etc/modprobe.d/nvvidia-installer-disable-nouveau.conf. with my air cooled 6200 but other than that ..spot on...thanks guys. :adios:

Link to comment
Share on other sites

You first need to install

kernel source

kernel syms

gcc

make

automake

 

Then you need to disable the nvidia repository and uninstall the current nvidia drivers.

 

Once all that is done, it is a pretty straight forward process.

 

open a konsole

su

 

init 3

 

cd to the directory where the driver is aka cd /home/adam/Downloads

 

sh NV hit the tab key and it will fill in the rest automagically

 

follow through the prompts make sure to allow the install of 32 bit compatibity, and at the end let it write the xorg file. when finished reboot

 

I had a feeling I was going to be the only one that didn't know what to do. Would you mind please explaining how to do this in a bit more detail.

 

I googled it and I found "yum install kernel-devel" , and wasn't sure if that's all I needed to do.

Link to comment
Share on other sites

I'm using Mint , supposed to be the same repos as Ubuntu , from what everyone says. I did an update with the update manager , but after rebooting , it still says I'm using 270.41.06 when I check the Nvidia x server settings in the control center.

 

I tried to install the 295.40 driver by following this video , he says to change the permissions to execute file as a program but that didn't do anything.

I then tried the first method he mentioned. it says I have to exit the X server first, I'm trying to find out how to do that now.

 

http-~~-//www.youtube.com/watch?v=MAr8jbDH2NM

 

I found this from the nvidia installation guide http://us.download.n...talldriver.html

it said you need to configure x before using the driver. did you have to configure it, or just update?

Edited by Sanford
Link to comment
Share on other sites

sorry i am not familiar with mint, but yes i understand it may be using the same repos. i have not installed a driver from nvidia in years....all of my drivers get installed/updated using synaptic package manager.

 

how did you install your drivers in the first place? and what video card are you using?

 

if you used synaptic to install....open synaptic and search for "nvidia-current" ....if you find it, see what version it is.

 

as i said, i am using ubuntu 12.04 and the "nvidia-current" from synaptic is version 295.40, which installed a few days ago through a normal update.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...