Jump to content

cryptswap1 error


Sanford
 Share

Recommended Posts

I recently started using cryptkeeper, and lately I'm getting this error message every time I start up the computer. Can anyone tell me what this is/why its showing me this error?

 

It doesn't seem to affect anything , not that I've noticed anyhow, but I would like to know if there's anything I can do to prevent it from coming up each time I boot up.

 

http://i46.photobucket.com/albums/f143/Tortuga2112/cryptswap1error.jpg

Link to comment
Share on other sites

I found this when I googled it http://ubuntuforums.org/showthread.php?p=11780103 post # 8 the guy wrote this

 

sudo swapoff -a

sudo mkswap /dev/sda6

sudo swapon /dev/sda6

sudo ecryptfs-setup-swap

 

is this what I should do?

I wasn't sure what to do when you said to add to the /etc/rc.local file, or how to do that. I didn't see the folder you were talking about. I found the /etc folder and saw a bunch of .rc folders , I didn't see one named localPosted Image

Link to comment
Share on other sites

how do I add to the file ?

Do I enter it the same as what the other guy did, or do I need to change anything?

can I just enter it the same as whats written below?

 

sudo swapoff -a

sudo mkswap /dev/sda6

sudo swapon /dev/sda6

sudo ecryptfs-setup-swap

Link to comment
Share on other sites

Is your swap file on .dev/sda6?

 

Probably isn't.

 

Did you try what I said?

 

You simply open the file with a text editor and add the lines I posted.

 

You make things far more difficult for your self then you have to, because you do not follow simple instructions.

Link to comment
Share on other sites

yes you added the commands in the correct place, sorry it didn't work for you and have no advice of my own to offer, except try the commands you listed earlier in a terminal

sudo swapoff -a
sudo mkswap /dev/sda6
sudo swapon /dev/sda6
sudo ecryptfs-setup-swap
making sure the " /dev/sda6 " parts point to your actual swap partition so those lines might read
sudo mkswap /dev/sda1
sudo swapon /dev/sda1
and see if that works.

 

:b33r:

Edited by terry1966
Link to comment
Share on other sites

this is what the guy who helped me said

 

"The warning is due because the device /dev/mapper/cryptswap1 is not ready when the files of /etc/fstab are mounted by the system.

 

Therefore you have to comment the line /dev/mapper/cryptswap1 none swap sw 0 0 on /etc/fstab:

 

# /etc/fstab: static file system information.

#

# Use 'blkid -o value -s UUID' to print the universally unique identifier

# for a device; this may be used with UUID= as a more robust way to name

# devices that works even if disks are added and removed. See fstab(5).

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0

# / was on /dev/sda5 during installation

UUID=d689d262-2e00-4ad1-aa9c-f99ae98a99de / ext4 errors=remount-ro 0 1

# swap was on /dev/sda6 during installation

#UUID=c69c46d8-cff1-4d4f-8900-77c4d8da8ea1 none swap sw 0 0

#/dev/mapper/cryptswap1 none swap sw 0 0

 

The next step is to add a swapon command to the file /etc/rc.local. I suppose that the device will be ready when the file /etc/rc.local is processed.

 

gksudo gedit /etc/rc.local

 

Add the command swapon /dev/mapper/cryptswap1

 

#!/bin/sh -e

#

# rc.local

#

# This script is executed at the end of each multiuser runlevel.

# Make sure that the script will "exit 0" on success or any other

# value on error.

#

# In order to enable or disable this script just change the execution

# bits.

#

# By default this script does nothing.

 

Save & Exit.

 

Reboot the computer."

 

it looks like he did the same thing as what you guys were saying , as far as I can tell(adding swap 0n ), but for some reason it worked this time. What's the difference in what he wrote and what you guys suggested?

Edited by Sanford
Link to comment
Share on other sites

No he didn;t say even remotely what we said.

 

He said /dev.mapper/cryptswap was trying to mount before the swap file was mounted and ready. Therefore he removed it from dev mapper.

 

The he added it to rc.local which is started after all system services are running.

 

So in short he simply took it out from the early boot process and placed it at the very end of the process.

Link to comment
Share on other sites

Now that you have a it running I have huge, monstrous warning for you.

 

If you encrypt directories or file systems I have a feeling that you will end up losing access to them because if something goes wrong, pretty much you will have to know how to remedy it, and that will certainly be far more complicated then just turning the service on.

Link to comment
Share on other sites

thanks for the warning , Bruce. I'll be sure to keep a backup externally of the stuff in the encrypted folders. Currently I don't really have anything too important in them , just a few naughty pics the GF sent me that I don't want anyone to be able to just open if they're using my computer when I'm not nearby.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...