Jump to content
Sign in to follow this  
Sanford

openshot problem with blender

Recommended Posts

I'm trying to add an animated title like the one in this guy's video working , but its not working the way he says to do it.

I tried to follow his tutorial but I don't think I have the path right for blender.

 

I did what he said at the 6:00 mark , I typed in which blender in terminal and got the path and pasted it in. But , when I went to try it in openshot I got an error. it said to make sure the path is correct for blender.

 

http://www.youtube.com/watch?v=dh7P-UCKAd4

 

I just checked it again , and it said to make sure its pointing to version 2.56 or greater , but it says my version is 2.49

so, how do I get the newer version?

Edited by Sanford

Share this post


Link to post
Share on other sites

sudo add-apt-repository ppa:cheleb/blender-svn
sudo apt-get update
sudo apt-get install blender

New software with ubuntu or mint = ppa.

 

Always always always always always always always always ppa.

Edited by adam22

Share this post


Link to post
Share on other sites

thanks, I guess I should know that by now , eh! :facepalm:

 

I updated blender , but I'm still getting this error

 

Error Output:

No frame was found in the output from Blender

 

what's that mean?

Edited by Sanford

Share this post


Link to post
Share on other sites

Well it's working well for me. The blender effects are what got me interested in looking at it. Not time to play with some of those effects. :tup:

Share this post


Link to post
Share on other sites

I found another guy's solution here http://www.openshotusers.com/forum/viewtopic.php?f=25&t=876

I created the folder and changed the directory as he did it and was trying to get it to extract the files but it was giving me this error

 

sudo tar jxvf /path/to/archive/blender-2.62-linux-glibc27-i686.tar.bz2

[sudo] password for dc:

tar (child): /path/to/archive/blender-2.62-linux-glibc27-i686.tar.bz2: Cannot open: No such file or directory

tar (child): Error is not recoverable: exiting now

tar: Child returned status 2

tar: Error is not recoverable: exiting now

 

 

When I go into the blender folder and launch it from there it opens fine.

what exactly is this error telling me? what is the frame its looking for?

 

Error Output:

No frame was found in the output from Blender

Edited by Sanford

Share this post


Link to post
Share on other sites

I guess it is telling you that no frame was found in the output.

 

All of my searches say it is a path issue.

 

As for the extract issue well you need to supply the real path name not /path/to

Share this post


Link to post
Share on other sites

ok.

 

so, what's does the guy in the post I linked to mean when he says this part?

 

 

"4. And extracted the Blender Archive in the new folder Code: Select all sudo tar jxvf /path/to/archive/blender-2.57-linux-glibc27-i686.tar.bz2 "

this is where he lost me, and from what you said about supplying the real name, I guess I was supposed to change what he wrote to where my computer has the file. The only thing I did was change the 2.57 to 2.62

 

I don't know how to extract the file to the /opt/blender directory , where do I find that when I'm extracting the file?

when I hit extract I don't see the directory, so I guess I'm not looking in the right place.

Edited by Sanford

Share this post


Link to post
Share on other sites

Yes you are supposed to change it to where the file exists on your computer. Or of course you could simply right click the file and choose extract here or whatever gnome menu has to d file extractions. :tup:

 

I don't know where you are extracting to but it won't automatically go to opt. you would have to put it there after extracting if that is where you want it.

 

To be honest, I understand your confusion I was there at one time a long time ago. However if you take your time, and look at things using basic common sense things will start to come together for you. Pretty much folks complicate things more than they have to when trying new things.

Share this post


Link to post
Share on other sites

Testing a new android app, and openshot blender options :tup:

 

Share this post


Link to post
Share on other sites

I think you're misunderstanding me , I can extract it no problem , where I'm not following the guy's instructions is where the /opt folder is.

When he says he creates a folder in /opt , what/where is "/opt"? is that just the name of a folder he's just made, or is that a folder somewhere I'm not looking?

 

I made that directory using the "sudo mkdir /opt/blender" command he says to use , and did step 3. "cd /opt/blender" , but I'm doing something wrong in the last step.

 

so, where is the /opt directory being created?

Again, I apologize if these seem like stupid questions, but following some of the instructions is a bit confusing when the guy writing it kind of assumes you're supposed to know what you're doing. I have stated previously , I'm learning this stuff as I

go. That's why a lot of the time I'm just copying/pasting the commands , and when the person writes "path/to" it gets copied in as is.

 

 

 

 

"1. Download the Blender 2.57 archive, blender-2.57-linux-glibc27-i686.tar.bz2 from http://www.blender.org/download/get-blender/

2. Created a folder in which to extract the archive. I created the folder in /opt rather than in my home directory. Code: Select all sudo mkdir /opt/blender

 

3. I then changed to the directory I created Code: Select all cd /opt/blender

 

4. And extracted the Blender Archive in the new folder Code: Select all sudo tar jxvf /path/to/archive/blender-2.57-linux-glibc27-i686.tar.bz2

 

5. I next opened the Preferences dialog in OpenShot and set the correct Blender executable,

for me it is now /opt/blender/blender-2.57-linux-glibc27-i686/blender

6. I then created an animated title as a test, it worked.

7. Blender did now show up in my menu so I edited the menu to create a new item."

Edited by Sanford

Share this post


Link to post
Share on other sites

So it is working for you now?

 

/opt is exactly where it says.

 

/ is the root directory

 

So /opt is one level into the root directory

 

Then of course /opt/blender is two levels deep.

 

If you were to browse to the / directory on your system it would show you all the directories it contains and /opt will be there. Gnome is of course different than KDE but the directory structure is the same for instance here is what my / directory looks like and it has a /opt directory.

 

Posted Image

Share this post


Link to post
Share on other sites

I've located the /opt folder , and the blender folder I created in terminal , but its not allowing me to extract it to that folder. I'm unable to copy the files there either.

its saying I don't have permission to copy it to that folder.

 

nevermind, I got it extracted , I didn't see the "open as administrator" at the bottom.

 

 

I've changed the path in openshot to "/opt/blender/blender" but I'm still getting the same error.

Edited by Sanford

Share this post


Link to post
Share on other sites

here you go sanford this should help you get a better understanding of linux and it's file system, so you understand "paths" and "permissions" and lots of ther stuff.

 

http://lowfatlinux.com/

 

just click on the "file systems" link and read the page then click on the next lesson link underneath until you've gone through them all.

 

after reading all the lessons you should have a much better idea of what your trying to do, when following other people's guides/instructions.

 

:b33r:

Share this post


Link to post
Share on other sites

I bookmarked that link, I will read it tomorrow.

 

What helps a lot of people (and did so in my college linux course) was to draw out the unix/linux hirerarchial file system.

 

It makes a lot more sense than the file management used in Windows, in my opinion.

 

Short tip: files/folders in the / (root) directory require superuser privelages to access/modify. Also,placing a dot (.) in front of a folder makes that folder hidden.

Share this post


Link to post
Share on other sites

I've located the /opt folder , and the blender folder I created in terminal , but its not allowing me to extract it to that folder. I'm unable to copy the files there either.

its saying I don't have permission to copy it to that folder.

 

nevermind, I got it extracted , I didn't see the "open as administrator" at the bottom.

 

 

I've changed the path in openshot to "/opt/blender/blender" but I'm still getting the same error.

 

In the post above my folder shot you said it was working. Then you went and made changes........why did you change it if it was working? :huh:

Share this post


Link to post
Share on other sites

In the post above my folder shot you said it was working. Then you went and made changes........why did you change it if it was working? :huh:

 

it was never working for me. I was quoting what the other guy did to get it working.

 

thanks for the link Terry.

 

here's a screencast of what I did. I read a lot of post from others with the same problem and this is how they fixed the problem. I don't know why its not working for me.

 

What do you guys think , did I do something wrong ? I'm pretty sure I followed their instructions correctly.

BTW, I'm using the latest version of openshot 1.3.0, and the latest version of blender 2.62 , if that makes a difference.

 

http-~~-//www.youtube.com/watch?v=XkwOj9cgUwY

 

 

ok, I finally got it working . I uninstalled openshot and downloaded the newer version 1.4.2 and it worked.

Edited by Sanford

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...