Jump to content
Sign in to follow this  
Sanford

compiz burn effect won't work

Recommended Posts

I was trying to get this effect working but it just won't work.

 

 

 

 

 

what settings are you guys that have this effect using?

Share this post


Link to post
Share on other sites

What graphics controller are you using? Burn works fine for me, but it's a little laggy so I don't bother with it. Are you using a proprietary or open source driver?

Share this post


Link to post
Share on other sites

If you go to terminal and put in "lspci" it will output some hardware information for you. Here is mine:

 

01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]

If you go to system>admin>additional drivers, you can see if you have activated a proprietary driver.

Share this post


Link to post
Share on other sites

You don't know what video card you have?

 

I knew I had a nvidia graphics card , but I wasn't sure what he meant when he said graphics controller. I thought he was asking about the driver.

Share this post


Link to post
Share on other sites

If you go to terminal and put in "lspci" it will output some hardware information for you. Here is mine:

 

 

 

If you go to system>admin>additional drivers, you can see if you have activated a proprietary driver.

 

here's what it said for the graphics controller when I entered "lspci" in terminal.

 

01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 335M] (rev a2)

 

I went into system>admin> additional drivers , and it said NVIDIA accelerated graphics driver. At the bottom it said driver activated but not in use.

So, how do I switch to this one?

 

Posted Image

Edited by Sanford

Share this post


Link to post
Share on other sites

well, I went through a bunch of stuff with Bruce to check this , and he says I'm using the recommended NVIDIA driver even though it says I'm not.

I still can't get this effect to work for me. I'll post a screencast of what settings I've got it set to later.

Share this post


Link to post
Share on other sites

sanford, as much as i hate video tutorials, i will do my best to show you how i set up the burn effect in compiz-config-settings-manager (ccsm). i will not add audio, so i will explain it first then you can see how i did it in the video:

 

first open ccsm, go to > effects > animation

 

in "open animation" tab, under "animation selection"....click once on the top effect (glide 2 ?) to highlight it, then click the "edit" button. in the window that opens, double click inside the box that says "windows match" to highlight the entire line, then right-click on it and choose "copy" from the drop down list. click "close" on that box. back in the open animation tab, click the "new" button. when that window opens, click the little arrows at the end of the "open effect" box and choose "burn" from the list. change the "duration" box to something around 500. next, double-click in the empty "window match" box and choose "paste" from the drop-down list (effect will not work if this box is left blank....which is why i had you copy the contents from the glide 2 effect and past it here). close that box when finished. back in the open animation tab, look at the list under animation selection, and you should see that "burn" has been added to the bottom of the list....click once on "burn" to highlight it, then keep clicking the "up" button until "burn" is at the top.

 

thats is....burn should be working for "open animation". repeat the same process for "close animation" if you want.

 

here is my very, amateurish video showing how its done:

 

http://youtu.be/KcA9tyssWnU

 

hope that helps somehow.

 

btw, i would not worry about the additional drivers thing saying that the drivers are not enabled....i believe that is a bug. as bruce pointed out (in another thread?)...so long as nvidia-settings opens properly, they are enabled. if they were not enabled, nvidia-settings would not open correctly. instead you would see a message saying that drivers are not installed or working properly.

Edited by numerounoyankeefan

Share this post


Link to post
Share on other sites

Sanford, it's a bug. I've seen it before. Your graphics card driver is in use.

 

Yankeesfan tutorial is spot on.

Share this post


Link to post
Share on other sites

you're welcome. about those settings....the 500 number was just what i set mine to. that controls the length of the burn, a higher number results in a slower burn, a lower number will bring a quicker burn.

 

i have no idea what that "window match" line i had you copy and paste actually means. :shrug: i only know that burn does not work if the space is left blank. i did not know what to put in there, so i just copied the info from the glide 2 effect into the space and was pleasantly surprised when it worked.

 

i was just playing around with that setting and i found a much less complicated looking, window match line under the shade animation tab for the "roll up" effect...you may want to try replacing that line with the following:

 

(type=Normal | Dialog | ModalDialog | Utility | Unknown)

just copy and paste that line in place of the one you did earlier....see if the burn effect looks any better. again, i have no idea what any of that means, but you can try it and see if you notice any difference.

 

you can use that same (or similar) approach for trying out any of the animations. ...some of them are pretty cool!

Share this post


Link to post
Share on other sites

Not sure why you guys need to edit that line. For me, it's just a matter of selecting the effect. I have mine set to 150, by the way.

 

I wasn't able to make kazam work. I'm going to be going to mint 12 so I will try from there.

Share this post


Link to post
Share on other sites

Mint 12 has big issues with ATI cards. It works fine until you load the ATI driver then everything gets fubarred pretty bad.

Edited by Bruce

Share this post


Link to post
Share on other sites

Not sure why you guys need to edit that line. For me, it's just a matter of selecting the effect. I have mine set to 150, by the way.

 

adam, when you selected burn....was that line filled in, or blank? mine was originally (by default?) set on glide 2, when i changed it to burn...that line was blank and burn would not work. also, the burn length was set at its lowest setting of 50. it only worked when i added something into the window match line, and of course increased the length of the burn to something other then 50 (which is so fast i can't even see it).

 

no idea why you are guys are having problems with kazam. it installed without issues for me, and works really well. it is by far the easiest screen capture app that i have used (not that i have tried many mind you, but i have tried a few over the years). :tup:

Edited by numerounoyankeefan

Share this post


Link to post
Share on other sites

yankeefan, that vid was just what I needed. I don't know why none of the tutorials I watched on youtube mentioned that. almost all the vids I saw were just guys showing off the effects, and not giving you much instruction on how to set them up.

 

Adam, I just got compiz working , as well as just got my skype camera to work , so even if I can't get kazam to work I think I'll stick with 11 for a while. If you weren't able to get it to work , I doubt I will either.

Edited by Sanford

Share this post


Link to post
Share on other sites

Line was already filled in.

 

Bruce, guess Mint 12 is a no go at this point. I need to use the catalyst driver, the open source one isn't very good.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...