Jump to content
Sign in to follow this  
Sanford

gtk record my desktop pixelation

Recommended Posts

I just built Kazam from source and it seems to work relatively well, I am going to play with it a bit and see if I can get it to work better :tup:

Share this post


Link to post
Share on other sites

Just out of curiosity, how were you able to get snap to work?

Share this post


Link to post
Share on other sites

I've seen tutorials about it but was never able to get it working. Do you know what version of Compiz you are using? The tutorials that I saw made the expo feature not work, which is lame.

Share this post


Link to post
Share on other sites

synaptic says i have compiz version: 1:0.9.6+bzr20110929-0ubuntu6.1

 

i never used any tutorial or anything to set it up....when unity came along, i just kinda felt my way around. enabling a few of the effects caused me to loose unity, the top panel and all windows management....my only recourse was to press ctrl-alt-f1 to drop to a TTY, then do a sudo reboot to get back to the desktop. after that whatever effect i was trying to enable would be working fine. was just a pita to do that 2-3 times when first setting it up.

 

btw that half-screen, snapping windows effect is called "grid" in compiz-config-settings-manager, and like i said....i do not remember enabling it. afaik, it was already enabled and working fine.

Share this post


Link to post
Share on other sites

Thanks for the information. You are on a newer version of Compiz and Ubuntu. I'm also not using Unity, but classic GNOME.

 

I have Grid but all I am able to do is edit the key bindings, which is far less useful than simply dragging it to the side of the screen.

 

I might have to upgrade to Mint 12 and the newer compiz to take advantage of this feature, but I'm not really looking forward to that.

Share this post


Link to post
Share on other sites

Would you mind giving me the ppa you used yankeefan?

 

E: Some index files failed to download. They have been ignored, or old ones used instead.

[email protected] ~ $ sudo apt-get install kazam

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package kazam

 

 

Edit: I had to use this ppa: ppa:and471/kazam-daily-stable since I was on an older version of Ubuntu/Mint.

 

The damn program won't launch for me. I'll need to figure this out.

Edited by adam22

Share this post


Link to post
Share on other sites

kazam
/home/adam/.themes/aerospace/gtk-2.0/toolbar-custom.rc:21: Unable to locate image file in pixmap_path: "Toolbar/toolbar-black.png"
/home/adam/.themes/aerospace/gtk-2.0/toolbar-custom.rc:24: Background image options specified without filename
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:20: Unable to locate image file in pixmap_path: "Panel/panel-bg-black-36.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:72: Unable to locate image file in pixmap_path: "Panel/panel-bg-black-36.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:102: Unable to locate image file in pixmap_path: "Panel/panelbutton_gray_2.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:105: Background image options specified without filename
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:123: Unable to locate image file in pixmap_path: "Panel/panelbutton_gray_2.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:129: Background image options specified without filename
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:225: Unable to locate image file in pixmap_path: "Panel/panelbutton_black_4.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:231: Background image options specified without filename
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:238: Unable to locate image file in pixmap_path: "Panel/panelbutton_black_4.png"
/home/adam/.themes/aerospace/gtk-2.0/panel_custom.rc:241: Background image options specified without filename
/home/adam/.themes/aerospace/gtk-2.0/gtkrc:187: Unable to locate image file in pixmap_path: "Arrows/arrow-up.png"
/home/adam/.themes/aerospace/gtk-2.0/gtkrc:191: Overlay image options specified without filename
ERROR Kazam	  - Could not find any typelib for AppIndicator3
Traceback (most recent call last):
  File "/usr/bin/kazam", line 74, in <module>
    appWindow = KazamApp(datadir, args.debug)
  File "/usr/lib/python2.7/dist-packages/kazam/app.py", line 83, in __init__
    self.indicator = KazamIndicator()
  File "/usr/lib/python2.7/dist-packages/kazam/frontend/indicator.py", line 148, in __init__
    super(KazamIndicator, self).__init__()
  File "/usr/lib/python2.7/dist-packages/kazam/frontend/indicator.py", line 59, in __init__
    self.menuitem_pause = Gtk.CheckMenuItem(_("Pause recording"))
TypeError: GObject.__init__() takes exactly 0 arguments (1 given)

Kazam doesn't like me

Share this post


Link to post
Share on other sites

Just get the latest source and build it. That's what I did and it works flawlessly

Share this post


Link to post
Share on other sites

<p>

<br />

Just get the latest source and build it. That's what I did and it works flawlessly<br />

 

</p>

<p> </p>

<p>Hey Bruce , nice vid , thanks for mentioning me , I feel like I've actually made a minor contribution now, rather than just being a leech, lol. I have a few questions , though.</p>

<p> </p>

<p>1. could you tell us ( when I say us, I mean the noobs , like moi <img alt=":mrgreen:" class="bbc_emoticon" src="http://forums.pcpitstop.com/public/style_emoticons/default/icon_mrgreen.gif" title=":mrgreen:" /> )what you did when you say to build it. I'm afraid what seems simple to you is still beyond my skillset.</p>

<p>2. your video mentioned changing the settings on the video card, I had mentioned on my other thread about compiz burn effect that when I checked which driver I was using it said NVIDIA accelerated drivers are installed but not in use. should I change the settings before installing kazam , or does that even matter?</p>

<p>3. How do I switch to the accelerated driver that's not in use?</p>

<p>4. This link you posted , <a href="http://www.webupd8.org/2010/09/try-kazam-new-screencasting-application.html">http://www.webupd8.org/2010/09/try-kazam-new-screencasting-application.html</a> ,</p>

<p>there's a line which says "If you're not using Ubuntu, grab Kazam Screencaster from <a class="external" href="https://code.launchpad.net/kazam">HERE</a> (you'll need BZR to download it)."</p>

<p>can I still use the Ubuntu version, even though I'm using mint 11 ?</p>

<p> </p>

<div style="text-align: justify;"> </div>

Share this post


Link to post
Share on other sites

I am not sure how well the unbuntu repo nvidia drivers work.

 

You need to figure out why your system isn't using the nvidia driver.

 

It will indeed make a difference.

 

That said, on my systems I always install nvidia drivers via command line and don't repositories. Only because I like to try different drivers on a regular basis and I am used to doing things that way.

 

I don't think you need to build kazam from source if it working, but getting your drivers configured properly is pretty important.

Share this post


Link to post
Share on other sites

Open a terminal, run sudo nvidia-xconfig, and restart X (reboot works).

Share this post


Link to post
Share on other sites

Yep that is correct.

 

It is basically saying that it wrote a new file because the other one wasn't being used.

 

You can try restarting now.

 

If it is broke aka no desktop, I hope you have a way to get here so we can revert it back.

Share this post


Link to post
Share on other sites

ok, I'm going to try restarting it now. but if it doesn't show the desktop , can I still get into terminal to revert it?

Share this post


Link to post
Share on other sites

ok, I'm back , had me scared there for a sec, went to a black screen , I thought it was done ,flashed the NVIDIA logo , and then came back up.

I went and checked , but it still said driver is activated but not in use.

Share this post


Link to post
Share on other sites

run glxinfo in a terminal.

 

If the driver is working properly you should see a line

 

direct rendering: Yes

 

and the line

 

OpenGL vendor string: NVIDIA Corporation

Share this post


Link to post
Share on other sites

ok, those lines are there.

 

here's what it said

 

sudo glxinfo

[sudo] password for dc:

name of display: :0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: NVIDIA Corporation

Edited by Sanford

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...