Jump to content

Change Mode

sfc workaround


Bright boy
 Share

Recommended Posts

May be old news but new to me and possibly others. I think it is safe to say many of us have run into the problem when running SFC and being asked for the CD which more than l ilkely we don't have.

Here is a workaround.

 

Copy the I386 directory to the root of C..Now type regedit in the Run box on the start menu and navigate to:

 

HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows

CurrentVersionSetup

 

You will see various entries here on the right hand side. The one we want is called:

 

SourcePath

 

It probably has an entry pointing to your CD-ROM drive, and that is why it is asking for the XP CD. All we need to do is change it to:

 

C:

 

Simply double click the SourcePatch setting and a new box will pop up allowing you to make the change.

 

Now restart your computer and try scannow sfc again!

Edited by Bright boy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...