Jump to content

Change Mode

Opensuse 11.4 - Sound


Recommended Posts

Hello,

About to do a fresh install of openSuse 11.4

 

What changes should I make to get sound via HDMI. I have onboard sound for my pc speaker and an HDMI slot on my ATI HD3450 vid card. PC speakers work fine but if I open Kmix set HDMI for sound. I get nothing from the TV sound still comes from the pc speakers. As some of you know, I multiboot. Onboard sound and TV sound via HDMI works fine on Sabayon, Ubuntu and Windows. Not on openSuSE or Fedora.

 

Thanks

Link to post
Share on other sites

to get the sound through the hdmi, if i remember correctly what you need to do is go into system settings>multimedia>phonon and then set the ati digital audio as the default sound output device,

 

or as i did with the mythtv app i could just change what audio device it used for sound output so could get all sounds coming out of my speakers while setting mythtv to use the ati hdmi audio output through the tv.

 

been a long time since i used an ati card tho.

 

at the minute, i use nvidia along with headphones and speakers for my sound output choices, and have mythtv coming out the tv on hdmi, the ringing of skype coming out of the speakers but the actual call coming out of the headphones and then everything else coming out of the speakers.

 

i think some apps the sound might actually come out of both the tv and the speakers but can't really remember which now because i don't really use anything except, mythtv, skype and firefox on a regular basis.

 

:b33r:

Link to post
Share on other sites

Is using YaST to change the default sound output device any different than right clicking on the speaker icon in the toolbar then "select master channel" and choosing HDMI?

Link to post
Share on other sites

It's not a complicated process, and if changing your output device to HDMI does not work, then something is broke...could be a setting, could be a problem with OpenSuSE.

 

Posted Image

Link to post
Share on other sites

It's not hard at all Adam .... but it's not just openSuSE. Doesn't work properly in Fedora either. Works great in Sabayon and Ubuntu. Think I said all this in the first post :)

Link to post
Share on other sites

pulse audio I am willing to bet is rearing it's disgusting awful ugly head. ;)

 

If you are using KDE just disable pulse audio in Yast.

 

Then go into software management and uninstall the horrid thing that it is

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...