Jump to content

Change Mode

Cpu Temperature Monitor


Recommended Posts

I'm running opensuse 11.3 and am having some issues trying to monitor my cpu temps. I ran the sensors-detect and answered the questions, and it seemingly found the sensor for my amd cpu. However when I try to configure gkrellm under the temperature settings I only have one for my gpu and the k10temp that shows overall system temperature. I am not sure what I am doing wrong. I also tried conky but it does not give me the info I am after either. On my intel based laptop also running opensuse it displays the cpu temp on the my computer page, and I did not even have to configure anything. Any suggestions?

Link to post
Share on other sites

Run the sensors command from a terminal. What does it say? Here's mine right now while encoding some video.

 

[email protected]:~> sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +54.0°C  (high = +80.0°C, crit = +100.0°C)  

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +53.0°C  (high = +80.0°C, crit = +100.0°C)  

coretemp-isa-0002
Adapter: ISA adapter
Core 2:      +54.0°C  (high = +80.0°C, crit = +100.0°C)  

coretemp-isa-0003
Adapter: ISA adapter
Core 3:      +52.0°C  (high = +80.0°C, crit = +100.0°C)  

it8720-isa-0290
Adapter: ISA adapter
in0:         +1.09 V  (min =  +0.00 V, max =  +4.08 V)   
in1:         +1.63 V  (min =  +0.00 V, max =  +4.08 V)   
in2:         +3.34 V  (min =  +0.00 V, max =  +4.08 V)   
in3:         +2.93 V  (min =  +0.00 V, max =  +4.08 V)   
in4:         +2.35 V  (min =  +0.00 V, max =  +4.08 V)   
in5:         +3.10 V  (min =  +0.00 V, max =  +4.08 V)   
in6:         +0.75 V  (min =  +0.00 V, max =  +1.06 V)   
in7:         +3.01 V  (min =  +0.00 V, max =  +4.08 V)   
Vbat:        +3.28 V
fan1:       1388 RPM  (min =   10 RPM)
fan2:          0 RPM  (min =    0 RPM)
fan3:          0 RPM  (min =    0 RPM)
fan4:          0 RPM  (min =    0 RPM)
temp1:       +36.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp2:       +49.0°C  (low  = +127.0°C, high = +90.0°C)  sensor = thermal diode
temp3:       +48.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor

[email protected]:~> 
Link to post
Share on other sites

not sure what to tell you, if that's all sensors shows then maybe that's the only temp sensor to find. :shrug:

 

:b33r:

 

can you run sensors-detect again and post the entire output and we can check it for you.

 

we'll see if you need to modprobe any other drivers like the coretemp one in johns post.

Edited by terry1966
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...