Jump to content

Change Mode

Athlon Xp Compatible Games


Recommended Posts

  • Replies 581
  • Created
  • Last Reply

Top Posters In This Topic

In that thread Jonathan Blow says "The Steam version of Braid already has the Athlon XP fix."

and another comment "So, the full game didn't work on a non-SSE2 %#@%#^ of mine, dled this file, worked, so I just swapped .exes and it all works like a charm ^^ thx a million."

So steam version should atleast work and using .exe from demo works.

Not 100% cause i dont have it but steam price is 2.70.Almost free.

 

umm sounds interesting, i will try

well, i do own the game, but i had to run it in my notebook thanks to our hated enemy sse2

and it ran like crap

i will try to swap exes and see what happens

Link to post
Share on other sites

Anything new?Its using physx=sse2 hah hah.Again propably thats crashing it.

Try game forums and/or send mail to Headup.

There wasnt that nvtt.dll if i remember right?

 

hmm... sorry I wasn't aware that physx = sse2 somehow :huh: I was just surprised it crashed because of the minimum system requirements...oh well, time 2 upgrade i guess :rolleyes:

no nvtt.dll in game folder either...

Link to post
Share on other sites

hmm... sorry I wasn't aware that physx = sse2 somehow :huh: I was just surprised it crashed because of the minimum system requirements...oh well, time 2 upgrade i guess :rolleyes:

no nvtt.dll in game folder either...

 

Not sure is it physx but wheres physx theres problems.I dont have game myself but if you are interested ask Headup if they could fix.

My link and comment "I was there with Alien Breed, only thanks to Team17's goodwill i was able to play it. I was the only one who complained about it in their forums and still they fixed it. That's why i love small companies, they care about their customers." so it is possible and asking doesnt cost anything.:)

Link to post
Share on other sites

Working games so far, that haven't been posted:

 

Serious Sam HD First & Second Encounter :rocks:

Company of Heroes + All Expansions

Painkiller: Redemption also runs, it uses the old PK engine :geezer:

Cities in Motion

Super Meat Boy

Zombie Driver

 

Shank didn't work for me (SSE2 related)

Warhammer 40.000: Dawn of War 2 (and it's expansions) didn't work either on Athlon XP 3200+ (probably SSE2 related, i'm not sure because it's supposed to be the same engine as CoH :surrender:)

 

edit: this list is awesome, too bad it's spread so wide among 6 pages, should be on wikipedia imo :unsure:

Edited by dseries
Link to post
Share on other sites

And about DeathSpank?Somebody writes in steam forums My link that non-sse2 patch is done but not tested?

My link (dead thread) they tried compile something without sse2 and some library still used sse2.

Maybe it was also third party and not their own code?

Are DeathSpank and Shank using physx?

So propably these are compiled with sse2?

Edited by kazoomsha
Link to post
Share on other sites

Just find out that Dogfighter was updated "legacy PhysX support (2.8.3) for non-SSE2".

And about DeathSpank?Somebody writes in steam forums that non-sse2 patch is done but not tested?

Are DeathSpank and Shank using physx?

 

hi! they don't use physx I think

both Shank & Deathspank require SSE2 on an engine-level.....found this on shank blog: :mrsgreen:

 

Potential Customer '">

So is the patch going to do anything about about the SSE2 instructions?

The requirements say "Pentium 4 (or equivalent)". This includes the Athlon XP on every other Steam game page.

 

Jamie (dev)'">

@Potential Customer — alas, we do require SSE2 for the game. We've now updated the requirements description to avoid that confusion — sorry about that!

 

edit: or it might be just a portion of the engine that uses SSE2, like in Call of Duty series, where in Modern Warfare & MW2 you just had to delete/rename a file (because of the miles sound system), but in World at War & Black Ops miles was intergrated into the engine, not allowing you to rename the little file :hammer: ...annoying

Edited by dseries
Link to post
Share on other sites

I was wondering that iw engine too.So i downloaded Quantum of Solace demo and it right away gives illegal instruction.Theres same file (mssmp3.asi) as in MW's but delete/rename didnt help.Is full game supposed to work (NOT working) cause i didnt find anything and if not, working iw games are made by Infinity Ward.Heh...(or maybe Activision got something to do with this,new games sales also new cpu's)Maybe this miles problem could be fixed by modding .exe or where ever it is set in use?Location usually: bin(or where ever game .exe is)milesmssmp3.asi) NecroVisioN and same thing but watson gives error in Engine.dll.The Witcher uses miles.Wasnt sure about this so i first renamed mssmp3.asi to .bak and started from witcher.exe and works.Then i renamed it back to .asi and started witcher.exe and works.Launcher worked alsoDrift City use miles works.Duke Nukem Forever use miles works. (unreal2.5)mss32.dll version 7.2.6.0 but theres MilesAudio.dll and dont remember seeing it in these other games.Space Siege use miles but works.Empire:Total War miles and rename works.Total War:Shogun 2 use miles and not working (demo) but sse2 is in game requirements.Napoleon:Total War use miles and not working (demo) but sse2 is in requirements.Might&Magic Heroes 6 demoAfter loading logo videos it crashes to desktop and illegal instruction error.Also tried set all in profile file to false and low.Mss32.dll 7.2.2.0.Under Item Name:File Version 7.2c.Gives error with 7.2.6.0 "The procedure entry point [email protected] could not be located in the dynamic link library mss32.dll."Sideway miles works.Mss32.dll 7.2.6.0.Under Item Name:File Version 7.2.g.Most Source Engine games uses Miles.All?Is that fixed cod mssmp3.asi working with these others?

Edited by kazoomsha
Link to post
Share on other sites

NOT working demo games.

 

Supreme Commander 2

James Cameron's Avatar:The Game

Civilization V

Crash Time 4 ( it got separate .exe for lower and higher settings)

Dynasty Warriors 6

The Club

 

Venetica My link and My link

Demo didnt work but in those link is mentioned patch.

And if i translated right it shouldnt use sse2."Aktuell unterstützt Venetica kein SSE2.

 

Quantum of Solace

It got also this,from wikipedia:

"Several users have reported that the PC version of the game will not run on Windows XP if Internet Explorer 8 or an updated version of Internet Explorer 7 is installed on the system.[40][41][42] This essentially makes the game unplayable for users who keep their Windows systems up to date. The issue seems to be fixed if the user reverts the system to Internet Explorer 7 prior to the June 2009 Security Update,[43] by uninstalling all IE7 Security Updates issued since then, but this has the obvious repercussion of leaving the system insecure. As of April 2011, Activision has not released a patch addressing this issue, and there is no page on Activision's customer support database acknowledging it."

 

Operation Flashpoint:Dragon Rising

Wildlife Park 3

Colin McRae:Dirt 2

Booster Trooper

Aion 2.5:Empyrean Calling (trial) (cry engine)

Final Fantasy XIV benchmark

Nimbus

Mercenaries 2:World in Flames

R.U.S.E.

 

Evochron Mercenary demo gives black screen and illegal instruction after selecting pilot profile.

Problem is eap155.dll.Full game might be patched?

 

Orcs Must Die! (Vision engine)

Airline Tycoon 2 (i dont get these,they could have some more players by leaving support for sse)

Wasteland Angel (Vision engine)

 

Fortix 2 (http://forums.steamp...d.php?t=2224459 using sse2 to fast math calculations)steam reqs 1.5Ghz)

(crash before game itself starts,instruction cvtps2dq)

Ignite (just opens couple of window frames and crash,Fortix 2 similar at startup, these moving window at screen like some size problems?)

(instruction also cvtps2dq)

 

Warhammer 40,000:Space Marine

 

Two Worlds 2:Castle Defence demo

It opens window with black background and illegal instruction error.

Official reqs are:Newest Adobe Flash Player drivers, newest directX drivers, graphics card with shader model 2.0.

Every other what i found says XP 2500+ and one single core Intel or AMD 2.0.(In steam also single core intel amd 2.0 for this and tw2)

Just thinking can here be some sse2 conflict between flash and ati drivers?(NET framework?)Most likely flash uses sse2.

 

Darkspore (PhysX 2.8.4.4 files changed to 2.8.4.6->hangs with background (or front) error usually after menu or after that start button. My link forum.)I

 

SkyDrift

The Adventures of Tintin - The Secret of the Unicorn (launcher works,exe crash->function: TINTIN!GetConfigFileLanguage) ???

 

Xotic demo crashing to desktop in loading screen.Theres http://forums.steamp...d.php?t=2123892 thread for it.

If this get fix,buy it. :)

 

Disney Universe (forget add it earlier.too bad that dont work,game isnt so bad)

Edited by kazoomsha
Link to post
Share on other sites

yeah! works like a charm

now i can run it at full speed in mi desktop pc =D

 

Yes!!! Just that .exe was compiled with sse2.I watched earlier videos of Braid gameplay with new hardware and it looks same aswell Dogfighter.

So next question is how many games .exe and/or other files is just compiled with sse2???(what optimizations compiler does)

Point of this is that theres games which could be patched without reprogramming too much.

So why they dont do it?

Looks like quite many sse2 games are more or less console ports and/or usingPhysX?

Seems that sse2 really is faster (depending on cpu?) so its easier to compile with it.Developerspublishers dont have to do optimizations for pc to game code.

They get performance with just couple of mouse clicks.(in fact even without few clicks)

And propably thats why nvtt.dll is compiled with sse2.

And yeah Eidos&Deus Ex:Human Revolution "the PC version of the game needed to be a game in itself and not just of port of the console version." My link .Game is working.

Why devs just give option to disable those things what are using sse2.

 

We still have something what Intel dont and thats 3DNow(AMD is going to cut it off,maybe NOT good idea)

Main question here;Is there any game what is fully optimized to use it and sse?My link "Serious Sam"

This was also mentioned somewhere else but if game doesnt use many sse2 instructions why not use 3DNow instead only sse2?(or map to 3DNow)

 

What PSU do you have?

Edited by kazoomsha
Link to post
Share on other sites

Crysis 2 mp demo crashes to desktop.Menu and everything works and it loads map but then crash.

 

Battlefield:Bad Company 2 does same.I downloaded somebodys savegames and it loads and crash.

Game didnt update (error:Your windows version is not supported by this application).

One and only solution what i found was updating windows.It was XP too.Didnt try that

but update worked in built-in administrator account.Could be OS problem. (still dont have all win updates)

I bought this used and if i remember right multiplayer asked key which wasnt valid or something like that.

If MoH 2010 multiplayer works(beta) then Bad Company 2(beta) should work too cause both use same engine(Frostbite 1.5).

 

Prototype same thing.

 

These are exactly same.Everything else works normally and loads mission but then always crash to desktop before game itself starts.

Didnt realize back then check or save logs,maybe crash sse2 instruction is cvtps2dq.

Edited by kazoomsha
Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Yes!!! Just that .exe was compiled with sse2.I watched earlier videos of Braid gameplay with new hardware and it looks same.

So next question is how many games .exe and/or other files is just compiled with sse2???

Point of this is that theres games which could be patched without reprogramming too much.

So why they dont do it?

Looks like quite many sse2 games are more or less console ports and/or usingPhysX?

 

What PSU do you have?

 

you mean, the power supply?

well, its a HEC 550 w winpower

Link to post
Share on other sites

Yep power supply.Should write power its maybe clearer.

I had fan problem.Sometimes when starting game and there was much hd reading fans speed went slower and gpu almost stopped.(played Crysis high with all these and with tx it feels smoother,dont remember what vx did but i didnt notice much difference between hipro and konig->OS maybe more stable.Should have done benchmarks.)

Tested all these powers:

HIPRO HP-D2537F3P (250W) comp is hp

Konig CMP-PSUP450w/s

Corsair 450 vx

Corsair TX 850 w (finally decided to buy it)

Less wattsamps more often it did it and still happened with that tx couple of times.(last time few days ago after i updated ati drivers,using sapphires 11.2)

And in some situations (atleast with 3850 12v30a) it isnt bad idea if you have some extra amps.Also propably gives more lifetime to components.

(Happened rarely and after bigger installations.Somebody used 1100 w with dual Palomino mobo and 5 harddrives.)

Corsair TX is broken and propably something else.It doesnt always even post and when boots power gives about 16v at 12v and 7v at 5v.Going to keep little break from that comp.

 

In case that power really really is causing problems looks like Corsair HX650 is working for sure

http://forums.anandt...2072689.html .

It gives 30A to 5v and 24A to3,3v shared max 170w

52A to 12v max 624w.

Edited by kazoomsha
Link to post
Share on other sites

I'll come home in 2 weeks and than I'll try and see. Not sure for now.

I shall also try to install new Windows 7 and give it a try with new drivers Ati 11.4 PREWIEW.

I get BSOD-s on Xp (not many). I just hope Win 7 wouldn't kill performance and that is

stable OS.

BTW, what OS are you using ?

Is it better to install Win 7 Home Premium or Proffesional?

I think our old Athlon XP really does depend on newest softver and drivers.

 

XP Pro sp3.

Dont know how much difference theres between 7 versions but propably professional.

Gpedit is good tool and it isnt in homes.Otherwise home is lighter.

Well,better coded and hardware optimizations but drivers are tricky part here.

Motherboard chipset drivers are old and then is also AMD cpu driver(K7).

Those need some imrovements.

 

Watched videos again.7 works with socket A cpu's very good.Would be intresting to know how it performs in gaming.

hopefully we get more new games with lower requirements.

Amazing it boot and works P3 450MHz ,192 Megs RAM, Leadtek WinFast AGP

.

 

Sometimes been thinking that it would be good idea to do game benchmarks in home and professional versions

with factory/default settings.Cause if you can get 1+ stable fps more its just good thing especially for us and others with old hardware.

Makes difference if you can get min or average fps to 20+.

Linux Geekbench gave with XP 2800+ better results than in Windows.Dont remember how much,propably 50-300.

 

For me 1C game demos caused BSOD's.

Edited by kazoomsha
Link to post
Share on other sites

Tried two versions of Homefront.

First one crashed at first door.

Second crashed when koreans throw player to stairs.

Have to check this more.

Black screen (theres still some sounds) and in background unknown exception error box.

No luck yet with this?

But most likely its bug or problem here.

And yes,multiplayer demo works.If somebody got single player working ,just post here.

Edited by kazoomsha
Link to post
Share on other sites

One reason for Cryostasis bsod propably was cpu overheating (cant get temps but it was quite hot,high settings but didnt try lower).

Others (with different hardware) got problems with these demos too and one solution was using lower resolution.

Also compatibility modes helped.

 

With this 11.2 Sapphire driver i got few bsod "The device driver got stuck in an infinite loop...".

Installed these in built-in administrator account and seems more stable.

It seems to be related catalyst settings and is happening only with browsers (ie8,ie6,firefox nightly),so maybe flash videos.

So far I have enabled VPU recover and disabled Atierecord in registry

.

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesAtierecord

eRecordEnable

eRecordEnablePopups

Change these values to 0.

 

After that happened only once after i changed some catalyst settings.

Also maybe it affects how long computer is been turned on.

Got several bsod's again.Hmn,after uninstalled Adobe Air,none.

Two again but its good enough.

Disabled that VPU recover,dont normally use it.

 

Usually freezed first and only mouse cursor was moving and then blue screen.

Also updated flash to 10.3.181.14.It freezed once and then plugin crash.

 

 

My link one thread about 11.x drivers problems.

There was suggested to try csa patch but i didnt use it.

Quote from there:

"The drivers shouldn't require SSE2 (I'm note sure about that), BUT the new CCC is build around .net 3.5 SP1 and VC++ 2010 (which requires SS2). If the drivers are build with VC++ 2010 too, yes they need a SSE2 capable processor."

Answer:

"They're using 2k8, not 2k10. The dependency is msvcr80.dll, not msvcr100.dll. And it's not about code optimization, where 2k10 tends to use SSE2. (And it can be turned off by the way.) It's a driver, it uses assembly code a lot."

 

Heh.One more when Trend Micro blocked web site.So i uninstalled it.

.....happening now mostly with youtube videos.Its common problem with ATI 11.x (no problems with 10.6)driversflash,but theres also been sse2 crashes with flash.

Funny thing is that everytime i did something it was better for a while.Last time i updated flash in built-in account and took Radeon off and cleaned everything.

No blue screens about in two weeks and bang,again.(this been happening with NVidia too)

Also noticed that windows search causing bsod.Fixed it by just disabling search assistant and same for ie My link .

 

Temporarily fix is disable hardware acceleration in flash settings.(didnt work here)

My link with 11.6 and 11.8 no bsod but his CCC dont work.

 

My link

Added this registry key

HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer

New DWORD "NoDetailsThumbnailOnNetwork" set it to 1.

Had one or two bsods right after this and its worked since hardware acceleration enabled.Flash version 10.3.183.7.Now using also Safari and no problemo.

Edited by kazoomsha
Link to post
Share on other sites

Tried Call of Pripyat benchmark to be sure and works. Good example how well game scales to different hardware and what system requirements should be.

I mean every pc gamer knows about those requirements is it gonna work. (if not theres allways google but its frustrating if you have to try game to know is it working)

I will post results later.Writing now what i remember.Max settings 1024x1280,average over 20,max about 50,min 0.It lags time after time so bad that it gives min fps 0 but overall works well...

 

Stalker: Call of Pripyat minimal system requirements • Operating system: Windows XP SP2 • Processor: Intel Pentium 4 2.2 GHz / AMD Athlon XP 2200+ • Memory: 768 MB RAM • HDD: 6 GB free space • Graphics card: Geforce 5900 128 MB / Radeon 9600 XT 128 MB • Sound: DirectX 9 compatible • Input: Keyboard and mouse Stalker: Call of Pripyat recommended system requirements • Operating system: Windows Vista SP1 or Windows 7 • Processor: Intel Core 2 Duo E8300 / AMD Phenom II X2 550 • Memory: 2 GB RAM • HDD: 6 GB free space • Graphics card: Geforce GTX 260 / Radeon HD 4870 512 MB • Sound: DirectX 9 compatible • Input: Keyboard and mouse

Edited by kazoomsha
Link to post
Share on other sites

So guys...any more info about Crysis 2? I just played through Crysis 1 & Warhead and had a blast.

I googled around a bit and according to various forums, Crysis 2 is more optimized than Crysis 1, and thus runs better & looks better.

I found posts about Crysis 2 running at TWICE as fast (FPS wise) than Crysis 1 on same computer, with same settings.

 

So currently the situation is: It runs, loads main menu, but when loading a map it crashes?

 

There is an update (1.2, I think) out, has anyone tried with that?

Link to post
Share on other sites

Nothing new about crysis 2.But cause it starts sounds logical

that it isnt (atleast .exe) compiled with sse2?Think it should crash immediately.

Hows trapped dead?

What settings did you use in warhead?

Been playing Crysis on high 1024x1280.Its playable but not so smooth.

It lags,just dont remember where and its not installed right now.

Going to reinstall it when i have time to finish it.

(Some youtube comment was medium 30 fps.no specs)

(Somewhere somebody wrote that played high with clocked Barton 2,4GHz ,dont remember maybe 2800+ and wasnt other specs)

Edited by kazoomsha
Link to post
Share on other sites

work:

Post Apocalyptic Mayhem

fallout new vegas (there was some problems but in 'higher priority' everything worked great)

Risen

 

not work:

Crysis 2 (first time i got error with suggestion that 'activationx86.dll' can help, but with this activationx86.dll work only menu and loading screen then i got "normal" error ://)

dead space

dead space 2

trapped dead

 

tested on -> athlon xp +3000 (~ 2,1ghz), ati radeon x1650 pro 512mb, 2 gb ram

 

/sorry for my english ;)

Link to post
Share on other sites

Trapped Dead is a lost cause...didn't work even with the patch.

I'm sorry to hear about Crysis 2 :mrsgreen: i was really hoping to play it, oh well.

 

I ran Crysis 1 & Warhead with Objects Detail on Low/Medium (tweaked the config file a little, because this is the biggest performance hit among the options), Textures & Physics Medium, and the rest of the stuff Medium/High with Motion Blur OFF. 1024x768 @ 75Hz

Specs: Athlon XP 3200+, 2Gb RAM, GeForce 7900

 

edit: oh, and Warhead ran better with the same settings, it is more optimized i guess.

 

edit2: i'm really hoping that Portal 2 would run, since it's Source engine ...we'll see :)

Edited by dseries
Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...