Jump to content

Change Mode

Athlon Xp Compatible Games


Recommended Posts

I have an old system that's been maxed out, but unfortunately it sports the 7 years obsolete "socket A", and there are no socket A processors which support the SSE2 instruction set. My goal with this thread is to compose a list of modern games that don't require the SSE2 instruction set to run. This is to say, even if a game requires 2GB RAM, an HD Radeon/8000 series GeForce card, or a 3GHz processor; and even if the game initially requires SSE2 but has a known fix which allows it to work on non-SSE2 systems, I'm looking for modern games that simply don't (necessarily) require the SSE2 instruction set to run.


I will start out the list with the following...


Crysis (Plays well on medium settings)

Spore (Plays Perfect)

The Sims 3 (Plays like garbage even with SSE2. Horribly unoptimized.)

Unreal Tournament 3 (Plays great!)

Mirror's Edge (Plays decent, but drops to about 10fps under stress. Processor is an apparent bottleneck.)

Zeno Clash (Plays and looks great, even on my 7 year old Radeon 9600 XT)

Borderlands (Initially requires SSE2, but plays fine without it using a patched DLL)

Arkham Asylum (Awesome game, and worth every penny)


(The descriptions in parentheses are based on a system with an Athlon XP 2600+, a Radeon HD 2600 Pro video card and 2GB system RAM)

Link to comment
Share on other sites

  • 1 month later...
  • Replies 581
  • Created
  • Last Reply

Top Posters In This Topic

1) Call of Duty 4 Modern Warfare (runs if patched)

2) World in Conflict

3) Fallout 3

4) Starcraft 2 (Runs great )


Mafia 2 , Metro 2033, Lost Planet, Assasins Creed, Colin McRae: Dirt Doesn't run.


I think its easier to make a list of games that does not run :).

Link to comment
Share on other sites

1) Risen

2) League of Legends

3) Worms Reloaded

4) Anno 1404:Dawn of Discovery

5) Bioshock

6) Left 4 Dead

7) Left 4 Dead 2

8) King's Bounty: The Legend

9) The Settlers VI: Rise of an Empire


Burnout Paradise, Street Fighter IV doesn't run.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
  • 4 weeks later...
  • 1 month later...

I have tried all games (couple full games found in net) on high or almost high settings,some with anti-aliasing ,1280x1024 some 1600x1200.
Few games were too slow/laggy to really play with those settings but not extremely slow.
All are playable on some settings and if dont need always smooth fps high settings can be used. (SPECS PAGE 2)
Bunch of games checked only steam requirements and added some for sure.
Aaand later in this thread is some more tips,tricks,links...

These all are demo versions and working:
The Maw
Alien Breed 3:Descent

Dogfighter (it was updated "legacy PhysX support (2.8.3) for non-SSE2,
maybe worked before that update cause i downloaded it twice and worked at second time much better)its very good with joystick

Hegemony:Philip of Macedon
Kane&Lynch 2:Dog Days
King Arthur-The Role-playing Wargame

Nation Redhttp://forums.steamp...ad.php?t=976591
Didnt earlier check that link there but full game 1.76 and down works and demo used Bullet physics.Have read something that Bullet is maybe easier to use than PhysX.

The UnderGarden
Wings of Pray
Overlord II
FUEL (If graphics problems try Windows 2000 compatibility)
Darkest of Days
Fantasy Wars
Amnesia:The dark descent
Sniper:Ghost warrior
ARMA II:Operation arrowhead
King's Bounty:Armored Princess (If you get BSOD try Windows 98/Windows ME Compatibility mode.Worked in XP SP3.)
The Last Remnant
Sacred 2:Fallen Angel
Mass Effect 2
Divinity II:The Dragon Knight Saga
NFS:Pro Street
NFS:Shift-Falken tire
Call of Juarez:Bound in Blood
Crash Time 3 (It got .exe for sse2 and sse)
Pro Evolution Soccer 2011
Anno 1404
Warhammer Online:Age of Reckoning (Endless trial) DEAD GAME.
Emergency 2012
Magic :The Gathering - Duels of the Planeswalkers 2012
Ancients of Ooga
Space Siege (not bad game)
Duke Nukem Forever
Homefront multiplayer
Spider-Man:Friend or Foe (not much Athlon XP reqs,in readme only "Athlon" and also for Xbox 360)
Greed:Black Border
Defence Grid:The Awakening
Secret of the Magic Crystal
Football Manager 2011
GTR Evolution (race 07 expansion)
Tropico 3
Battlefield 2:Gulf of Oman (OLD but useful demo,single/multiplayer)

Edited by kazoomsha
Link to comment
Share on other sites

WORKING full games
Blade Kitten
Fallout New Vegas ( found this video My link ) http://www.gamespot....-sse2-48240352/ clocked Sempron 2600+ Fallout 3->runs well.
Crysis Warhead ( found this video

Call of Duty:Modern Warfare 2 (found this video
) (rename mssmp3.asi to mssmp3.bak)
Splinter Cell:Conviction
Alpha Protocol
FlatOut:Ultimate Carnage
Medal of Honor 2010 ( Dont know about multiplayer?)
Neverwinter nights 2. Hows expansions?
DriftCity ( My link for EU version.)
Medieval II:Total War
Eragon (most min reqs "1.4 GHz Intel Pentium 4 or AMD Athlon" without XP)

Bioshock 2 (dont know was single core problem with .bik files patched but one solution besides waiting is delete them)

Global Agenda Free (Needs fixed nvtt.dll.Crashed first in character creation but worked later.)
Moonbase Alpha (Needs fixed nvtt.dll.)
Terminator Salvation
Lead and Gold:Gangs of the Wild West
Shadow Harvest:Phantom Ops
Medal of Honor:Airborne
Battlefield Play4Free
Test Drive Unlimited
Silverfall:Earth Awakening
Harry Potter and the Deathly Hallows Part 1
Tunnel Rats (not bad game,more like "old school")
theHunter (free online hunting game,using same Avalanche 2.0 engine as Just Cause 2<-not work,and playable max 1024x1280)
Team Fortress 2 (Free to Play)
Dino D-Day Half-Life 2 mod (NOT that new game)
ArmA 2 Free (AMD Athlon 3200+ in requirements)

Need for Speed:Shift 2 Unleashed
Its using PhysX (but no files in game folder) and includes installer.I got again after menu "Instruction at..." error or sometimes black screen.
Google found for black screen some fixes.(one was using alternative .exe).
First i deleted HKLMSoftwareElectronic ArtsSHIFT 2 UNLEASHED key.No help.
Then uninstalled PhysX using Revo unistaller,reboot and CCleaner found missing shared PhysXLoader.dll.
Tried without PhysX (gave that error) and noticed that game was loading old 2.7.x PhysX files from system32.So i deleted those.Reboot.
Now missing PhysXLoader.dll error.So i installed reboot and worked.

Section 8 (needs fixed nvtt.dll+libpng12.dll+zlib1.dll.Usually copied all,so dont know does other games requiring )

Section 8:Prejudice (Unreal 3.Athlon XP 3200+ in official,wiki,steam requirements?Still needs fixed nvtt.dll+libpng12.dll+zlib1.dll)Reminds cod4 but is good one.

CrimeCraft:Bleedout (free)

Vindictus (free,modified Source engine)(game is good but little different,better to try,personally i think that similar singleplayer could be very good)

StealthBastar*d (free,official reqs 2.0 dual core gfx dx 8.0,not bad game and only 19.5MB download)
Clive Barker's Jericho (not bad,try it)
Braid (if it doesnt work look page 2)
All Telltale Games games.
Thrill Kill (post this cause its cancelled PS1 game but google finds it and emulator too aand it was ahead of its time)
The Elder Scrolls IV:Oblivion
Wolfenstein:Enemy Territory (good,old,free)
Take On Helicopters (propably works,using same Real Virtuality 3 engine as Arma 2)
Blood Bowl:Legendary Edition (reqs 2400+,nice graphics.)

Ys:The Oath in Felghana (doesnt look bad game,min reqs: Pentium 3 800MHz,32 MB VRAM 3D accelerator compatible.)

Real Warfare 2:Northern Crusades official minimum (havent tried,If it blue screens try lowest settings and resolution.Propably its anti-aliasing/resolution/shadows?CPU: Intel Pentium ® IV 2.0 GHz or AMD ® 2000+RAM: 512 MBGraphics: GeForce MX400 or Radeon 8500 or higherFree space: 3 GB)
All DLCs,expansions working,atleast no one posted anything opposite?
(Anybody knows is there games what demo works but full game not or update added sse2 and crash?)

Edited by kazoomsha
Link to comment
Share on other sites

Sorry for my English but I'm Italian and I'm very interested on these topic. This is what I know, by triyng or searching on line


NBA 2k9

MLB 2k10

Splinter Cell Double Agent


Arma II

Kane & Linch

King's bounty

Armored princess

Gears of war

Saints Row 2 (on my Athlon xp 2800 very very slow)

rainbow six vegas 1 e 2

brother in arms 2

Link to comment
Share on other sites

NOT working full games:

Fable 3

Dungeon Siege 3

Dark Sector,

Chronicles of Riddick: Assault on Dark Athena,

G4 Arcania,

Quantum of Solace

Force Unleashed 2.

Witcher 2 (version 1.0)



Games that runs:

Bionic commando

Hunted; Demon's Forge (nvtt.dll no sse2)

Deus ex: Human Revolution

Haunted Hells Reach (nvtt.dll no sse2)

Dungeon defenders (nvtt.dll no sse2)

Tron Evolution (nvtt.dll)

War of Cybertron (nvtt.dll + 2 gb ram minimum)


Is it possible to open game engine.dll in Visual studio and remove it SSE 2 protocol run just like

fix for Borderlands was done (http://gbxforums.gea...ead.php?t=85817).

He opened nvtt.dll in Visual studio and removed SSE 2.I don't have Visual studio but maybe someone can try.


I have found that Star Wars Ultimate Edition probably would run


Originally Posted by ivan rutar

"Tnx Mahaj , the game works perfect, saves just fine , no lag at all even on my system which is waaaay below specs (athlon xp 3000+ @2,01 GHz ,geforce 8600gt,2gb ram)."


But, I didn't try it myself for now.


Look at this, new Oblivion mod


Edited by Starsylph
Link to comment
Share on other sites

NOT working full games.

Assassins Creed 2
grand theft auto:Episodes From Liberty City (might be fix for GTA IV,google for GTA IV Athlon XP and GTA IV Pentium 3)

Launcher worked then crash and if i remember right no error,I DINT TRY ANY POSSIBLE FIX.


Call of Duty:Black Ops
Operation Flashpoint:Dragon Rising. Mission editor works but in testing it tries to use game exe and crashes.
Far Cry 2
Red Faction:Guerrilla

EVE Online . Requires sse2 after Incursion 1.1.0
My link Its third party binary what is using sse2 to some feature.

Call of Duty:Black Ops-Multiplayer (Steam free weekend)
War Inc. Battlezone
Dino D-Day (steam free weekend,old HL2 mod works)
Brink (steam free weekend) error "CPU does not support the Intel Streaming SIMD Extensions 2 (SSE2)"

Drakensang Online (error My link " no SSE/SSE2 support on this CPU. XNA-Math was compiled with SSE/SSE2 support")
Theres XNA gaming studio for download if its possible fix with it.

Alien vs. Predator (2010)
Ferrari Virtual Race (different exe for hi and low)

Alien Swarm (My link 42 pages behind that link and 88330 views)
"I tried to compile nonSSE2 version of Alien Swarm, after changingSSE2>SSE inside VS2008, but no luck. Looks like tier0.dll is usingSSE2, and I don't know how to get it."
"Same (NULL) Error here. mines an athlon XP 2800+ but has enoughupgrades to be able to play l4d2 at 1920x1080 (native) resolution onfull graphics settings.
Athlon XP 2800+
3Gb DDR 400
ATI 4670 1Gb.
X-Fi Elite Pro
1T SATA Raid (2x500 Gb. set as striped raid)
Windows XP SP3
Viewsonic VX2260WM (via HDMI)"

Guitar Hero III (found one post wheres only said that its not working)

Battle Dawn is a strategy MMO browser based game featuring three types of worlds with thousands of other real players. The game is built entirely in Flash. It's free to play and requires no downloads.SSE2 requirement.(but havent tried)

Edited by kazoomsha
Link to comment
Share on other sites

Threads about sse2 and Athlon XP cpu:s http://win2kgaming.prophpbb.com/topic154.html , Side-Project:SSE2 Exception Handler http://win2kgaming.prophpbb.com/post826.html#p826 and thread about this thread http://win2kgaming.prophpbb.com/topic865.html, My link
Athlon XP technical info My link Model 10 data sheet, My link Model 8 data sheet.
http://groups.google...da2d940c5b69745 theres talked about 3DNow and SSE.

Fast image processing with sse2 http://www.google.fi/url?sa=t&rct=j&q=&esrc=s&source=web&cd=147&cad=rja&ved=0CHEQFjAGOIwB&url=http%3A%2F%2Fwww2.cvl.isy.liu.se%2FScOut%2FPublications%2FPapers%2Fssba05_sf.pdf&ei=7lMLUuPcKsKC4gTfsoHYDg&usg=AFQjCNFmGWm2VUWoPjeGF6qrHkSXC2Cefg&sig2=2hg3bpfyJxW3c9mjQIGf-w

Benchmarks with XP 3200+ and several older AMD's.
No big differences to those AMD64's so its really just sse2.
Battlefield Bad Company 2 beta on K8(not socket A) Sempron 2800+My link

Didnt know http://www.techpower...DMI-Output.html Radeon 5450 DX11 PCI.
Something like 5770 or 5850 for agp would be nice.Anyway some games would take benefit about more powerful card.(thinking UE3 games)
http://www.newegg.co...dbc3a2a406144b4 GeForce 9500 GT 1GB PCI
PCI->PCIE adapter http://www.virtuavia...s-adapter-.html
Atleast these CPUs are NOT supporting SSE2:
AMD Athlon XPSempron (socketA) and downwards
Intel Pentium 3 and downwards
Transmeta Crusoe

Files are there http://www.mediafire...7w1y1lbto7ri7av if somebody wants try,also no-cuda.(added libpng12.dll,zlib1.dll.Also jpeg62.dll,libtiff3.dll but none of games didnt ask these)(files already and originally were in gnuwin32bin folder)
Original fix didnt include jpeg62.dll and libtiff3.dll.I made this with Visual Studio 2008 Professional trial and SSE2 Sempron laptop and XP Pro.(dont know is it possible without sse2cpu)"Enable Enhanced Instruction Set" was not set by default so i removed only sse2.
Thanks goes http://gbxforums.gea...ead.php?t=85817



csapatch=catalyst socket a patch( My link dead) 40,108 times.

My link"According to the XAUDIO2 team, it only requires SSE and optionally uses SSE2."
In Team Fortress 2 config file is options to disable/enable 3DNow and sse2 codes.TF2 Cvarlist http://www.ugcleague...varlist_tf2.cfm
And L4D so is it common option in Source games? (anybody tried add disable sse2 to new engine config?)
Also with ATI Tray Tools is possible to disable SSE2 in driver level.Most ATT tweaks are registry keys.

AMD made new CPUs,Geode series, for socket 7 and A http://en.wikipedia....ode_(processor)
but "In 2009, comments by AMD indicated that there are no plans for any future micro architecture upgrades to the processor and that there will be no successor; however, the processors will still be available with the planned availability of the Geode LX extending through 2015."
Wouldnt hurt us if AMD could make new plans for this.
Athlon XPs have very good FPU.NVidia (like Ageia) used old x87 instructions (its done in FPU) for CPU PhysX and then changed to SSESSE2.It just sounds logical that cause others things are using SSE anyway,CPU PhysX would need more clocks,cores.Anyway,2.8.3 files worked well for us.
AMD should have continue with socket A (dont know was there some technical impossibilities) and make SSE2 K7 CPU like 3GHz-3.6GHz.
It could beat quite many processors.

Bioshock on PS2 My link


.http://www.xtremesys...hp/t-17709.html CBId (Central Brain Identifyer)
"A classic version of CBId can do another trick as to enabling and disabling features bits, such as MMX, SSE, SSE2, 3DNow!, etc. There was a time, when I liked to play with those bits. For example, I enabled SSE2 support for my funky Thoroughbred B0 1700+@2200MHz processor and ran Sandra benchmark. I don’t remember exactly what happened to it, but Sandra attempted to perform SSE2 CPU/Memory bench :)"
Does it allow any game to start?Might just edit this registry key?:
HKLMHARDWAREDESCRIPTIONSystemCentralProcessor0 FeatureSet


Interesting benchmark http://etutorials.org/Misc/pc+hardware+tuning+acceleration/Chapter+3+Moderate+and+Extreme+Overclocking+Modes/Extreme+Overclocking+of+Processors/
Results for Athlon XP 1700+ (3,107.05 MHz)
Results for Pentium 4 2.8 GHz
Dhrystone ALU (MIPS)
Whetstone FPU (MFLOPS)
2,408 5,250 (SSE2)
Integer aEMMX/aSSE (it/sec)
1,3090 (SSE2)
Floating-point (it/sec)
1,9600 (SSE2)
RAM integer buffered aEMMX/ aSSE bandwidth (MB/sec)
2,937 (SSE2)
RAM floating-point buffered aEMMX/aSSE bandwidth (MB/sec)
2,940 (SSE2)

Edited by kazoomsha
Link to comment
Share on other sites

Working demos continue.





Tales of Monkey Island


Disney - Pixar Up (if blue screen try lowerdisable antialiasing)


Supreme Commander

Victoria 2



All Aspects of Warfare

Watchmen:The End is Nigh


Dungeon Defence UDK Demo. needs fixed nvtt.dll.There was same Bordelands.Tried first that ,worked.Then i tried,worked and seemed little smoother or actually stable.


Sanctum UDK Demo http://www.udk.com/showcase-sanctum (same thing but original was and works with

Kung Fu Panda. nice graphics

Gray Matter. It got xaudio error but theres My link thread for it.


Wanted:Weapons of Fate

Ghostbusters:Sanctum of Slime

The Witcher (works well on high)

Disciples 3:Renaissance

Black Sails:Das Geisterschiff

Two Worlds

Angle of Attack

Risk Factions

Winter Voices


Command & Conquer:Red Alert 3. Almost every min.reqs says: "XP: Intel Pentium 4 2.2 GHz or better, AMD Athlon XP 2100+ or better" but i found this My link .

There "after the RA3 beta patch 1.03 it was impossible to start the game with an AMD Athlon XP processor" and "in the RA3 beta it was possible to solve this problem with a patch".

EA fixed this one.


Project Aftermath 1.05

Darkstar One

Sega Rally,Revo . (also sse1.exe,had performance problems with demo but was common problem)



Men of War

Men of War:Assault Squad

Anomaly Warzone Earth

Theatre of War 3:Korea (trial) if it gives error try again


Empire:Total War (also rename mssmp3.asi)

Freeze with blinking white lines My link .No error??

But in last post there "Now, I got the demo started with my ancient Athlon XP 2800, got the same screen as you did, but i bypassed it by pushing escape and thus going to the menu screen."

Propably this isnt only game what would work somehow or atleast start if it just wouldnt stop to error.


Pound of Ground

Your Doodles Are Bugged! Funny Lemmings like game.

Trapped Dead demo link http://www.trappeddead.com/demo/

Tom Clancy's Ghost Recon Advanced Warfighter 2 SP

The Ball . Needs fixed nvtt.dll

Sam&Max:The Devil's Playhouse. Episode1:The Penal Zone

Wildlife Park 2


Faery:Legends of Avalon


RIFT. Free trial.

MotoGP 08

Dark Void

Shattered Origins:Guardians of Unity

Edited by kazoomsha
Link to comment
Share on other sites

  • 3 weeks later...

video again.Somebody playing crysis on dual pentium 3+x1600 pro 512MB.(two cpu's)

Minecraft xp 3000+ & VIA Unichrome.



Crysis Warhead P3 733MHz 3850 AGP.Its like optimized game.


Skyrim 3200+ 3850 but crash after intro with those settings?

youtube.com/watch?v=Vq61TgJPzQo (cant add more media files,if somebody wants post this,just post)

Edited by kazoomsha
Link to comment
Share on other sites

  • 2 weeks later...

No, it is the same after 1.04.

Probably due lack of memory. I'll try to low AGP aperture size to 128 mb in bios.

Some people say it's better than.

Dragon age 2 will have better optimized engine like Mass effect 2 so I'll wait for that.


DA:O works quite good on high with Pentium4 and 3850 agp and 2,2gigs ram(youtube video).

Just thinking that it should work better on low????

Edited by kazoomsha
Link to comment
Share on other sites

Wait. isn't your P4 SSE2 processor?


No,that Dragon Age P4 was another youtube video what i found.

My specs Athlon XP 3200+,Sapphire Radeon HD 3850 AGP,2 gigs ram,xp pro sp3,

Seagate Barracuda ST3200021A 200gigs.

Motherboard ASUS A7N8X-LA chipset nforce 2,socket A (462)

Corsair TX850W

Just got interested it cause RodrigoJurado said its working fine.


Forgot gpu is clocked 669/829 to 720/950.Using ati overdrive.

Edited by kazoomsha
Link to comment
Share on other sites

Trapped Dead won't run for me, instantly crashes, i think it's SSE2 related, although System Requirements says otherwise:


Minimum System requirements

OS: Windows XP, Vista, Windows 7

CPU: Intel Pentium 4 @ 1.5 GHz processor / AMD Athlon XP 1500+

RAM: 1 Gb

Video Card: nVidia GeForce 6600 / ATI Radeon X1300 128 Mb

Sound: DirectX Compatible Soundcard

Hard disk: 2 Gb


Tried with the patch, same crash...

Link to comment
Share on other sites

Hey, I played DA:O introduction and fIrst quest in cave as a mage on low settings, but

when I got to first big city I noticed huge FPS drop.

Is this fixed with 1.04 patch?


Athlon xp 2800


HD 3650


i didnt experience many fps drops tru the game

with two eceptions, denerim market square ( noticiable fps drop but still very playable)

and the ice mointains stage, in wich i had some serious fps drops

in large, frozen areas ,to the point that it was barely playable


with the rest of the game i had no problems, all good and smooth


i ran the game in high quality settings, but without antialiasing

at a resolution of 1024x768


my specs are a little higher than yours trought

xp 3200+

2gb ram in dual channel mode

Radeon HD 4650

Overclocked to 700/530 (CORE/MEMO)

Link to comment
Share on other sites

No,that Dragon Age P4 was another youtube video what i found.

My specs Athlon XP 3200+,Sapphire 3850 agp,2 gigs ram,xp sp3.

Just got interested it cause RodrigoJurado said its working fine.


i assure you, it works great, fantastic

denemim maket its just a detail

the ice stage is the one and only annoying area

but its only in some areas of the stage, and while slow

its still decently playable


i played all the game, with the expansions and dlcs

and safe for those 2 areas, all fast smooth and beauty


plus, your spects are a little higher than mine


my specs

xp 3200+

2gb ram in dual channel mode

Radeon HD 4650

Overclocked to 700/530 (CORE/MEMO)


be sure to have dual channel activated for the memories

it helps a lot in games

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...