Jump to content

Pcmatic - How To Not Apply Some Changes


exn01

Recommended Posts

The latest run of PCMatic selected a service to change to manual. By doing this, it would have an impact on my laptop and I need the service to stay automatic startup. Is there a way that I can set this before running the 'Fix All'? The only way I can get around this now is to go back to services.msc and change the startup of this service back to 'Automatic' before the reboot - a major hassle :(

 

Any advice would be appreciated.

Link to post
Share on other sites

There is currently no way to skip the services optimization.

 

Extensive research was done on the services before this feature was implemented. Any service set to manual will start as soon as it is called upon to do so. What service is it that you need to have set to automatic?

 

Please open a ticket at our help desk so that we can get some more information.

 

You can open a ticket from here:

 

http://www.pcpitstop.com/store/service.asp

Link to post
Share on other sites

The service that got changed to 'Manual' was 'Smart Card' (C:\Windows\System32\SCardSvr.exe) which is my Activecard reader. I need this to access my work network (VPN), and when connected I need it to access our secure objects that need my certificate which is on the card. The service does not start automatically when I put the card in, and I get an error from the application that there is no card reader....so I have to leave it as 'Automatic', unless I manually start the service when I need it (which is always).

 

Should I log a helpdesk ticket for this, or are the details above sufficient?

 

Thanks.

Link to post
Share on other sites

Thank you for the additional information.

 

Yes, please open a help desk ticket so that we can get the information to the developer.

 

Thank you for your assistance.

Link to post
Share on other sites

I have the same problem. After I run PCMatic, my Smart Card is broken. This is pretty crappy that you can't turn off one "fix".

 

And to say that “Extensive research was done on the services before this feature was implemented” strikes me as questionable since clearly the “feature” breaks some systems.

Link to post
Share on other sites

We use a VPN at PC Pitstop with SmartCard set to manual and have had no problems at all. It just works. These are the first two reports of any issue with the SmartCard service. Thank you for taking your time to let us know there is a problem.

 

That said, we are now working on a service whitelist that will allow individual services to be excluded. Until the implementation is complete the workaround is to manually reset the service to automatic.

Link to post
Share on other sites
  • 1 month later...

This change was made without alerting users. I am finding several services switched to manual and preventing things happening that I normally took for granted. A services whitelist is an urgent requirement.

Annoyed user!!

Alan

Link to post
Share on other sites

:wp:

 

This topic is over a month old. The services white list was implemented several weeks ago.

 

At the end of the scan, from the scan results page before the clean-up, click on the red rectangle for 'Services' under the Other category, find the name of the service and add a check mark in the box to the right of that service to exclude it from being changed.

 

If PC Matic has been set to Auto Fix, that will first need to be changed to access the dashboard where the services can be added to the whitelist.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...