Jump to content
Sign in to follow this  
Bruce

National Geographic Wallpapers

Recommended Posts

Download all the National Geographic wallpapers from 2008 and 2009 at once with two simple scripts.

 

http://dl.dropbox.com/u/2886083/w8/natgeo2008.sh

 

http://dl.dropbox.com/u/2886083/w8/natgeo2009.sh

 

Change into the directory where the scripts are then run the commands

 

sh natgeo2008.sh

 

sh natgeo2009.sh

 

The scripts will download the wallpapers to the directory where the script is sitting, so you may want to create a directory, place the script in it, then run from the new directory.

Edited by Bruce

Share this post


Link to post
Share on other sites

thanks bruce for sharing they are coming now :)

 

for the folks that are having trouble getting the command to run this worked

 

sudo chmod +x ./natgeo2008.sh

then finally

 

./natgeo2008.sh

you should see your wallpapers piling up and download activity in terminal.

 

bruce didn't mention it' but the wallpapers will download to the directory where the scripts are, i have my scripts in pictures folder.

 

also if you don't know how to cd to that directory in terminal to even begin the process it would be easier for you to install nautilus-open-terminal first ;)

 

after nautilus-open-terminal is installed you can right click in the directory where the scripts are and hit open in terminal then run the commands above :tup:

Share this post


Link to post
Share on other sites

thanks bruce for sharing they are coming now :)

 

for the folks that are having trouble getting the command to run this worked

 

sudo chmod +x ./natgeo2008.sh

then finally

 

./natgeo2008.sh

i only needed to add an "sh" in front of the commands... like this:

 

sh ./natgeo2008.sh
sh ./natgeo2009.sh

:b33r:

Share this post


Link to post
Share on other sites

did you get a 404 error at the end of 09" script ?

 

 

--2009-12-21 17:29:02--  http://error.nationalgeographic.com/404error.html
Resolving error.nationalgeographic.com... 74.217.81.133
Connecting to error.nationalgeographic.com|74.217.81.133|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-12-21 17:29:07 ERROR 404: Not Found.

i don't know how many made it, maybe half... it definitely happened towards the end.

Share this post


Link to post
Share on other sites

did you get a 404 error at the end of 09" script ?

 

yup.... got a bunch of those and 169 wallpapers out of '09

 

saw a bunch with the '08 as well...along with 226 wallpapers.

 

just shy of 400 for me. :)

Share this post


Link to post
Share on other sites

Got 395 .jpg files: :tup:

 

[email protected]:~> cd /home/mythtv/Download
[email protected]:~/Download> cd /home/mythtv/Download/national-geographic-wallpapers
[email protected]:~/Download/national-geographic-wallpapers> ./natgeo2008.sh
[email protected]:~/Download/national-geographic-wallpapers> ./natgeo2009.sh
[email protected]:~/Download/national-geographic-wallpapers> ls -1R | grep .*.jpg | wc -l
395
[email protected]:~/Download/national-geographic-wallpapers>

edit: Tried this one. It's purrrdy. :lol:

Posted Image

Edited by John 44

Share this post


Link to post
Share on other sites

Thanks. Didn't work at first, couldn't connect to server for some reason. However, it is now working like a charm. Looks like there's some great stuff. :cheers:

 

Edit: Looks like 396 jpgs were downloaded.

Edited by adam22

Share this post


Link to post
Share on other sites

thanks bruce for sharing they are coming now :)

 

 

 

bruce didn't mention it' but the wallpapers will download to the directory where the scripts are, i have my scripts in pictures folder.

 

also if you don't know how to cd to that directory in terminal to even begin the process it would be easier for you to install nautilus-open-terminal first ;)

 

 

 

Yes I did mention it, I said you should put the script in a directory whereyou want the wallpapers to go.

Share this post


Link to post
Share on other sites

i stand corrected bruce, my bad.

 

 

The scripts will download the wallpapers to the directory where the script is sitting, so you may want to create a directory, place the script in it, then run from the new directory.

 

enough of that now' we need more scripts :geezer:

 

 

:rofl2:

Share this post


Link to post
Share on other sites

WOW!

 

 

Very nice Bruce.

 

 

Thank you.

 

 

Just finished downloading 2008, now to work on 2009.

 

D.

Share this post


Link to post
Share on other sites

Question?

 

I have SuSe 11.2 32 bit and Ubuntu 9.1 32 bit in a daul boot now. In SuSe I was able to use nautilus super-user to move the files around, how do I move a locked file in Ubuntu?

 

The files are in my "Downloads" folder with locks on them.

 

D.

Share this post


Link to post
Share on other sites

I don't have this problem at all. I placed them in a folder named National Geographic in the Pictures directory and I can drag and drop them where ever I like. It's a permission issue, I assume, I just don't know why you're having it...?

Share this post


Link to post
Share on other sites

I don't have this problem at all. I placed them in a folder named National Geographic in the Pictures directory and I can drag and drop them where ever I like. It's a permission issue, I assume, I just don't know why you're having it...?

 

 

Thanks. I think I'll retry like you have.

 

D.

Share this post


Link to post
Share on other sites

Well, leave it to me.....a Windows man trying to get the hang of Suse all over again....but I'm having trouble getting this to work. I have a folder titled National Geographic Wallpapers and I've saved the two links to that folder, but when I try to cd to that folder I can't. Getting the message "no such.....". What am I doing wrong folks??

 

:geezer:

Share this post


Link to post
Share on other sites

You have spaces in the names of the directories you created ;)

 

Put dashes or under scores in the names otherwise you will just make it difficult and a lot of typing in the terminal to cd into a directory.

 

For example

National-Geographic-Wallpapers

or

National_Geographic_Wallpapers

 

The other option is to use your file manager, go to the directory, and once inside, click tools, open terminal then run the command.

Share this post


Link to post
Share on other sites

Right click the directory with the images and hit permissions. Tell us what it says.

 

 

I figured it out.

 

Thanks.

 

D.

Share this post


Link to post
Share on other sites

You have spaces in the names of the directories you created ;)

 

Put dashes or under scores in the names otherwise you will just make it difficult and a lot of typing in the terminal to cd into a directory.

 

For example

National-Geographic-Wallpapers

or

National_Geographic_Wallpapers

 

The other option is to use your file manager, go to the directory, and once inside, click tools, open terminal then run the command.

 

Did that and tried that, but when I run the command everything sort of freezes...... :surrender:

 

:geezer:

Share this post


Link to post
Share on other sites

You should try using sh before natgeo2008.sh and natgeo2009.sh like this:

 

sh natgeo2008.sh
sh natgeo2009.sh

Note the space between sh and natgeo2008.sh,natgeo2009.sh and elimination of ./

Edited by markcynt

Share this post


Link to post
Share on other sites

You should try using sh before natgeo2008.sh and natgeo2009.sh like this:

 

sh natgeo2008.sh
sh natgeo2009.sh

Note the space between sh and natgeo2008.sh,natgeo2009.sh and elimination of ./

 

Thanks Mark, when I run the command it throws me into a reboot to a login screen asking for my user name and password. Not sure what's going on there......machine runs [email protected] alright..

 

Should prolly say that what I've done is created a National-Geographics-Wallpapers folder in my /home/Downloads. Clicked on Bruce's 2 links and saved to that folder and when I run the command even like you suggested it does this reboot thing.

 

 

:geezer:

Edited by caintry_boy

Share this post


Link to post
Share on other sites

There is nothing in the scripts that could cause such a thing, it only uses wget to grab a list of files.

Share this post


Link to post
Share on other sites

 

Thanks Mark, when I run the command it throws me into a reboot to a login screen asking for my user name and password. Not sure what's going on there......machine runs [email protected] alright..

 

Should prolly say that what I've done is created a National-Geographics-Wallpapers folder in my /home/Downloads. Clicked on Bruce's 2 links and saved to that folder and when I run the command even like you suggested it does this reboot thing.

 

 

:geezer:

Can you try it again and show us the whole output of the terminal?

 

Also open Dolphin, click view, Navigation Bar, then select Editable Location, then open the folder where the files are and then show us a screenshot of that.(Or you could just copy what's in the location bar and include that in your reply.)

 

What's happening to you is indeed strange. :blink:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...