Jump to content

Change Mode

How to correctly start/stop the x server in CentOS


Recommended Posts

Hello all,

 

I'm losing my mind here over something really simple

 

Say I'm running a GNOME session in CentOS 5.2, and want to kill the x server. So I do ctrl-alt-backspace and log into the command line. If I want to start it back up again I type in 'startx' and get:

 

[[email protected] ~]$ startx

xauth: creating new authority file /home/Administrator/.serverauth.5324

 

 

Fatal server error:

Server is already active for display 0

If this server is no longer running, remove /tmp/.X0-lock

and start again.

 

Basically, I'm trying to forward the X server to my Windows box using Xming over ssh, but I can't seem to start the x server to try it.

 

What am I doing wrong?

 

Thanks,

Adam

 

Ok, edit time. If I delete the .X0-lock file and then run startx from Putty I get this:

 

xauth: creating new authority file /home/Administrator/.serverauth.5411

 

X Window System Version 7.1.1

Release Date: 12 May 2006

X Protocol Version 11, Revision 0, Release 7.1.1

Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.

Current Operating System: Linux bosko.isilm.com 2.6.18-92.1.22.el5 #1 SMP Tue Dec 16 12:03:43 EST 2008 i686

Build Date: 21 June 2008

Build ID: xorg-x11-server 1.1.1-48.41.el5_2.1

Before reporting problems, check http://wiki.x.org

to make sure that you have the latest version.

Module Loader present

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (II) informational,

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 6 12:39:12 2009

(==) Using config file: "/etc/X11/xorg.conf"

 

localuser:Administrator being added to access control list

No profile for user 'Administrator' found

SESSION_MANAGER=local/bosko.isilm.com:/tmp/.ICE-unix/5432

 

Then it just sits there, I look over at the monitor connected to the box and see the screen is black with the black 'x' mouse cursor

 

If I then do ctrl-c in Putty the monitor connected to the server goes to the GUI login screen and Putty on my end shows this:

 

waiting for X server to shut down FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.

 

 

xinit: unexpected signal 2.

Couldnt get a file descriptor referring to the console

 

Basically, does anybody know how to forward the x server/GNOME to your desktop via Putty over SSH?

Edited by Chrono86
Link to post
Share on other sites

You can leave the xserver running.

 

Start a session on display:1 instead of display:0

 

Linux is a multi user system and x was designed with that exact scenario in mind.

 

Just like when I vnc into my machine I don't go into the current desktop, but instead it takes me to a login screen and when I login it takes me to a new session.

Link to post
Share on other sites

Thank you Bruce, you are correct

 

Won't work regardless though, as I had forgotten my Windows box here at work is on our internal network, and the CentOS box is on our DMZ, and our DMZ is set up not to be able to see our internal network, so the display is being forwarded nowhere :mrsgreen:

Edited by Chrono86
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...