Jump to content

Hard Disk Link Not Consistant. Any Ideas?


megaspaz
 Share

Recommended Posts

this is no big deal really since the link goes to the right directory when i click it. the wierd behavior in question pertains to my mounted windows C drive. when i right-click the desktop link and choose Properties and then go to the device tab, the value in the device text box is /dev/hda11. if i view the link in like kwrite, the device line is correct at /dev/hda1. it's wierd cause i was wondering how that was working (before i viewed the link in kwrite) since /dev/hda11 is my swap partition. anyway i've tried changing the device to the right device in the properties window, but it always reverts to the wrong device label (even though in kwrite, the device label is correct). any ideas? like i said, it's working and the device label is correct when viewed in kwrite, but i'm still curious. :rolleyes:

Edited by megaspaz
Link to comment
Share on other sites

yeah, i agree it's no biggie, but i'm still curious. :rolleyes::)

 

screenshot:

 

Posted Image

 

properties in kwrite:

 

[Desktop Entry]

Dev=/dev/hda1

Encoding=UTF-8

FSType=Default

Icon=/usr/share/icons/slick/32x32/devices/hdd_mount.png

MountPoint=swap

ReadOnly=false

Type=FSDevice

UnmountIcon=/usr/share/icons/slick/32x32/devices/hdd_unmount.png

 

edit:

 

hmmm....just noticed in the properities viewed in kwrite that the mountpoint is swap (ie. like /dev/hda11). changed that to "" as that's what it is for the other hard drive icons. but it changes back to swap if i change the device text box in the right click icon > Properties. eriee.... i've already tried to create a new hard disk link too, but with the same result.... :blink:

Edited by megaspaz
Link to comment
Share on other sites

okay, i changed the mountpoint in kwrite to:

MountPoint=/winC/vfat1

 

and that solves the problem of that getting changed to swap. but right clicking on the icon and choosing properties still shows /dev/hda11 instead of the correct device /dev/hda1 (which is what shows when you open the link in kwrite). but it changing it and clicking ok doesn't change the mount point, which is good. i'm still plenty confused though as my other hard disk links show the mountpoint as blank in kwrite, but show the correct device with right click > Properties > Device tab. :blink:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...