Jump to content

Change Mode

LOGITECH MX310 MOUSE: is it me. . ?

Recommended Posts

Feel like a right banana coming on here because I'm thinking there's something I'm doing to screw everything up, but here goes anyway:


My Dell mouse gave up when some internal spindle or other broke and the mouseball was no longer cradled properly. Friends said, forget old-fashioned mice, what you need is an optical mouse. So I've bought a brand new Logitech MX310 Optical Mouse.


It's a USB/PS/2 device, NOT a wireless mouse, plugs into the PS/2 slot at the back of the Dell. So I plugged it in, turned on the Dell, and it worked straight off the bat. I then installed something called Mouseware software, it came with the mouse. This allows you to customise the mouse. I looked at the default settings and the main left control allows you to click on something but, but, but. . . the main right button has NO option at all for the Windows right-click function I'm so used to. Instead it brings up context sensitive details of whatever you're highlighting.


Well, yippee, but that's not what I want. Right-clicking my old mouse always and unfailingly brought up a standard menu allowing you to open something, undo, cut, copy, paste, delete etc.


But not the Logitech MX310. Gawd, why???????


Anyway. I've uninstalled the mouseware software thing, shut down the PC, then booted up again.


Guess what. There's still no right click function on the Logitech MX310.


Question: is this something I can resolve myself?? Or is this mouse faulty -- I can't believe Logitech would produce a mouse lacking the functionality you'd find in something costing a quid from Poundland. . .

Link to post
Share on other sites

Thanks bp but that was the first thing I did.


The downloadable software comes with an optional extra: a link to eBay. God knows why: does eBay own Logitech now??


Anyway. The software not only did nothing for the right button functionality. It doesn't even offer open / copy / paste / delete functionality anyway.


I'm baffled. Until now I figured a mouse was a mouse was a mouse and that every mouse could perform elementary Windows functions.

Link to post
Share on other sites

Don't have the MX310 but do have a Logitech optical on my second computer with Mouseware installed and the right click works just the way its supposed to. These are the settings that I have,


Posted Image


Also just in case, the version of Mouseware that I have is 9.79.025


P.S. as for the ebay thing, just uncheck it during install. Also the Logitech drivers/software aren't really required as the default Windows drivers work just fine, only reason for the Logitech stuff is for the extra functions that the mouse has.


Almost forgot, :wp:

Edited by stormy13
Link to post
Share on other sites

Hi Stormy: many thanks for that -- I'm going to have another go now. And yes, you're right! That's the screen I get when using the Mouseware, but though the illustration shows what the righthand mouse button can do (Context Menu / Alternate Select) when I come to click the button, nothing comes up at all -- or rather, drops down, which is why I was wondering if I'm doing something wrong.


I'm currently working on a big job using Word documents, so when I right-click on any part of the text with my ultra cheap ($2!) back-up non-optical mouse, a menu drops down with stuff like Cut Copy Paste Font Paragraph Bullets Numbering Hyperlink. . . but when I right click on the same text in the same document using the Logitech optical mouse, nothing at all appears. . .


Anyway. Am off to try again!


(Sorry to be a nuisance here!)

Link to post
Share on other sites

The way you're describing what is happening, it sounds like you managed to get a defective mouse (it happens).


Not too sure from reading your original post whether the right click worked on the new mouse before you installed Mouseware.

Link to post
Share on other sites
  • 2 weeks later...

Hi Stormy -- just a final word / belated update!


Yup, the mouse was defective, as you rightly guessed: the right button function continued to, er, non-function.


I've returned it to the supplier and am now awaiting delivery of its replacement. Hopefully, better luck this time!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...