Jump to content

Change Mode

Optimize cannot connect to internet


Recommended Posts



It sounds like you have done all the right things.


Are you also running Zone Alarm, Windows Defender, Peer Guardian, etc?


If you will post a TEch Express link we may be able to spot something. If you haven't done that before, this should help: http://forums.pcpitstop.com/html/helpfiles/techexphelp.htm


Just to make sure, have you troied withthe AVG fierwall swirchewd completely off? Of with just the Windows firewall active:


You'll need to set your firewall to allow www.pcpitstop.com. The corresponding IP is


Go to Start>Control Panel>Windows Firewall>General and make sure that the "Don't allow exceptions" box is NOT checked.


Also, please check for the setting below, and if it exists, that it is set to 'OK'.


Start/ControlPanel/SecurityCenter/WindowsFirewall/Advanced(TAB)/NetworkConnectionSettings/SelectSettings(RadioButton)/ICMP(TAB)/Check Allow Incoming ECHO/ OK

Link to post
Share on other sites

Thanks IntelGuy for your reply. In answer to your questions about Zone Alarm etc....NO....nothing like that on my system. I have followed every bit of advice offered from PC Pitstop and still nothing. I have now emailed AVG to see if they can offer some advice. But thanks again IntelGuy.......we will get there in the end I am SURE!

Link to post
Share on other sites

having the same problem. When I check for latest revision it says "cannot connect to server, please try again later" I would like to check for an update as it has been three months.

Link to post
Share on other sites

The only issues we have seen with the "Check for latest version" button have all been on computers with Norton Internet Security installed. The button check is handled differently than the download and ping tests, which work properly on these computers.


Configuration of the Norton product is best done through Symantec support, as there are many different versions and settings to consider:



or: http://www.symantec.com/home_homeoffice/support/index.jsp


However, depending on the NIS version, you can go into options and see if anything is obvious, For NIS 2007 you have to find the Options dialog, then find the firewall, and then select "Ask me what to do" so when an application wants to access the Internet, NIS will prompt for a decision. If the option is set to let NIS decide, chances are it will decide to block the update button.


The work-around is to check for and update from our Customer Service page:


Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...