Jump to content
Sign in to follow this  
bpelowski

BIOS Update

Recommended Posts

I just installed a new HD and only 127 of 160 GB are available. I was reading about this issue on the Seagate site ( http://www.seagate.com/support/kb/disc/cap.../137/index.html ) and it seems my best option is to update the BIOS.

 

Does Intel only make one set of BIOS? I couldn't find anything specific to my board: Intel® Desktop Board D845EBT

 

I found this page with some info: http://www.intel.com/design/motherbd/standardbios.htm

 

Is this the info I need to updgrade my BIOS?

Share this post


Link to post
Share on other sites

Only upgrade your bios if it fact solves the problem your having with the drive. My question is are you looking in the bios to see if it recognizes the full drive size or are looking in windows. XP that doesn't have SP2 installed has 137gb limit I believe.

Bios updates gone wrong can leave you with a very expensive paperweight/doorstop.

Share this post


Link to post
Share on other sites

Only upgrade your bios if it fact solves the problem your having with the drive. My question is are you looking in the bios to see if it recognizes the full drive size or are looking in windows. XP that doesn't have SP2 installed has 137gb limit I believe.

Bios updates gone wrong can leave you with a very expensive paperweight/doorstop.

 

OK, well I am using SP2. I could also do this: http://www.seagate.com/support/kb/disc/cap...7/bios.html#ddo

Share this post


Link to post
Share on other sites

Updating the bios is as easy as the makers make it for you, some boards are very easy and I've done a few boards like this now, BUT there are ones out there that are not so easy to do and those I have not tried to do, the thing to remember is that if you get it wrong you could kill the motherboard, I would suggest giving Maxtor's Big Drive Enabler, it edits the registry without risk to enable large drive support, I don't see why it shouldn't work on your drive as it works on the OS not the drive, and not to mention they now own Maxtor, hope this helps.

 

>>>Big Drive Enabler<<<

Share this post


Link to post
Share on other sites

I ran this and got a message saying "Support is currently enabled for 48-bit logical block adressing (LBA) for ATAPI drives. You do not need to run this registry update."

 

Weird. It still shows the drive capacity as 127 when I right click on the drive. Anyone else have any ideas? Thx.

Edited by bpelowski

Share this post


Link to post
Share on other sites

TBH if I reach such a point personally I stumble around as it would be a first for me, maybe try data lifeguard etc to check everything is OK possibly try a reinstall using the lifeguard to prepare the drive (formatting etc) for the new install, if I still got nowhere then maybe it is time to look at the bios option given they have identified a possible problem there.

 

>>>Here<<< is the page for your downloads if I'm right including the bios, the page you showed above certainly appears to be their guide for doing it, but it's essential you remember you can kill your board if it goes wrong so if you have any doubts then best to steer clear I'd suggest, it's one of those things that if all goes well then you wonder why you worried, but if it goes wrong then the fun and expense starts, the safest option IMHO if this can't be sorted and you don't want to risk the bios option is to partition the drive to say 2 x 80gig partitions, this way you will have the full 160gig available without any risk, hope you get a result anyway.

Share this post


Link to post
Share on other sites

I continue to have problems with this new drive. I reformatted the drive as what I read on the Seagate site made it sound like if I did this the system would now see the drive at it's full size.

 

Instead of that happening, I still see the F: drive there but when I double click on it Windows says it isn't formatted. I did a windows format and when it got to the end it said Windows can not format this drive. I also get this error instead of the message to format the drive every once in a while if I double click on the F drive: F:\ is not accessible. The parameter is incorrect.

 

I looked in device manager and the drive is there and it shows no errors. I've tried reformating again with the Seagate util, it goes through the whole process and then says everything should be working but that is not the case.

 

Any ideas? I hate this.

Share this post


Link to post
Share on other sites

I only have the experience to stumble around when it gets to this point, that and a refusal to be beaten by it lol, have you tried partitioning the drive ?

Hopefully someone may be able to help more than I can.

Share this post


Link to post
Share on other sites

There is a very good reason why you can not find a bios update for your board. The reason for that is here,

 

http://support.intel.com/support/motherboa...esktop/d845ebt/

 

Intel has a bad habit of dropping support for older products faster than a hot potato when they decide that it has reached its EOL.

 

Anyway that is enough slagging of Intel. Poking around Intel's site via Google the best I can find is that is the max size hd your motherboard supports. You can get an explanation of the various bios settings from here,

 

http://support.intel.com/support/motherboa...b/cs-020304.htm

 

on page 8 of the pdf the only mention of hard drive size is under LBA, and it says the max is 128 gb. As for a bios update I did manage to find that as well (with a release date of 8/13/2002),

 

http://downloadfinder.intel.com/scripts-df...ms&lang=eng

 

only thing is that according to the Readme file, there is no added support for hd's over 128 gb.

Share this post


Link to post
Share on other sites

There is a very good reason why you can not find a bios update for your board. The reason for that is here,

 

http://support.intel.com/support/motherboa...esktop/d845ebt/

 

Intel has a bad habit of dropping support for older products faster than a hot potato when they decide that it has reached its EOL.

 

Anyway that is enough slagging of Intel. Poking around Intel's site via Google the best I can find is that is the max size hd your motherboard supports. You can get an explanation of the various bios settings from here,

 

http://support.intel.com/support/motherboa...b/cs-020304.htm

 

on page 8 of the pdf the only mention of hard drive size is under LBA, and it says the max is 128 gb. As for a bios update I did manage to find that as well (with a release date of 8/13/2002),

 

http://downloadfinder.intel.com/scripts-df...ms&lang=eng

 

only thing is that according to the Readme file, there is no added support for hd's over 128 gb.

 

Thanks for the info. I guess I'll have to make a second partition.

Share this post


Link to post
Share on other sites

Question, I've partitioned my drive and the software I used automatically made the bigger sector NTFS and the smaller sector FAT32. Why wouldn't it just create both as NTFS? Is there any advantage to me converting the smaller partition to NTFS?

Share this post


Link to post
Share on other sites

The program you used probaly defaulted to formatting any partition over 32 gb as NTFS and under as FAT32. One of those things that you have to specify in the options/settings before proceeding. Good news is that if after your partitoning and Windows sees all partitions, it is an easy matter of changing the smaller drive over to NTFS if you want to.

 

If you do just right click on My Computer and select Manage. In the new window click on Disk Management and from there click on the partition, right click Delete, then format and select NTFS as the file system.

Share this post


Link to post
Share on other sites

The program you used probaly defaulted to formatting any partition over 32 gb as NTFS and under as FAT32. One of those things that you have to specify in the options/settings before proceeding. Good news is that if after your partitoning and Windows sees all partitions, it is an easy matter of changing the smaller drive over to NTFS if you want to.

 

If you do just right click on My Computer and select Manage. In the new window click on Disk Management and from there click on the partition, right click Delete, then format and select NTFS as the file system.

 

Thanks, good info. Any reason to change though? If I plan on just storing photos on this partition is NTFS any better than FAT32?

Share this post


Link to post
Share on other sites

from Mouse:

XP that doesn't have SP2 installed has 137gb limit I believe.

Correction: BIOS is the one who limits the size of hard drives, not SP2. Win98 even supports upto 2TB though...

 

Thanks, good info. Any reason to change though? If I plan on just storing photos on this partition is NTFS any better than FAT32?

The NTFS file system has security options and it is quite faster than the FAT32 File system :) Edited by ineedhelpregularly21

Share this post


Link to post
Share on other sites

from Mouse: Correction: BIOS is the one who limits the size of hard drives, not SP2. Win98 even supports upto 2TB though...

Correction,

 

This article describes the Microsoft Windows XP Service Pack 1 (SP1) 48-bit Logical Block Addressing (LBA) support for ATA Packet Interface (ATAPI) disk drives that can increase the capacity of your hard disk to more than the current 137 gigabyte (GB) limit.

 

Note Windows XP does not support 48-bit LBA support unless you are running Windows XP SP1. If you want to use 48-bit LBA support, you must apply Windows XP SP1 or later.

http://support.microsoft.com/kb/303013/

 

and an iteresting read on Windows 98, http://www.seagate.com/support/kb/disc/faq/137_win98.html

 

The NTFS file system has security options and it is quite faster than the FAT32 File system :)

 

For what he plans on using the drive for it is debatable whether any speed difference between the two formats would even be noticeable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...