Jump to content

Change Mode

car audio help


gordesky1

Recommended Posts

we found a 1000watt bridgeable pyramid pb 780 amp and it works.

 

but when we turn it up like half way the sound gets alittle bad im not sure if my 100watt car cd deck is powerfull for it?

 

like if i have it at 20% its sound good but when i want it louder it gets mess up.

 

and another thing i thought this whould shake the ground and stuff with alot of bass but it doesint.

 

and my speakers well woffers or sub woffers lol is 650watt theres 2 of them in the box pretty sure they 10inch or 8.

 

im planing on puting this in my firebird that has a 200watt cd player will that fix the problem?

 

right now its in my truck just for testing.

 

i just want it too have alot of bass and shake something lol.

Link to post
Share on other sites

If you want a lot of noise, use two amps. One 4 way that looks after the cabin speakers, and a 2 way (connected to the 4 way) that controls the sub(s).

 

You'll draw a lot of juice doing this, but it will make the noise you're looking for.

 

You say you found the amp. Roughly how old is it? If it's second hand, it might be shot.

Link to post
Share on other sites

because there is no standard (& no laws) dictating power output measurements, anyone can say they have 1000w amp but only put out 100 usable watts. pyramid as a company is junk...their products are junk. that's why you 'found' it dude. :)

 

 

 

go get a real amp before that thing blows your stereo and speakers up.

Link to post
Share on other sites

well i got it in the firebird now and its pretty loud how i want it.

 

i just got my 2 subs hook up too it one is a 300watt round sub and the other one is a 600watt 2 way tweeters and subs with light around them:)

 

and its pounding now:)

 

i guess it was the cd deck in my truck 100watts wasint powerfull anuff for the amp.

 

but i ony put it in my truck for testing and seeing if it whould work.

 

when i was playing it for about 10min the fuse in the firebird in the fuse box blew out lol was ony a 10amp in it so i put a 20amp in and its been runing good now:)

 

by the way heres the amp http://www.shopping.com/xPF-Pyramid_PB780 the one we found is red.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...