Jump to content

Incorrect Registry Value in Optimize

Recommended Posts



One of my customers came to me today to ask about your program, PC Pitstop Optimize.


I downloaded the "Optimize Scan" and ran it on my pc.


I noticed something right away that you may want to address for the future.


PC Pitstop Optimize is using an incorrect registry value for the "Auto MTU Discovery"


The value PC Pitstop Optimize is using is: EnablePMTUBHDiscovery


The correct value is: EnablePMTUDiscovery


You can verify this from Microsoft at the following link:




I hope this helps and you guys can correct this.


While the link above shows the value and is recommending disabling "Auto MTU Discovery" for an MTU less than 576, this should be ignored.


It is the name of the value in the registry that is important.


Here is another more descriptive link:



Edited by tweaked2themax
Link to post
Share on other sites

Under Win98SE Optimize recommends setting:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP\SackOpts = 1 or enabled

but that leaves TCP vulnerable to a fault condition that exists with non-compliant services that result in packet sizes as small as 8 bytes making throughput painfully slow even though available bandwidth is free for use. See MS KB article that describes the problem and recomends disabling SackOpts under win98/SE.




I've experienced the effect after following other MSTCP tweakers advice and enabling SackOpts and certain connections in peer to peer swarm were so badly affected I was getting less than 2Kbytes per second total, while ping rates and normal web connectivity was mostly fine.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...