Jump to content

terry1966

Anti-Spyware Brigade
  • Content Count

    9,289
  • Joined

  • Last visited

Everything posted by terry1966

  1. that's normal and has to do with the way a hard drive needs a certain amount of space to organise itself before any data is stored on it. think of it like this, you have a filing cabinet draw that can be filled with loads of files, only problem is you can never find what you want when you need it because it's not organised, so to organise it you put in a lot of dividers, now you can find files easily but have lost a certain amount of storage space taken up by the dividers. well that is more or less what happens with any hard drive, so you can think of the missing 0.2TB out of your 2TB as the dividers.
  2. personally i don't see why you'd need to clean install or delete either leap or windows, like i said in an earlier post i'd simply dual boot, then you can use windows to your hearts content, and when you felt like it, try and get the updates done on the already installed leap42 os. when/if you ever did finally manage to update the linux os you could then work on installing the driver and getting everything working again, we know it's possible because you've already done it once and had everything working great. trying to think if there's an easy way where you can download the updates first or resume from where you left off on next try to make things worth persevering with, but not ever having had to do it myself am at a bit of a loss. i guess you could use something like wget to copy and resume the download of the repo's into separate folders in your home directory first, then once you have the repo's on your hard drive doing the updates should be fast and easy, requiring a simple temporary change in the repo list so they point to each folder and not the internet url's. once updated reverting those repo changes and delete the folders. but it's not something i've ever tried or tested myself and i'm not sure how long it would take you to finish the downloads in the first place, even though it would allow you to resume what you downloaded there would be so much more data needing downloading than you actually need in the first place, you might never complete it. there must be a better easier way of resuming the updates but can't think of it, maybe someone else has an answer. i don't even know if trying to get the updates at the same time as you do an install will work out easier and better for you seeing how i never install that way. personally i'd chat up your landlord or someone at work and see if they'll let you pop round and connect by wire to their network and get the updates completed that way or find an internet cafe where they will let you connect by wire there just to update. not being much help here am i? cable is just fine, but you need to connect to their network by wire and not wifi then you'd have no problems getting the updates done, once the updates are done and the driver installed and working then you can connect by wifi to any network without any further issues.
  3. well you know for a fact my grasp of the english language and correct grammar isn't great (to say the least. ) but to me this is a conditional sentence, "When you turn on a brand new computer, connected to a brand new internet connection, the amount of time from the first attempt at hacking that computer is four minutes," with "connected to a brand new internet connection" being the condition, so to me what you've done here without the condition "When you turn on a brand new computer,..., the amount of time from the first attempt at hacking that computer is four minutes," Farmer said. is to take something completely out of context thereby changing the complete meaning of the sentence as originally meant and spoken. we all know just turning on a new pc won't mean anyone/thing is likely to attempt hacking it within 4 minutes just by the fact it's turned on, but when you add the condition of connecting it to the internet then that makes a hacking attempt within 4 minutes much more likely and logical. (well at least to me.) now not being an english grammar expert i have no idea which interpretation is correct yours or mine. but logically i'd go with my interpretation, so therefore i refute your claim the sentence was made to be dramatic and is in fact just a plain statement of truth without any embellishments or scaremongering, and i don't care if you no longer care about the point. which was the point (in my mind anyway.) that a brand new pc (so malware free.) connected to a brand new unused, pristine clean ip address (therefore not known to have a pc located there.) will still be tested by hackers (their bots really.) within 4 minutes of being connected to the internet.
  4. still think you missed what he was saying tomk (as i understood it anyway. ) edit --------------- should add, i never watched the video (needs JavaScript enabled,) and am going by this quote only. "When you turn on a brand new computer, connected to a brand new internet connection, the amount of time from the first attempt at hacking that computer is four minutes," Farmer said. --------------------- you just bought a brand new pc, had the internet connection installed, so first thing you do is connect your all in one modem/wifi/switch device to the internet connection, connect your pc to the modem, and within 4 minutes of you connecting that all in one modem (with it's built in firewall.) to the internet connection and it establishing it's connection to the isp it will have received at least 1 attempt to gain access to the new network and pc. so no i don't think the statement was made to be dramatic, it's just the plain and simple truth as i understand it anyway. i agree it doesn't matter if the pc is new or old or if it's even connected to the modem yet but that's not the point i think he was trying to make. i just had a thought on how to test the 4 minute quote easily too, if you have an all in one device like they issue over here in the uk and you get a new ip address every time you restart it, so after a restart the modem connects to the isp and is given a new ip then look in the logs and see if within the 4 minutes on the new ip you got an inbound attack then that would prove the 4 minute quote. to my mind anyway.
  5. ...paranoia runs deep... not paranoia when it's true though. hackers can even get data off an infected pc when it has no connection to any network whatsoever (air gapped.). :- https://www.wired.com/2015/07/researchers-hack-air-gapped-computer-simple-cell-phone/ Again, I'm not buying it, even if he is a professional expert. When I turn on a brand new computer, I connect it to my existing router. Hackers cannot tell that I've turned on a new computer. The "four minutes" fact sounds made up to me. think you missed the point, he said connected to brand new internet connection. which to me means it takes the bots out there 4 minutes to test your brand new ip address just issued to you from your isp for the very first time to see if they can gain access to whatever's behind it. just look in your routers logs for proof, in mine there's very few minutes where an inbound connection attempt wasn't rejected, and most minutes have at least 2 or 3 such attempts and rejections, even though my router is stealthed and doesn't respond to any inbound communications. so i definitely believe the 4 minute time, surprised it takes that long to be honest with how fast pc's are today. a site some might find of interest with some tests you can run to test different things like if you have any open ports or if your router is stealthed or not :- https://www.grc.com/x/ne.dll?bh0bkyd2
  6. there is no more "popular" os out there than linux. it runs nearly everything including i bet the server your seeing this forum on. so i'm not really a believer in the more popular argument. like we all know though the biggest problem with any os is not the os itself (especially now windows follows a more secure way of operating by default.) but the idiot using it.
  7. take care, both of you. (the rose is for karen not you. )
  8. has he ever had a virus? have you? he may not be "virus proof" but i bet he's more chance winning the lottery than getting infected. know any linux users who have been infected? bet you have though. truth is no os is impervious to being hacked or infected with malware, but at the moment it's not anything a mac or linux user really needs to lose sleep over, number one reason i see why people say install an anti-virus software on a mac or linux system is "if you share files with a windows pc" take this topic for example they say they have found code aimed at linux and mac in a windows malware making it cross platform, but how are they going to get the linux or mac user to install and run it with the permissions it needs to do any damage in the first place? and because that is not so easy to do in the first place it makes things much harder to infect those os. i bet i'll never ever see or run whatever malware app this code is from on my linux machine, and it wouldn't surprise me to learn my linux machine is one of the most vulnerable to infection out there just because of it's user.
  9. ok. should add, there's nothing wrong with your laptop or your wifi and it's just a driver problem. of course it would be a lot easier to fix things if you could connect by wire to a router, it's just relying on the flaky wifi driver to fix the flaky wifi driver that's the problem. by the way just keep hitting r when you get that option (a,r,i) anything else just cancels the update process and it needs to start from scratch next time you try. a lot of the time even when connected by wire on my pc i get that happen and if it doesn't work after 1 or 2 retries then it's usually a repo problem, once or twice i've had to change to a different repo mirror to get it to update, either that or forgo the updates until a later time when any issues are usually resolved.
  10. first install leap with patterns :- base development, kde development and linux kernel development, it will add other patterns too. next update leap with zypper up next add any repo's like packman and libdvdcss update again with zypper dup. go into yast and set it to use network manager. (seeing how you've just done a clean install, just make sure those patterns and repo's are installed, and everything is upto date.) then follow instructions in previous post to clone the git repo and install the driver. create and add the rtl8723be.conf file with whatever options you found worked to /etc/modprobe.d/ folder. reboot and test. if no joy then we'll need to try and figure out why if you want or you can stick to using windows, your choice. one thing you can do though is create a text file and copy everything you do into it so while following the instructions to install and test the driver, copy each and every command and it's output into it as you go along, that way we can see what if any errors occurred which should help figure out why it's not working now when it did before.
  11. sorry been so long in getting back to you kurt, but after spending hrs trying different ways to resize a root partition and being able to log back in again after, i think you'll be better off just doing a clean install but with a bigger root partition to start with. anyway to cut a very very long story short, it is possible but it's also very convoluted. i finally succeeded by first logging in as root in run level 3, umount /home, resize it to minimum or size you want to add to root, create a new partition in empty space, dd /home across to new partition, mount new partition as home, delete old home. then reboot to a live cd so i could finally resize the root partition to use the free space left from when i deleted the old home partition. that was the only way i found i could resize things and still be able to boot into the desktop again after, don't know what the problem was doing things any other way but first i thought it might be a uuid issue in fstab but mounting partitions by label never fixed it, so i assume it must have been a permission issue copying the user folder back caused (even though i did try and set the folders permissions back to username and user group) any whatever the issues were i think using dd fixed that problem. upto you but if you want to try it anyway instead of doing a clean install i'll give detailed instructions on how i did it, but i can't guarantee they'll work for you even though i don't see why not. thinking about it, i don't think i tried dd when i just used a live cd to do everything, so might give that a try in a bit which if it works should make things a bit easier than the way i finally did it.
  12. can you make a live usb/cd/dvd? i think it might be easier for you if you can. if yes, but you need a live iso, then you can download the suse 13.2 kde 64bit live iso from here :- http://download.opensuse.org/distribution/13.2/iso/ just find it and click on it and save file. or click on this direct link :- http://download.opensuse.org/distribution/13.2/iso/openSUSE-13.2-KDE-Live-x86_64.iso i use imagewriter in suse to then put the iso onto a usb so it's bootable, but there are other programs/ways to do it. what disks app? in what os? and congrats and good luck in your new job.
  13. don't m$ only release security updates 1ce a month unless the last update broke something then they try and release a fix as soon as possible? http://pcsupport.about.com/od/termsp/g/patch-tuesday.htm so no need to start worrying.
  14. sorry been a bit lazy today so haven't got around to it yet, just started installing a windows os on a pc so i can dual boot it with leap to give you a step by step guide. the guide will be a choice of 2 options, first choice and probably easiest will be using a live usb/cd/dvd, 2nd choice will be more complicated and will mean booting into level 3 and logging in as root because it's not possible to unmount /home when logged in as your user i believe, will know more when i start testing after getting everything setup.
  15. OK. first though open yast, partitioner, click on hard disks on left and take a picture or screenshot of what it shows and post it in next reply.
  16. what i would try and do is, copy the contents of the /home folder (make sure it's the root home folder contents you copy across, in /home will be a folder for every user on the system and it's those user folders you need to copy.) to windows partition. unmount and delete the home partition (assume / and home partitions are next to each other.) leaving free space, now you should be able to resize/expand the / partition into the free space, say 30 GB minimum, then create a new partition in the space left and mount it as home again, copy folders back from windows into home partition and that's it. my root partitions are 40GB in size if your wondering.
  17. no idea on what the errors are or if they are anything to worry about. as to the root partition (what size is it anyway?), personally i wouldn't delete anything (way to easy to break something if you start deleting things.) and would look into expanding it if possible.
  18. wow you have a lot of wifi hot spots near you, think there's only 5 near me. and yes that looks perfect so assume everything is as good now in linux as it is in windows, regarding wifi. which os? so things are working good now and you don't feel the need to look into anything else?
  19. ok. if possible make sure everything is up to date with leap and also add the packman repository. how close to the wifi access point are you, don't forget the further away it is the weaker the signal is going to be anyway. i'm in the same room as my router and why i got a 70/70 signal when i tested. must admit though going by those results, it does seem to me like you don't have the new driver installed correctly yet. also is everything else working ok now? main concern is that you can boot into windows any time you like without problems and can also boot into leap when you feel like trying to sort through it's issues, so you don't feel the need to keep re-install things and starting from scratch any more.
  20. the reason you can't access the windows partition when in linux i believe is because when you left the windows os it shuts down in such a way that makes booting windows again fast, (called fast startup.) it's a sort of hibernate and not a full shutdown of the os and locks the partition. so the answer to that is to not use fast startup. http://www.howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/ ok when that's done you shouldn't have any more problems booting either windows or leap, plus you should now be able to access the windows partition when in leap. now onto the wifi driver. did it make and install ok, did you add the options file? lets see what results you get for each ant_sel option, so you run these commands. sudo modprobe -v rtl8723be ant_sel=0 sudo iwlist wlan0 scan | egrep "SSID|level" we want something like this :- "Quality=70/70 Signal level=-28 dBm" where it shows the quality=70/70 for your ssid, then we know it works and your using the correct option for best wifi reception. sudo modprobe -v rtl8723be ant_sel=1 sudo iwlist wlan0 scan | egrep "SSID|level" sudo modprobe -v rtl8723be ant_sel=2 sudo iwlist wlan0 scan | egrep "SSID|level" regardless of wifi strength first thing i'd do is a zypper -v up, to make sure default install is fully upto date with latest kernel, after that you will probably need to make the wifi driver again and test if it installed a new kernel. sounds like a graphics driver problem, easy option for now is to turn off screen saver and any screen power saving options, then we'll work on that later.
  21. that doesn't really tell us what issues you had that made you think you needed to reinstall both leap and windows. i think you need to slow down and not get to click happy. in my opinion there was no reason to re-install either leap or windows. no idea why leap only offered you the chance to only install to windows partition but during leap install have you ever used the expert partitioning? in there you could see what partitions are on the drive and then just re-install leap to the partitions it's already used. errors during make usually just mean missing dependencies, when i install suse i always add the patterns for linux kernel development kde development base development c/c++ development then i usually find i have no problems when it comes to making my drivers. don't be in such a rush and take notes, stop when unsure, post what you've done so far then carry on when you have an answer. never used a laptop with uefi and windows 10 on it, so no experience with what problems windows 10 may cause when dual booting but i'm sure we can work any issues out just as long as you can be a bit more patient and post the problems before trying to fix them and starting from scratch all the time.
  22. why what's the specific problem? are you having any problems with dual booting besides the wifi in suse? like are you having problems logging into either os on start up, if so explain them and i'm sure there's a simple solution just finding it sometimes can be a hassle. there really shouldn't be a need to keep re-installing suse for example. personally as long as you can boot into both operating systems then i'd leave suse on there and just work on any linux issues when you feel like it, and when you don't just log into the windows os and use that. as i said before though it's up to you but if you decide to try again sometime then we'll be here to try and help. just for info any pc that came with windows i would always leave windows os and recovery partitions on there and just set up a dual boot system that way when it came time to sell or give the pc away i wouldn't need to spend hours restoring it to factory condition.
  23. to be honest from my understanding the ant_sel option makes no difference without first installing the newer driver. instructions are open a terminal and enter each of these commands git clone https://github.com/lwfinger/rtlwifi_new you'll now see a new folder in your home directory called rtlwifi_new. cd rtlwifi_new git checkout rock.new_btcoex make sudo make install sudo modprobe -rv rtl8723be sudo modprobe -v rtl8723be ips=0 ant_sel=0 see what it works like now. if it now works fine then i think all you need in the config file is options rtl8723be ips=0 ant_sel=0 if still have problems then try the ant_sel=1 or 2 and test each time. you will need to follow instructions from the cd rtlwifi_new command every time your kernel is updated and breaks things so your wifi has a weak signal and the driver needs to be installed again to get a strong signal. (until of course the new kernel includes the latest driver. which is kernel 4.7 i believe.)
  24. what have you done so far to try and fix weak signal, slow connection? did you try making the driver and did you add the file to modprobe.d? i take it everything else works fine and it's only wifi your having problems with.
  25. ok. just for info, with a uefi dual boot, there are 2 ways to make sure it shows the grub menu on boot, first and best way in my opinion is what you've done and set it in the uefi and 2nd way is when in windows use bcdedit command. with secure boot enabled :- bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi with secure boot disabled :- bcdedit /set {bootmgr} path \EFI\opensuse\grbx64.efi more info here :- https://tweakhound.com/2015/11/04/dual-boot-opensuse-leap-and-windows-10-uefi/ as to the weak wifi signal, try adding a file named "rtl8723be.conf" (without quotes.) with this line in it. options rtl8723be ips=N fwlps=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1 in the /etc/modprobe.d/ folder. no idea what all the options are for without more research, but worth a try to see if it helps you anyway, and if it doesn't you can always delete the file.
×
×
  • Create New...